summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2011-11-13 21:44:04 +0000
committerChristian Birchinger <joker@gentoo.org>2011-11-13 21:44:04 +0000
commit2b0658ed7b26827747d62c93d2587078050d8d5d (patch)
tree27ca3d56f2a7fc13fa9e97fdc8b64ae7ef577eb0 /net-misc
parentVersion bump. Make it work with gupnp-0.18. Clean up old revision. (diff)
downloadgentoo-2-2b0658ed7b26827747d62c93d2587078050d8d5d.tar.gz
gentoo-2-2b0658ed7b26827747d62c93d2587078050d8d5d.tar.bz2
gentoo-2-2b0658ed7b26827747d62c93d2587078050d8d5d.zip
Initial import. Based on the ebuild by thegryghost@gmail.com
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/r8168/ChangeLog10
-rw-r--r--net-misc/r8168/metadata.xml14
-rw-r--r--net-misc/r8168/r8168-8.026.00.ebuild31
3 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/r8168/ChangeLog b/net-misc/r8168/ChangeLog
new file mode 100644
index 000000000000..4d783aae5ec6
--- /dev/null
+++ b/net-misc/r8168/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/r8168
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/ChangeLog,v 1.1 2011/11/13 21:44:04 joker Exp $
+
+*r8168-8.026.00 (13 Nov 2011)
+
+ 13 Nov 2011; Christian Birchinger <joker@gentoo.org> +r8168-8.026.00.ebuild,
+ +metadata.xml:
+ Initial import. Based on the ebuild by thegryghost@gmail.com
+
diff --git a/net-misc/r8168/metadata.xml b/net-misc/r8168/metadata.xml
new file mode 100644
index 000000000000..262d72961ef5
--- /dev/null
+++ b/net-misc/r8168/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>joker@gentoo.org</email>
+<name>Christian Birchinger</name>
+</maintainer>
+<herd>no-herd</herd>
+<longdescription>
+Official Realtek r8168 linux driver. The following cards are currently supported:
+RTL8111B RTL8168B RTL8111 RTL8168 RTL8111C RTL8111CP RTL8111D(L) RTL8168C
+RTL8111DP RTL8111E RTL8168E RTL8111F RTL8411
+</longdescription>
+</pkgmetadata>
diff --git a/net-misc/r8168/r8168-8.026.00.ebuild b/net-misc/r8168/r8168-8.026.00.ebuild
new file mode 100644
index 000000000000..60cbf36c7d58
--- /dev/null
+++ b/net-misc/r8168/r8168-8.026.00.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/r8168-8.026.00.ebuild,v 1.1 2011/11/13 21:44:04 joker Exp $
+
+EAPI=4
+
+inherit linux-mod
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="http://www.realtek.com.tw"
+SRC_URI="http://r8168.googlecode.com/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+CONFIG_CHECK="!R8169"
+
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+}