summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-02-02 17:40:13 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-02-02 17:40:13 +0000
commit04364006cbe28ab1597fb4817e2db66f98363e4c (patch)
tree2dba25b1c05975fd502d050b358ed83e15855ec3 /net-misc
parentBig leechcraft bump to 0.4.99, thanks to 0xd34df00d (diff)
downloadgentoo-2-04364006cbe28ab1597fb4817e2db66f98363e4c.tar.gz
gentoo-2-04364006cbe28ab1597fb4817e2db66f98363e4c.tar.bz2
gentoo-2-04364006cbe28ab1597fb4817e2db66f98363e4c.zip
Big leechcraft bump to 0.4.99, thanks to 0xd34df00d
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/leechcraft-core/ChangeLog10
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-0.4.99.ebuild66
2 files changed, 74 insertions, 2 deletions
diff --git a/net-misc/leechcraft-core/ChangeLog b/net-misc/leechcraft-core/ChangeLog
index 223eb35acbaa..3698bdb16452 100644
--- a/net-misc/leechcraft-core/ChangeLog
+++ b/net-misc/leechcraft-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/leechcraft-core
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.5 2011/12/31 12:10:51 maksbotan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.6 2012/02/02 17:40:13 maksbotan Exp $
+
+*leechcraft-core-0.4.99 (02 Feb 2012)
+
+ 02 Feb 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-core-0.4.99.ebuild:
+ Bump net-misc/leechcraft-core to 0.4.99, thanks to 0xd34df00d
*leechcraft-core-0.4.97 (31 Dec 2011)
diff --git a/net-misc/leechcraft-core/leechcraft-core-0.4.99.ebuild b/net-misc/leechcraft-core/leechcraft-core-0.4.99.ebuild
new file mode 100644
index 000000000000..caaf6b8a05c9
--- /dev/null
+++ b/net-misc/leechcraft-core/leechcraft-core-0.4.99.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-0.4.99.ebuild,v 1.1 2012/02/02 17:40:13 maksbotan Exp $
+
+EAPI="4"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sqlite postgres"
+
+DEPEND=">=dev-libs/boost-1.39
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-script
+ x11-libs/qt-sql[postgres?,sqlite?]"
+RDEPEND="${DEPEND}
+ x11-libs/qt-svg"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ local mycmakeargs="-DENABLE_HTTP=OFF
+ -DENABLE_POSHUKU=OFF
+ -DENABLE_TORRENT=OFF
+ -DENABLE_AGGREGATOR=OFF
+ -DENABLE_NUFELLA=OFF
+ -DENABLE_DBUSMANAGER=OFF
+ -DENABLE_DEADLYRICS=OFF
+ -DENABLE_HISTORYHOLDER=OFF
+ -DENABLE_LMP=OFF
+ -DENABLE_NETWORKMONITOR=OFF
+ -DENABLE_SEEKTHRU=OFF
+ -DENABLE_CHATTER=OFF
+ -DENABLE_FTP=OFF
+ -DENABLE_EISKALTDCPP=OFF
+ -DENABLE_YASD=OFF
+ -DENABLE_ANHERO=OFF
+ -DENABLE_KINOTIFY=OFF
+ -DENABLE_VGRABBER=OFF
+ -DENABLE_NEWLIFE=OFF
+ -DENABLE_PYLC=OFF
+ -DENABLE_POC=OFF
+ -DENABLE_AUSCRIE=OFF
+ -DENABLE_SUMMARY=OFF
+ -DENABLE_TABPP=OFF
+ -DENABLE_SECMAN=OFF
+ -DENABLE_QROSP=OFF
+ -DENABLE_POPISHU=OFF
+ -DENABLE_GLANCE=OFF
+ -DENABLE_SHELLOPEN=OFF"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry leechcraft "LeechCraft" leechcraft.png
+}