summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-17 17:19:07 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-17 17:19:07 +0000
commite9a5c1bdc2e145d2c1dd3d8bbf4b6671819020dc (patch)
tree8e6ff8665d8899af6ebb071fae194055f13944a7 /net-misc/whois
parentadd ~x86, bug #234203 (diff)
downloadgentoo-2-e9a5c1bdc2e145d2c1dd3d8bbf4b6671819020dc.tar.gz
gentoo-2-e9a5c1bdc2e145d2c1dd3d8bbf4b6671819020dc.tar.bz2
gentoo-2-e9a5c1bdc2e145d2c1dd3d8bbf4b6671819020dc.zip
Version bump #234746 by Raúl Porcel.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/ChangeLog7
-rw-r--r--net-misc/whois/whois-4.7.27.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 475d328f3add..09751672b265 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.110 2008/07/05 17:43:20 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.111 2008/08/17 17:19:07 vapier Exp $
+
+*whois-4.7.27 (17 Aug 2008)
+
+ 17 Aug 2008; Mike Frysinger <vapier@gentoo.org> +whois-4.7.27.ebuild:
+ Version bump #234746 by Raúl Porcel.
05 Jul 2008; Santiago M. Mola <coldwind@gentoo.org> whois-4.7.26.ebuild:
amd64 stable
diff --git a/net-misc/whois/whois-4.7.27.ebuild b/net-misc/whois/whois-4.7.27.ebuild
new file mode 100644
index 000000000000..e89db1be7519
--- /dev/null
+++ b/net-misc/whois/whois-4.7.27.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.7.27.ebuild,v 1.1 2008/08/17 17:19:07 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+RESTRICT="test" #59327
+
+RDEPEND="net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.7.26-gentoo-security.patch
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ cd po
+ sed -i -e "s:/usr/bin/install:install:" Makefile
+ echo 'install-pos: install' >> Makefile
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
+ sed -i -e "s:cd po.*::" Makefile
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake OPTS="${CFLAGS}" HAVE_LIBIDN=1 || die
+}
+
+src_install() {
+ emake BASEDIR="${D}" prefix=/usr install || die
+ insinto /etc
+ doins whois.conf
+ dodoc README
+
+ if [[ ${USERLAND} != "GNU" ]]; then
+ mv "${D}"/usr/share/man/man1/{whois,mdwhois}.1
+ mv "${D}"/usr/bin/{whois,mdwhois}
+ fi
+}