summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-03-17 04:34:34 +0000
committerSamuli Suominen <drac@gentoo.org>2008-03-17 04:34:34 +0000
commit5f640caae1547c6da40fc613b3904c6e7961a723 (patch)
tree6b920c5706332b9c4119b9f54d0b81c468a3fbc0 /net-misc/tn5250
parentDrop to ~mips due to unstable deps (diff)
downloadgentoo-2-5f640caae1547c6da40fc613b3904c6e7961a723.tar.gz
gentoo-2-5f640caae1547c6da40fc613b3904c6e7961a723.tar.bz2
gentoo-2-5f640caae1547c6da40fc613b3904c6e7961a723.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/tn5250')
-rw-r--r--net-misc/tn5250/files/gcc3.patch76
-rw-r--r--net-misc/tn5250/tn5250-0.16.5.ebuild61
-rw-r--r--net-misc/tn5250/tn5250-0.17.3.ebuild60
3 files changed, 0 insertions, 197 deletions
diff --git a/net-misc/tn5250/files/gcc3.patch b/net-misc/tn5250/files/gcc3.patch
deleted file mode 100644
index c2ac5c03d11a..000000000000
--- a/net-misc/tn5250/files/gcc3.patch
+++ /dev/null
@@ -1,76 +0,0 @@
---- tn5250.c.orig 2004-06-07 00:24:59.000000000 -0700
-+++ tn5250.c 2004-06-07 00:28:22.000000000 -0700
-@@ -174,17 +174,17 @@
- Tn5250CharMap *m;
- int i = 0;
-
-- printf ("tn5250 - TCP/IP 5250 emulator\n\
--Syntax:\n\
-- tn5250 [options] HOST[:PORT]\n");
-+ printf ("tn5250 - TCP/IP 5250 emulator\n"
-+ "Syntax:\n"
-+ " tn5250 [options] HOST[:PORT]\n");
- #ifdef HAVE_LIBSSL
-- printf("\
-- To connect using ssl prefix HOST with 'ssl:'. Example:
-- tn5250 +ssl_verify_server ssl:as400.example.com\n");
-+ printf("\n"
-+ " To connect using ssl prefix HOST with 'ssl:'. Example:\n"
-+ " tn5250 +ssl_verify_server ssl:as400.example.com\n");
- #endif
-- printf ("\n\
--Options:\n\
-- map=NAME Character map (default is '37'):");
-+ printf ("\n"
-+ "Options:\n"
-+ " map=NAME Character map (default is '37'):");
- m = tn5250_transmaps;
- while (m->name != NULL) {
- if (i % 5 == 0)
-@@ -192,28 +192,28 @@
- printf ("%s, ", m->name);
- m++; i++;
- }
-- printf ("\n\
-- env.DEVNAME=NAME Use NAME as session name (default: none).\n");
-+ printf ("\n"
-+ " env.DEVNAME=NAME Use NAME as session name (default: none).\n");
- #ifndef NDEBUG
-- printf ("\
-- trace=FILE Log session to FILE.\n");
-+ printf (
-+ " trace=FILE Log session to FILE.\n");
- #endif
- #ifdef HAVE_LIBSSL
-- printf ("\
-- +/-ssl_verify_server Verify/don't verify the server's SSL certificate\n\
-- ssl_ca_file=FILE Use certificate authority (CA) certs from FILE\n\
-- ssl_cert_file=FILE File containing SSL certificate in PEM format to\n\
-- use if the AS/400 requires client authentication.\n\
-- ssl_pem_pass=PHRASE Passphrase to use when decrypting a PEM private\n\
-- key. Used in conjunction with ssl_cert_file\n");
-+ printf (
-+" +/-ssl_verify_server Verify/don't verify the server's SSL certificate\n"
-+" ssl_ca_file=FILE Use certificate authority (CA) certs from FILE\n"
-+" ssl_cert_file=FILE File containing SSL certificate in PEM format to\n"
-+" use if the AS/400 requires client authentication.\n"
-+" ssl_pem_pass=PHRASE Passphrase to use when decrypting a PEM private\n"
-+" key. Used in conjunction with ssl_cert_file\n");
- #endif
-- printf ("\
-- +/-underscores Use/don't use underscores instead of underline\n\
-- attribute.\n\
-- +/-ruler Draw a ruler pointing to the cursor position\n\
-- +/-version Show emulator version and exit.\n\
-- env.NAME=VALUE Set telnet environment string NAME to VALUE.\n\
-- env.TERM=TYPE Emulate IBM terminal type (default: depends)");
-+ printf (
-+" +/-underscores Use/don't use underscores instead of underline\n"
-+" attribute.\n"
-+" +/-ruler Draw a ruler pointing to the cursor position\n"
-+" +/-version Show emulator version and exit.\n"
-+" env.NAME=VALUE Set telnet environment string NAME to VALUE.\n"
-+" env.TERM=TYPE Emulate IBM terminal type (default: depends)");
- p = valid_terms;
- while (p->name) {
- printf ("\n %s (%s)", p->name, p->descr);
diff --git a/net-misc/tn5250/tn5250-0.16.5.ebuild b/net-misc/tn5250/tn5250-0.16.5.ebuild
deleted file mode 100644
index 6b042c40183e..000000000000
--- a/net-misc/tn5250/tn5250-0.16.5.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/tn5250-0.16.5.ebuild,v 1.12 2007/07/22 08:11:44 dberkholz Exp $
-
-inherit eutils
-
-DESCRIPTION="Telnet client for the IBM AS/400 that emulates 5250 terminals and printers."
-HOMEPAGE="http://tn5250.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE="X ssl slang"
-
-RDEPEND="sys-libs/ncurses
- ssl? ( dev-libs/openssl )
- slang? ( =sys-libs/slang-1* )"
-DEPEND="${RDEPEND}
- X? ( x11-libs/libXt )"
-
-src_unpack() {
- unpack ${A}
-
- # First, for some reason, TRUE and FALSE aren't defined
- # for the compile. This causes some problems. ???
- echo >> "${S}/src/tn5250-config.h.in"
- echo "/* Define TRUE and FALSE */" >> "${S}/src/tn5250-config.h.in"
- echo "#define FALSE 0" >> "${S}/src/tn5250-config.h.in"
- echo "#define TRUE !FALSE" >> "${S}/src/tn5250-config.h.in"
-
- # Next, the Makefile for the terminfo settings tries to remove
- # some files it doesn't have access to. We can just remove those
- # lines.
- cd "${S}/linux"
- sed -i \
- -e "/rm -f \/usr\/.*\/terminfo.*5250/d" Makefile.in \
- || die "sed Makefile.in failed"
- cd "${S}/src"
- epatch "${FILESDIR}/gcc3.patch"
-}
-
-src_compile() {
- econf \
- $(use_with X x) \
- $(use_with ssl) \
- $(use_with slang) || die
- emake || die "emake failed"
-}
-
-src_install() {
- # The TERMINFO variable needs to be defined for the install
- # to work, because the install calls "tic." man tic for
- # details.
- dodir /usr/share/terminfo
- make DESTDIR="${D}" \
- TERMINFO="${D}/usr/share/terminfo" install \
- || die "make install failed"
- dodoc AUTHORS BUGS NEWS README README.ssl TODO
- dohtml -r doc/*
-}
diff --git a/net-misc/tn5250/tn5250-0.17.3.ebuild b/net-misc/tn5250/tn5250-0.17.3.ebuild
deleted file mode 100644
index 2396ba24deed..000000000000
--- a/net-misc/tn5250/tn5250-0.17.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/tn5250-0.17.3.ebuild,v 1.3 2007/07/22 08:11:44 dberkholz Exp $
-
-inherit eutils
-
-DESCRIPTION="Telnet client for the IBM AS/400 that emulates 5250 terminals and printers."
-HOMEPAGE="http://tn5250.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="X ssl slang"
-
-RDEPEND="sys-libs/ncurses
- ssl? ( dev-libs/openssl )
- slang? ( =sys-libs/slang-1* )"
-DEPEND="${RDEPEND}
- X? ( x11-libs/libXt )"
-
-src_unpack() {
- unpack ${A}
-
- # First, for some reason, TRUE and FALSE aren't defined
- # for the compile. This causes some problems. ???
- echo >> "${S}/src/tn5250-config.h.in"
- echo "/* Define TRUE and FALSE */" >> "${S}/src/tn5250-config.h.in"
- echo "#define FALSE 0" >> "${S}/src/tn5250-config.h.in"
- echo "#define TRUE !FALSE" >> "${S}/src/tn5250-config.h.in"
-
- # Next, the Makefile for the terminfo settings tries to remove
- # some files it doesn't have access to. We can just remove those
- # lines.
- cd "${S}/linux"
- sed -i \
- -e "/rm -f \/usr\/.*\/terminfo.*5250/d" Makefile.in \
- || die "sed Makefile.in failed"
- cd "${S}/src"
-}
-
-src_compile() {
- econf \
- $(use_with X x) \
- $(use_with ssl) \
- $(use_with slang) || die
- emake || die "emake failed"
-}
-
-src_install() {
- # The TERMINFO variable needs to be defined for the install
- # to work, because the install calls "tic." man tic for
- # details.
- dodir /usr/share/terminfo
- make DESTDIR="${D}" \
- TERMINFO="${D}/usr/share/terminfo" install \
- || die "make install failed"
- dodoc AUTHORS BUGS NEWS README README.ssl TODO
- dohtml -r doc/*
-}