summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-05-15 08:59:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-05-15 08:59:20 +0000
commit926aa578ea8f5466d6563f4f7c989dcef43bc25e (patch)
tree5222790fc5a1e63cc37c7a57f9aef638d0f44a4c /net-libs
parentmask libproxy[xulnenner] as it requires xul 1.9 (diff)
downloadgentoo-2-926aa578ea8f5466d6563f4f7c989dcef43bc25e.tar.gz
gentoo-2-926aa578ea8f5466d6563f4f7c989dcef43bc25e.tar.bz2
gentoo-2-926aa578ea8f5466d6563f4f7c989dcef43bc25e.zip
Adjust dep on xulrunner as it requires 1.9, fix libdl linkage by using portability eclass to link it only on linux, add a merge of various upstream commits to build on BSD and be more POSIX compliant and eventually keyword it ~x86-fbsd, bug #268529
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libproxy/ChangeLog10
-rw-r--r--net-libs/libproxy/files/libproxy-0.2.3-fbsd.patch75
-rw-r--r--net-libs/libproxy/files/libproxy-0.2.3-fix-as-needed-problem.patch2
-rw-r--r--net-libs/libproxy/libproxy-0.2.3.ebuild16
4 files changed, 96 insertions, 7 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index 0a35cf30c483..d7cfeeb39873 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.6 2009/05/14 21:29:32 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.7 2009/05/15 08:59:19 aballier Exp $
+
+ 15 May 2009; Alexis Ballier <aballier@gentoo.org> libproxy-0.2.3.ebuild,
+ +files/libproxy-0.2.3-fbsd.patch,
+ files/libproxy-0.2.3-fix-as-needed-problem.patch:
+ Adjust dep on xulrunner as it requires 1.9, fix libdl linkage by using
+ portability eclass to link it only on linux, add a merge of various
+ upstream commits to build on BSD and be more POSIX compliant and
+ eventually keyword it ~x86-fbsd, bug #268529
14 May 2009; Gilles Dartiguelongue <eva@gentoo.org> libproxy-0.2.3.ebuild,
+files/libproxy-0.2.3-implicit-declaration.patch:
diff --git a/net-libs/libproxy/files/libproxy-0.2.3-fbsd.patch b/net-libs/libproxy/files/libproxy-0.2.3-fbsd.patch
new file mode 100644
index 000000000000..8379b3997f45
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.2.3-fbsd.patch
@@ -0,0 +1,75 @@
+Mix of various upstream commits to build on FreeBSD and be more POSIX compliant.
+Drop at next bump.
+
+
+Index: src/lib/url.c
+===================================================================
+--- src/lib/url.c (revision 308)
++++ src/lib/url.c (revision 309)
+@@ -26,6 +26,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
+
+ #include "misc.h"
+ #include "url.h"
+Index: src/lib/proxy_factory.c
+===================================================================
+--- src/lib/proxy_factory.c (revision 308)
++++ src/lib/proxy_factory.c (revision 309)
+@@ -27,6 +27,7 @@
+ #include <math.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
+ #include <pthread.h>
+
+
+Index: src/plugins/pacrunner_webkit.c
+===================================================================
+--- src/plugins/webkit.c (revision 335)
++++ src/plugins/webkit.c (working copy)
+@@ -23,6 +23,7 @@
+ #include <sys/socket.h>
+ #include <netdb.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
+ #define __USE_BSD
+ #include <unistd.h>
+
+Index: src/plugins/pacrunner_mozjs.c
+===================================================================
+--- src/plugins/mozjs.c (revision 335)
++++ src/plugins/mozjs.c (working copy)
+@@ -23,6 +23,7 @@
+ #include <sys/socket.h>
+ #include <netdb.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
+ #define __USE_BSD
+ #include <unistd.h>
+
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 334)
++++ configure.ac (revision 335)
+@@ -199,7 +199,7 @@
+ AC_TYPE_SIZE_T
+ PLUGINDIR=$libdir/$PACKAGE_NAME/$PACKAGE_VERSION/plugins
+ AC_SUBST(PLUGINDIR)
+-CFLAGS="-g -std=c99 $CFLAGS -DPLUGINDIR=\\\"$PLUGINDIR\\\" -DSYSCONFDIR=\\\"$sysconfdir\\\" -D_POSIX_C_SOURCE=1"
++CFLAGS="-g -std=c99 $CFLAGS -DPLUGINDIR=\\\"$PLUGINDIR\\\" -DSYSCONFDIR=\\\"$sysconfdir\\\" -D_POSIX_C_SOURCE=200112L"
+
+ ### Checks for library functions.
+ AC_FUNC_MALLOC
+Index: src/bin/Makefile.am
+===================================================================
+--- src/bin/Makefile.am (revision 318)
++++ src/bin/Makefile.am (revision 319)
+@@ -3,5 +3,4 @@
+ # Command line interface to libproxy
+ proxy_SOURCES = proxy.c
+ proxy_CFLAGS = -I$(top_srcdir)/src/lib
+-proxy_LDFLAGS = -ldl
+ proxy_LDADD = ../lib/libproxy.la
diff --git a/net-libs/libproxy/files/libproxy-0.2.3-fix-as-needed-problem.patch b/net-libs/libproxy/files/libproxy-0.2.3-fix-as-needed-problem.patch
index 9dca639de6c8..55fec42b39c4 100644
--- a/net-libs/libproxy/files/libproxy-0.2.3-fix-as-needed-problem.patch
+++ b/net-libs/libproxy/files/libproxy-0.2.3-fix-as-needed-problem.patch
@@ -6,7 +6,7 @@ diff -Naur libproxy-0.2.3.orig/src/lib/Makefile.am libproxy-0.2.3/src/lib/Makefi
misc.h url.h pac.h dhcp.h dns.h slp.h wpad.h proxy_factory.h proxy.h config_file.h
libproxy_la_CFLAGS = -Wall
-libproxy_la_LDFLAGS = -lm
-+libproxy_la_LDFLAGS = -lm -ldl
++libproxy_la_LDFLAGS = -lm $(LIBDL)
include_HEADERS = proxy.h
diff --git a/net-libs/libproxy/libproxy-0.2.3.ebuild b/net-libs/libproxy/libproxy-0.2.3.ebuild
index e83013ab374b..9b634e3e03d3 100644
--- a/net-libs/libproxy/libproxy-0.2.3.ebuild
+++ b/net-libs/libproxy/libproxy-0.2.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.2.3.ebuild,v 1.5 2009/05/14 21:29:32 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.2.3.ebuild,v 1.6 2009/05/15 08:59:19 aballier Exp $
EAPI="2"
-inherit autotools eutils python
+inherit autotools eutils python portability
DESCRIPTION="Library for automatic proxy configuration management"
HOMEPAGE="http://code.google.com/p/libproxy/"
@@ -12,7 +12,7 @@ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~x86 ~x86-fbsd"
IUSE="gnome kde networkmanager python webkit xulrunner"
RDEPEND="
@@ -26,7 +26,7 @@ RDEPEND="
networkmanager? ( net-misc/networkmanager )
python? ( >=dev-lang/python-2.5 )
webkit? ( net-libs/webkit-gtk )
- xulrunner? ( net-libs/xulrunner )
+ xulrunner? ( >=net-libs/xulrunner-1.9 )
"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.19"
@@ -47,6 +47,8 @@ src_prepare() {
# Fix implicit declaration QA, bug #268546
epatch "${FILESDIR}/${P}-implicit-declaration.patch"
+ epatch "${FILESDIR}/${P}-fbsd.patch" # drop at next bump
+
# Fix test to follow POSIX (for x86-fbsd)
sed -e 's/\(test.*\)==/\1=/g' -i configure.ac configure || die "sed failed"
@@ -65,8 +67,12 @@ src_configure() {
$(use_with python)
}
+src_compile() {
+ emake LIBDL="$(dlopen_lib)" || die
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed!"
+ emake DESTDIR="${D}" LIBDL="$(dlopen_lib)" install || die "emake install failed!"
dodoc AUTHORS NEWS README ChangeLog || die "dodoc failed"
}