summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-05-20 23:13:15 +0000
committerOlivier Crête <tester@gentoo.org>2009-05-20 23:13:15 +0000
commit9269805bf909ce44c802096c1ec7b29dcd1c012c (patch)
tree7286a98f92482c5defb35582d9dd6381e644d0d0 /net-libs
parent Turn on default useflags for all Qt modules. Remove old. Move src_unpack (diff)
downloadgentoo-2-9269805bf909ce44c802096c1ec7b29dcd1c012c.tar.gz
gentoo-2-9269805bf909ce44c802096c1ec7b29dcd1c012c.tar.bz2
gentoo-2-9269805bf909ce44c802096c1ec7b29dcd1c012c.zip
Version bump
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/farsight2/ChangeLog7
-rw-r--r--net-libs/farsight2/farsight2-0.0.10.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/net-libs/farsight2/ChangeLog b/net-libs/farsight2/ChangeLog
index 29fb8c488357..4f1cf04ebf73 100644
--- a/net-libs/farsight2/ChangeLog
+++ b/net-libs/farsight2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/farsight2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/ChangeLog,v 1.4 2009/05/15 20:55:49 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/ChangeLog,v 1.5 2009/05/20 23:13:15 tester Exp $
+
+*farsight2-0.0.10 (20 May 2009)
+
+ 20 May 2009; Olivier Crête <tester@gentoo.org> +farsight2-0.0.10.ebuild:
+ Version bump
15 May 2009; Tobias Klausmann <klausman@gentoo.org>
farsight2-0.0.9.ebuild:
diff --git a/net-libs/farsight2/farsight2-0.0.10.ebuild b/net-libs/farsight2/farsight2-0.0.10.ebuild
new file mode 100644
index 000000000000..874cd93d8067
--- /dev/null
+++ b/net-libs/farsight2/farsight2-0.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/farsight2-0.0.10.ebuild,v 1.1 2009/05/20 23:13:15 tester Exp $
+
+EAPI="2"
+
+DESCRIPTION="Farsight2 is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE="http://farsight.freedesktop.org/"
+SRC_URI="http://farsight.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE="python"
+SLOT="0"
+
+COMMONDEPEND=">=media-libs/gstreamer-0.10.22
+ >=media-libs/gst-plugins-base-0.10.22
+ >=dev-libs/glib-2.16
+ >=net-libs/libnice-0.0.3[gstreamer]
+ python? (
+ >=dev-python/pygobject-2.12
+ >=dev-python/pygtk-2.10
+ >=dev-python/gst-python-0.10.10 )"
+
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-0.10.11
+ >=media-libs/gst-plugins-bad-0.10.11"
+
+DEPEND="${COMMONDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf $(use_enable python)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS README ChangeLog
+}