summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Noël Rivasseau <elvanor@gentoo.org>2011-02-22 10:59:09 +0000
committerJean-Noël Rivasseau <elvanor@gentoo.org>2011-02-22 10:59:09 +0000
commit0757a2816548f9edd8d7f7669d7b0c6e00196174 (patch)
tree2323db70eeadee907f7ab3f273918d3b47217771 /net-libs/pjsip
parentVersion Bump and python patches (diff)
downloadgentoo-2-0757a2816548f9edd8d7f7669d7b0c6e00196174.tar.gz
gentoo-2-0757a2816548f9edd8d7f7669d7b0c6e00196174.tar.bz2
gentoo-2-0757a2816548f9edd8d7f7669d7b0c6e00196174.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'net-libs/pjsip')
-rw-r--r--net-libs/pjsip/ChangeLog9
-rw-r--r--net-libs/pjsip/pjsip-1.6.ebuild4
-rw-r--r--net-libs/pjsip/pjsip-1.8.10.ebuild95
3 files changed, 104 insertions, 4 deletions
diff --git a/net-libs/pjsip/ChangeLog b/net-libs/pjsip/ChangeLog
index 662237d6c0cd..9a045857f846 100644
--- a/net-libs/pjsip/ChangeLog
+++ b/net-libs/pjsip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/pjsip
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/ChangeLog,v 1.3 2010/11/04 17:33:44 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/ChangeLog,v 1.4 2011/02/22 10:59:09 elvanor Exp $
+
+*pjsip-1.8.10 (22 Feb 2011)
+
+ 22 Feb 2011; <elvanor@gentoo.org> +pjsip-1.8.10.ebuild:
+ Version bump to 1.8.10.
04 Nov 2010; Christian Faulhammer <fauli@gentoo.org> pjsip-1.6.ebuild:
stable x86, bug 342757
diff --git a/net-libs/pjsip/pjsip-1.6.ebuild b/net-libs/pjsip/pjsip-1.6.ebuild
index e0c4065a2026..07f97bacad1c 100644
--- a/net-libs/pjsip/pjsip-1.6.ebuild
+++ b/net-libs/pjsip/pjsip-1.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/pjsip-1.6.ebuild,v 1.3 2010/11/04 17:33:44 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/pjsip-1.6.ebuild,v 1.4 2011/02/22 10:59:09 elvanor Exp $
EAPI="2"
diff --git a/net-libs/pjsip/pjsip-1.8.10.ebuild b/net-libs/pjsip/pjsip-1.8.10.ebuild
new file mode 100644
index 000000000000..fd2bc5a40d5e
--- /dev/null
+++ b/net-libs/pjsip/pjsip-1.8.10.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/pjsip-1.8.10.ebuild,v 1.1 2011/02/22 10:59:09 elvanor Exp $
+
+EAPI="2"
+
+DESCRIPTION="Multimedia communication libraries written in C language
+for building VoIP applications."
+HOMEPAGE="http://www.pjsip.org/"
+SRC_URI="http://www.pjsip.org/release/${PV}/pjproject-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa doc epoll examples ext-sound g711 g722 g7221 gsm ilbc l16
+oss python speex"
+#small-filter large-filter speex-aec ssl
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ gsm? ( media-sound/gsm )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ speex? ( media-libs/speex )"
+ #ssl? ( dev-libs/openssl )
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/pjproject-${PV}"
+
+src_prepare() {
+ # Remove target name from lib names
+ sed -i -e 's/-$(TARGET_NAME)//g' \
+ -e 's/= $(TARGET_NAME).a/= .a/g' \
+ -e 's/-$(LIB_SUFFIX)/$(LIB_SUFFIX)/g' \
+ $(find . -name '*.mak*' -o -name Makefile) || die "sed failed."
+
+ # Fix hardcoded prefix and flags
+ sed -i \
+ -e 's/poll@/poll@\nexport PREFIX := @prefix@\n/g' \
+ -e 's!prefix = /usr/local!prefix = $(PREFIX)!' \
+ -e '/PJLIB_CFLAGS/ s/(_CFLAGS)/(_CFLAGS) -fPIC/g' \
+ -e '/PJLIB_UTIL_CFLAGS/ s/(_CFLAGS)/(_CFLAGS) -fPIC/g' \
+ Makefile \
+ build.mak.in || die "sed failed."
+
+ # TODO: remove deps to shipped codecs and libs, use system ones
+ # rm -r third_party
+ # libresample: https://ccrma.stanford.edu/~jos/resample/Free_Resampling_Software.html
+}
+
+src_configure() {
+ # Disable through portage available codecs
+ econf --disable-gsm-codec \
+ --disable-speex-codec \
+ --disable-ilbc-codec \
+ --disable-speex-aec \
+ $(use_enable epoll) \
+ $(use_enable alsa sound) \
+ $(use_enable oss) \
+ $(use_enable ext-sound) \
+ $(use_enable g711 g711-codec) \
+ $(use_enable l16 l16-codec) \
+ $(use_enable g722 g722-codec) \
+ $(use_enable g7221 g7221-codec) || die "econf failed."
+ #$(use_enable small-filter) \
+ #$(use_enable large-filter) \
+ #$(use_enable speex-aec) \
+ #$(use_enable ssl) \ #broken? sflphone doesn't compile if enabled or disabled
+}
+
+src_compile() {
+ emake dep || die "emake dep failed."
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ DESTDIR="${D}" emake install || die "emake install failed."
+
+ if use python; then
+ pushd pjsip-apps/src/python
+ python setup.py install --prefix="${D}/usr/"
+ popd
+ fi
+
+ if use doc; then
+ dodoc README.txt README-RTEMS
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples"
+ doins "${S}/pjsip-apps/src/samples/"*
+ fi
+
+ # Remove files that pjproject should not install
+ rm -r "${D}/usr/lib/libportaudio.a" \
+ "${D}/usr/lib/libsrtp.a"
+}