summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-09-08 22:10:12 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-09-08 22:10:12 +0000
commit382da9b005b61428497b1fc184b5b48d5b806875 (patch)
tree02d9ee5d109fed1908af58c0f7ee1f4875425c7f /net-libs/gupnp
parentVersion bump. (diff)
downloadgentoo-2-382da9b005b61428497b1fc184b5b48d5b806875.tar.gz
gentoo-2-382da9b005b61428497b1fc184b5b48d5b806875.tar.bz2
gentoo-2-382da9b005b61428497b1fc184b5b48d5b806875.zip
Version bump. Add linux context manager using netlink.
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gupnp')
-rw-r--r--net-libs/gupnp/ChangeLog7
-rw-r--r--net-libs/gupnp/gupnp-0.18.0.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/net-libs/gupnp/ChangeLog b/net-libs/gupnp/ChangeLog
index 3d8583d15f1b..9c1c6ef41ae5 100644
--- a/net-libs/gupnp/ChangeLog
+++ b/net-libs/gupnp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/ChangeLog,v 1.38 2011/08/15 17:03:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/ChangeLog,v 1.39 2011/09/08 22:10:12 eva Exp $
+
+*gupnp-0.18.0 (08 Sep 2011)
+
+ 08 Sep 2011; Gilles Dartiguelongue <eva@gentoo.org> +gupnp-0.18.0.ebuild:
+ Version bump. Add linux context manager using netlink.
15 Aug 2011; Raúl Porcel <armin76@gentoo.org> gupnp-0.13.4.ebuild:
alpha stable
diff --git a/net-libs/gupnp/gupnp-0.18.0.ebuild b/net-libs/gupnp/gupnp-0.18.0.ebuild
new file mode 100644
index 000000000000..bb8c922a04b1
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.18.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/gupnp-0.18.0.ebuild,v 1.1 2011/09/08 22:10:12 eva Exp $
+
+EAPI="4"
+
+inherit eutils gnome.org multilib
+
+DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection networkmanager"
+
+RDEPEND=">=net-libs/gssdp-0.11.2[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ >=dev-libs/glib-2.24:2
+ dev-libs/libxml2
+ || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ networkmanager? ( >=dev-libs/glib-2.26 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ local backend=unix
+ use kernel_linux && backend=linux
+ use networkmanager && backend=network-manager
+
+ econf \
+ $(use_enable introspection) \
+ --disable-static \
+ --disable-dependency-tracking \
+ --disable-gtk-doc \
+ --with-context-manager=${backend}
+}
+
+src_install() {
+ default
+ # Remove pointless .la files
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libgupnp-1.0.so.3
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libgupnp-1.0.so.3
+}