summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-08-07 16:41:45 +0000
committerAlex Legler <a3li@gentoo.org>2010-08-07 16:41:45 +0000
commitdf5312e4bf6797b9343cfc430cca3b6dacfd2c07 (patch)
treedb9b302d69f990d383ef1975354a6fcb677dcbec /net-irc
parentAdd ~alpha/~arm/~ia64/~sparc (diff)
downloadgentoo-2-df5312e4bf6797b9343cfc430cca3b6dacfd2c07.tar.gz
gentoo-2-df5312e4bf6797b9343cfc430cca3b6dacfd2c07.tar.bz2
gentoo-2-df5312e4bf6797b9343cfc430cca3b6dacfd2c07.zip
Add a proper fix to respect user CFLAGS, thanks to flameeyes.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bip/ChangeLog6
-rw-r--r--net-irc/bip/bip-0.8.5.ebuild12
-rw-r--r--net-irc/bip/files/bip-configure.patch28
3 files changed, 40 insertions, 6 deletions
diff --git a/net-irc/bip/ChangeLog b/net-irc/bip/ChangeLog
index e198df8ace66..4092eeaa32d5 100644
--- a/net-irc/bip/ChangeLog
+++ b/net-irc/bip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/bip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.14 2010/08/07 12:46:33 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.15 2010/08/07 16:41:44 a3li Exp $
+
+ 07 Aug 2010; Alex Legler <a3li@gentoo.org> bip-0.8.5.ebuild,
+ +files/bip-configure.patch:
+ Add a proper fix to respect user CFLAGS, thanks to flameeyes.
*bip-0.8.5 (07 Aug 2010)
diff --git a/net-irc/bip/bip-0.8.5.ebuild b/net-irc/bip/bip-0.8.5.ebuild
index 2d0daf51623b..feaf776a79d8 100644
--- a/net-irc/bip/bip-0.8.5.ebuild
+++ b/net-irc/bip/bip-0.8.5.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.5.ebuild,v 1.1 2010/08/07 12:46:33 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.5.ebuild,v 1.2 2010/08/07 16:41:44 a3li Exp $
EAPI="2"
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Multiuser IRC proxy with ssl support"
HOMEPAGE="http://bip.t1r.net/"
@@ -21,6 +21,10 @@ RDEPEND="${DEPEND}
oidentd? ( >=net-misc/oidentd-2.0 )"
src_prepare() {
+ epatch "${FILESDIR}/${PN}-configure.patch" || die
+
+ eautoreconf
+
if use noctcp; then
sed -i -e '/irc_privmsg_check_ctcp(server, line);/s:^://:' src/irc.c || die
fi
@@ -39,9 +43,7 @@ src_configure() {
src_compile() {
# Parallel make fails.
- # {C,CXX,LD}FLAGS aren't respected, bug 241030.
- emake CFLAGS="${CFLAGS}" CPPFLAGS="${CXXFLAGS}" \
- LDFLAGS="${LDFLAGS}" -j1 || die "emake failed"
+ emake -j1 || die "emake failed"
}
src_install() {
diff --git a/net-irc/bip/files/bip-configure.patch b/net-irc/bip/files/bip-configure.patch
new file mode 100644
index 000000000000..028c7f0610b4
--- /dev/null
+++ b/net-irc/bip/files/bip-configure.patch
@@ -0,0 +1,28 @@
+Respecting user CFLAGS, removing unneded LDFLAGS.
+The -O0 stuff shouldn't be there as it disables fortifying.
+
+Upstream: to be submitted (2010-08-07)
+
+diff --git a/configure.ac b/configure.ac
+index f61a9ed..6720150 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -44,16 +44,14 @@ AC_ARG_ENABLE([pie], AS_HELP_STRING([--disable-pie], [Do not build a position in
+
+ AM_CONDITIONAL(DEBUG, test x$enable_debug = xyes)
+ AS_IF([test "x$enable_debug" = "xyes"], [
+- CFLAGS="-O0 -g -W -Wall"
+- LDFLAGS="-g"
++ CFLAGS="${CFLAGS} -g -W -Wall"
+ AC_CHECK_FUNC(backtrace_symbols_fd, [
+ AC_DEFINE(HAVE_BACKTRACE, [], [Use glibc backtrace on fatal()])
+ LDFLAGS="-rdynamic $LDFLAGS"
+ backtrace="(with backtrace)"
+ ])
+ ], [
+- CFLAGS="-O2 -g -W -Wall"
+- LDFLAGS="-g"
++ CFLAGS="${CFLAGS} -g -W -Wall"
+ enable_debug=no
+ ])
+