summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-22 04:11:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-22 04:11:55 +0000
commite8504acfe48c26f086cba6f9e0e06529fbf34881 (patch)
tree7cc24858de66c4dc7c97704258dbeef8696bbb13 /net-ftp
parentBump (diff)
downloadgentoo-2-e8504acfe48c26f086cba6f9e0e06529fbf34881.tar.gz
gentoo-2-e8504acfe48c26f086cba6f9e0e06529fbf34881.tar.bz2
gentoo-2-e8504acfe48c26f086cba6f9e0e06529fbf34881.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/yafc/ChangeLog9
-rw-r--r--net-ftp/yafc/yafc-1.2.6.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/net-ftp/yafc/ChangeLog b/net-ftp/yafc/ChangeLog
index e5ee4c95da11..3102ac015298 100644
--- a/net-ftp/yafc/ChangeLog
+++ b/net-ftp/yafc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/yafc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.43 2013/08/16 08:19:45 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.44 2014/07/22 04:11:55 patrick Exp $
+
+*yafc-1.2.6 (22 Jul 2014)
+
+ 22 Jul 2014; Patrick Lauer <patrick@gentoo.org> +yafc-1.2.6.ebuild:
+ Bump
*yafc-1.2.5 (16 Aug 2013)
diff --git a/net-ftp/yafc/yafc-1.2.6.ebuild b/net-ftp/yafc/yafc-1.2.6.ebuild
new file mode 100644
index 000000000000..7ec6d7856f60
--- /dev/null
+++ b/net-ftp/yafc/yafc-1.2.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.2.6.ebuild,v 1.1 2014/07/22 04:11:55 patrick Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="Console ftp client with a lot of nifty features"
+HOMEPAGE="http://www.yafc-ftp.com/"
+SRC_URI="http://www.yafc-ftp.com/upload/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="ipv6 readline kerberos socks5 ssh"
+
+DEPEND="dev-libs/openssl:0
+ readline? ( >=sys-libs/readline-6 )
+ kerberos? ( virtual/krb5 )
+ socks5? ( net-proxy/dante )
+ ssh? ( net-libs/libssh )"
+RDEPEND="${DEPEND}"
+
+DOCS=( BUGS NEWS README THANKS TODO )
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ export ac_cv_ipv6=$(usex ipv6)
+ econf \
+ $(use_with readline readline /usr) \
+ $(use_with socks5 socks /usr) \
+ $(use_with socks5 socks5 /usr) \
+ $(use_with kerberos krb5) \
+ $(use_with ssh) \
+ --with-bash-completion="$(get_bashcompdir)" \
+ --without-krb4
+}
+
+src_install() {
+ default
+ dodoc -r samples
+}