summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-04 15:57:22 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-04 15:57:22 +0000
commit5fbddf7c5bd431bc3663d221907d8a01e8b2430e (patch)
treec4bedbba4f430bc4b321b93e38a68985b6cdc9bd /net-ftp/linksys-tftp
parentmake the mmx asm work with newer versions of nasm (bug #339150) (diff)
downloadgentoo-2-5fbddf7c5bd431bc3663d221907d8a01e8b2430e.tar.gz
gentoo-2-5fbddf7c5bd431bc3663d221907d8a01e8b2430e.tar.bz2
gentoo-2-5fbddf7c5bd431bc3663d221907d8a01e8b2430e.zip
Revbump to fix CFLAGS (bug 240894) and LDFLAGS (bug 336956)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/linksys-tftp')
-rw-r--r--net-ftp/linksys-tftp/ChangeLog16
-rw-r--r--net-ftp/linksys-tftp/files/linksys-tftp-1.2.1-r1-Makefile.patch28
-rw-r--r--net-ftp/linksys-tftp/files/linksys-tftp-1.2.1-r1-header.patch20
-rw-r--r--net-ftp/linksys-tftp/linksys-tftp-1.2.1-r1.ebuild32
-rw-r--r--net-ftp/linksys-tftp/linksys-tftp-1.2.1.ebuild8
5 files changed, 98 insertions, 6 deletions
diff --git a/net-ftp/linksys-tftp/ChangeLog b/net-ftp/linksys-tftp/ChangeLog
index 47af799034ff..1f3818f7f8ee 100644
--- a/net-ftp/linksys-tftp/ChangeLog
+++ b/net-ftp/linksys-tftp/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-ftp/linksys-tftp
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/linksys-tftp/ChangeLog,v 1.5 2009/09/23 18:37:13 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/linksys-tftp/ChangeLog,v 1.6 2010/10/04 15:57:22 xmw Exp $
+
+*linksys-tftp-1.2.1-r1 (03 Oct 2010)
+
+ 03 Oct 2010; Michael Weber <xmw@gentoo.org> linksys-tftp-1.2.1.ebuild,
+ +linksys-tftp-1.2.1-r1.ebuild,
+ +files/linksys-tftp-1.2.1-r1-Makefile.patch,
+ +files/linksys-tftp-1.2.1-r1-header.patch:
+ Revbump to fix CFLAGS (bug 240894) and LDFLAGS (bug 336956)
+
+ 03 Oct 2010; Michael Weber <xmw@gentoo.org> linksys-tftp-1.2.1.ebuild:
+ Updating HOMEPAGE, pointing SRC_URI to mirrors (thanks to Roland Ramthun
+ <bts@roland-ramthun.de> for his report on bug #339495)
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> linksys-tftp-1.2.1.ebuild:
Remove virtual/libc
diff --git a/net-ftp/linksys-tftp/files/linksys-tftp-1.2.1-r1-Makefile.patch b/net-ftp/linksys-tftp/files/linksys-tftp-1.2.1-r1-Makefile.patch
new file mode 100644
index 000000000000..b374e808ece2
--- /dev/null
+++ b/net-ftp/linksys-tftp/files/linksys-tftp-1.2.1-r1-Makefile.patch
@@ -0,0 +1,28 @@
+Fix LDFLAGS (bug http://bugs.gentoo.org/336956 ) and
+CFLAGS (bug http://bugs.gentoo.org/240894 ) by
+Michael Weber <xmw@gentoo.org>
+
+--- linksys-tftp-1.2.1/Makefile
++++ linksys-tftp-1.2.1/Makefile
+@@ -19,18 +19,18 @@
+ # We override /usr/include/arpa/tftp.h with our own because
+ # we want tu_block to be unsigned short, not short as on most platforms
+ #
+-CFLAGS= -I. -O2 -Dsin=sin_x
++CFLAGS += -I. -Dsin=sin_x
+ #DEBUG
+ # CFLAGS= -I. -Wall -ggdb -Dsin=sin_x
+ SRCS= main.c tftp.c tftpsubs.c
+ OBJS= main.o tftp.o tftpsubs.o
+ DOBJS= tftpsubs.o
+-CC= gcc
++CC?= gcc
+
+ all: linksys-tftp
+
+ linksys-tftp: ${OBJS}
+- ${CC} -o $@ ${CFLAGS} ${OBJS}
++ ${CC} -o $@ ${CFLAGS} ${OBJS} ${LDFLAGS}
+
+ clean:
+ rm -f ${OBJS} ${DOBJS} *core linksys-tftp
diff --git a/net-ftp/linksys-tftp/files/linksys-tftp-1.2.1-r1-header.patch b/net-ftp/linksys-tftp/files/linksys-tftp-1.2.1-r1-header.patch
new file mode 100644
index 000000000000..386cf7b1e210
--- /dev/null
+++ b/net-ftp/linksys-tftp/files/linksys-tftp-1.2.1-r1-header.patch
@@ -0,0 +1,20 @@
+--- linksys-tftp-1.2.1/main.c
++++ linksys-tftp-1.2.1/main.c
+@@ -40,6 +40,8 @@
+ #include <setjmp.h>
+ #include <ctype.h>
+ #include <netdb.h>
++#include <stdlib.h>
++#include <strings.h>
+
+ #define TIMEOUT 5 /* secs between rexmt's */
+
+@@ -110,7 +112,7 @@
+ char *index();
+ char *rindex();
+
+-main(argc, argv)
++int main(argc, argv)
+ char *argv[];
+ {
+ struct sockaddr_in sin;
diff --git a/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r1.ebuild b/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..572e2f4c64c1
--- /dev/null
+++ b/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r1.ebuild,v 1.1 2010/10/04 15:57:22 xmw Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TFTP client suitable for uploading to the Linksys WRT54G Wireless Router"
+HOMEPAGE="http://redsand.net/projects/linksys-tftp/linksys-tftp.php"
+SRC_URI="http://redsand.net/projects/${PN}/pub/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/gcc"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}-Makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ doexe linksys-tftp || die
+ dodoc README || die
+}
diff --git a/net-ftp/linksys-tftp/linksys-tftp-1.2.1.ebuild b/net-ftp/linksys-tftp/linksys-tftp-1.2.1.ebuild
index 848aef36138b..a37e325e87da 100644
--- a/net-ftp/linksys-tftp/linksys-tftp-1.2.1.ebuild
+++ b/net-ftp/linksys-tftp/linksys-tftp-1.2.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/linksys-tftp/linksys-tftp-1.2.1.ebuild,v 1.4 2009/09/23 18:37:13 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/linksys-tftp/linksys-tftp-1.2.1.ebuild,v 1.5 2010/10/04 15:57:22 xmw Exp $
IUSE=""
DESCRIPTION="TFTP client suitable for uploading to the Linksys WRT54G Wireless Router"
-HOMEPAGE="http://redsand.net/"
-SRC_URI="http://redsand.net/code/linksys-tftp-${PV}.tar.bz2"
+HOMEPAGE="http://redsand.net/projects/linksys-tftp/linksys-tftp.php"
+SRC_URI="mirror://gentoo/linksys-tftp-${PV}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"