summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2013-08-28 16:19:04 +0000
committerConstanze Hausner <constanze@gentoo.org>2013-08-28 16:19:04 +0000
commit7fa3a133d2da385ae9f312c67678356c45f1d287 (patch)
tree5c52fe7c9aad137965c359fadb72e5f502927824 /net-firewall/shorewall-core
parentPer bug #482604, start include a changelog. Also install the other docs. (diff)
downloadgentoo-2-7fa3a133d2da385ae9f312c67678356c45f1d287.tar.gz
gentoo-2-7fa3a133d2da385ae9f312c67678356c45f1d287.tar.bz2
gentoo-2-7fa3a133d2da385ae9f312c67678356c45f1d287.zip
Version bump; Add new files/ structure
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key BB80F419010E3EC3)
Diffstat (limited to 'net-firewall/shorewall-core')
-rw-r--r--net-firewall/shorewall-core/ChangeLog8
-rw-r--r--net-firewall/shorewall-core/files/4.5.19/shorewallrc22
-rw-r--r--net-firewall/shorewall-core/shorewall-core-4.5.19.ebuild64
3 files changed, 93 insertions, 1 deletions
diff --git a/net-firewall/shorewall-core/ChangeLog b/net-firewall/shorewall-core/ChangeLog
index 0645e7f12668..9e80182e4d51 100644
--- a/net-firewall/shorewall-core/ChangeLog
+++ b/net-firewall/shorewall-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.41 2013/08/28 15:21:47 constanze Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.42 2013/08/28 16:19:04 constanze Exp $
+
+*shorewall-core-4.5.19 (28 Aug 2013)
+
+ 28 Aug 2013; Constanze Hausner <constanze@gentoo.org>
+ +files/4.5.19/shorewallrc, +shorewall-core-4.5.19.ebuild:
+ Version bump; Add new files/ structure
28 Aug 2013; Constanze Hausner <constanze@gentoo.org>
-shorewall-core-4.5.15.ebuild, -shorewall-core-4.5.17.ebuild:
diff --git a/net-firewall/shorewall-core/files/4.5.19/shorewallrc b/net-firewall/shorewall-core/files/4.5.19/shorewallrc
new file mode 100644
index 000000000000..c2fce7246c1b
--- /dev/null
+++ b/net-firewall/shorewall-core/files/4.5.19/shorewallrc
@@ -0,0 +1,22 @@
+#
+# Gentoo Shorewall 4.5 rc file
+#
+BUILD= #Default is to detect the build system
+HOST=linux #Generic Linux
+PREFIX=@GENTOO_PORTAGE_EPREFIX@/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=@GENTOO_PORTAGE_EPREFIX@/etc #Directory where subsystem configurations are installed
+SBINDIR=@GENTOO_PORTAGE_EPREFIX@/sbin #Directory where system administration programs are installed
+MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
+INITDIR=${CONFDIR}/init.d #Directory where SysV init scripts are installed.
+INITFILE=${PRODUCT} #Name of the product's installed SysV init script
+INITSOURCE=init.gentoo.sh #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD=@GENTOO_PORTAGE_EPREFIX@/usr/lib/systemd/system #Directory where .service files are installed (systems running systemd only)
+SYSCONFFILE=default.gentoo #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR=${CONFDIR}/conf.d #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARLIB=@GENTOO_PORTAGE_EPREFIX@/var/lib #Directory where product variable data is stored.
+VARDIR=${VARLIB}/${PRODUCT} #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall-core/shorewall-core-4.5.19.ebuild b/net-firewall/shorewall-core/shorewall-core-4.5.19.ebuild
new file mode 100644
index 000000000000..edfeabaae33a
--- /dev/null
+++ b/net-firewall/shorewall-core/shorewall-core-4.5.19.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/shorewall-core-4.5.19.ebuild,v 1.1 2013/08/28 16:19:04 constanze Exp $
+
+EAPI="5"
+
+inherit eutils prefix versionator
+
+MY_URL_PREFIX=
+case ${P} in
+ *_beta* | \
+ *_rc*)
+ MY_URL_PREFIX='development/'
+ ;;
+esac
+
+MY_PV=${PV/_rc/-RC}
+MY_PV=${MY_PV/_beta/-Beta}
+MY_P=${PN}-${MY_PV}
+
+MY_MAJORMINOR=$(get_version_component_range 1-2)
+
+DESCRIPTION="Core libraries of shorewall / shorewall(6)-lite"
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www.shorewall.net/pub/shorewall/${MY_URL_PREFIX}${MY_MAJORMINOR}/shorewall-${MY_PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="
+ >=dev-lang/perl-5.10
+ virtual/perl-Digest-SHA
+ !<net-firewall/shorewall-4.5.0.1
+ selinux? ( sec-policy/selinux-shorewall )
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-firewall/iptables-1.4.20
+ sys-apps/iproute2[-minimal]
+ sys-devel/bc
+ sys-apps/coreutils
+"
+
+DOCS=( changelog.txt releasenotes.txt )
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ cp "${FILESDIR}"/${PV}/shorewallrc "${S}"/shorewallrc.gentoo || die "Copying shorewallrc_new failed"
+ eprefixify "${S}"/shorewallrc.gentoo
+
+ epatch_user
+}
+
+src_configure() {
+ :;
+}
+
+src_install() {
+ DESTDIR="${D}" ./install.sh shorewallrc.gentoo || die "install.sh failed"
+ default
+}