summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-06-06 23:53:31 +0000
committerSven Wegener <swegener@gentoo.org>2008-06-06 23:53:31 +0000
commit2e9ce82b45a08a7b5c589de042c1e799f1f3d8b4 (patch)
treeabdcedb4311f4e0d0bb1adc6a7d676880a79eaad /net-firewall/ipsec-tools
parentstable on amd64, bug #224735 (diff)
downloadgentoo-2-2e9ce82b45a08a7b5c589de042c1e799f1f3d8b4.tar.gz
gentoo-2-2e9ce82b45a08a7b5c589de042c1e799f1f3d8b4.tar.bz2
gentoo-2-2e9ce82b45a08a7b5c589de042c1e799f1f3d8b4.zip
Use KV_DIR instead of relying on the /lib/modules build symlink pointing to the source, which is broken behaviour.
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-firewall/ipsec-tools')
-rw-r--r--net-firewall/ipsec-tools/ChangeLog6
-rw-r--r--net-firewall/ipsec-tools/ipsec-tools-0.6.7.ebuild26
2 files changed, 17 insertions, 15 deletions
diff --git a/net-firewall/ipsec-tools/ChangeLog b/net-firewall/ipsec-tools/ChangeLog
index e7fdd1225d2b..2f38bf193aa4 100644
--- a/net-firewall/ipsec-tools/ChangeLog
+++ b/net-firewall/ipsec-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/ipsec-tools
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.59 2008/03/13 11:23:52 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.60 2008/06/06 23:53:31 swegener Exp $
+
+ 06 Jun 2008; Sven Wegener <swegener@gentoo.org> ipsec-tools-0.6.7.ebuild:
+ Use KV_DIR instead of relying on the /lib/modules build symlink pointing
+ to the source, which is broken behaviour.
13 Mar 2008; Wolfram Schlich <wschlich@gentoo.org>
ipsec-tools-0.6.7.ebuild:
diff --git a/net-firewall/ipsec-tools/ipsec-tools-0.6.7.ebuild b/net-firewall/ipsec-tools/ipsec-tools-0.6.7.ebuild
index cd7eae6b6103..205aca849c7f 100644
--- a/net-firewall/ipsec-tools/ipsec-tools-0.6.7.ebuild
+++ b/net-firewall/ipsec-tools/ipsec-tools-0.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ipsec-tools-0.6.7.ebuild,v 1.12 2008/03/13 11:23:52 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ipsec-tools-0.6.7.ebuild,v 1.13 2008/06/06 23:53:31 swegener Exp $
inherit eutils flag-o-matic autotools linux-info
@@ -141,11 +141,11 @@ kernel_check() {
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# fix for bug #76741
sed -i 's:#include <sys/sysctl.h>::' src/racoon/pfkey.c src/setkey/setkey.c
# fix for bug #124813
- sed -i 's:-Werror::g' ${S}/configure.ac
+ sed -i 's:-Werror::g' "${S}"/configure.ac
AT_M4DIR="${S}" eautoreconf
epunt_cxx
@@ -157,7 +157,7 @@ src_compile() {
kernel_check
- myconf="${myconf} --with-kernel-headers=/lib/modules/${KV_FULL}/build/include"
+ myconf="${myconf} --with-kernel-headers=${KV_DIR}/include"
use nat && myconf="${myconf} --enable-natt --enable-natt-versions=yes"
# myconf="${myconf} $(use_enable broken-natt)"
@@ -197,8 +197,7 @@ src_compile() {
#myconf="${myconf} --enable-samode-unspec"
econf ${myconf} || die
- MAKEOPTS="${MAKEOPTS} -j1" # parallel make is still broken
- emake || die
+ emake -j1 || die
}
@@ -232,33 +231,32 @@ src_install() {
pkg_postinst() {
if use nat; then
- elog ""
+ elog
elog " You have enabled the nat traversal functionnality."
elog " Nat versions wich are enabled by default are 00,02,rfc"
elog " you can find those drafts in the CVS repository:"
elog "cvs -d anoncvs@anoncvs.netbsd.org:/cvsroot co ipsec-tools"
- elog ""
+ elog
elog "If you feel brave enough and you know what you are"
elog "doing, you can consider emerging this ebuild"
elog "with"
elog "EXTRA_ECONF=\"--enable-natt-versions=08,07,06\""
- elog ""
+ elog
fi;
if use ldap; then
- elog ""
+ elog
elog " You have enabled ldap support with {$PN}."
elog " The man page does NOT contain any information on it yet."
elog " Consider to use a more recent version or CVS"
- elog ""
+ elog
fi;
- elog ""
+ elog
elog "Please have a look in /usr/share/doc/${P} and visit"
elog "http://www.netbsd.org/Documentation/network/ipsec/"
elog "to find a lot of information on how to configure this great tool."
- elog ""
-
+ elog
}
# vim: set foldmethod=marker nowrap :