summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-06-14 12:39:26 +0000
committerAlin Năstac <mrness@gentoo.org>2007-06-14 12:39:26 +0000
commit9fc6152e68031a34ad1ba39e901f18d01e567d8e (patch)
tree31083b9830282b99b4069b2b92d2d195eca9ea49 /net-dialup/xl2tpd
parentold (diff)
downloadgentoo-2-9fc6152e68031a34ad1ba39e901f18d01e567d8e.tar.gz
gentoo-2-9fc6152e68031a34ad1ba39e901f18d01e567d8e.tar.bz2
gentoo-2-9fc6152e68031a34ad1ba39e901f18d01e567d8e.zip
Version bump (#181541).
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-dialup/xl2tpd')
-rw-r--r--net-dialup/xl2tpd/ChangeLog7
-rw-r--r--net-dialup/xl2tpd/files/digest-xl2tpd-1.1.103
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.1.10.ebuild59
3 files changed, 68 insertions, 1 deletions
diff --git a/net-dialup/xl2tpd/ChangeLog b/net-dialup/xl2tpd/ChangeLog
index 60e6388b5dc1..e2fe36425ed6 100644
--- a/net-dialup/xl2tpd/ChangeLog
+++ b/net-dialup/xl2tpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/xl2tpd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.8 2007/04/12 22:13:15 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.9 2007/06/14 12:39:26 mrness Exp $
+
+*xl2tpd-1.1.10 (14 Jun 2007)
+
+ 14 Jun 2007; Alin Năstac <mrness@gentoo.org> +xl2tpd-1.1.10.ebuild:
+ Version bump (#181541).
12 Apr 2007; Christian Faulhammer <opfer@gentoo.org> xl2tpd-1.1.09.ebuild:
stable x86/amd64, bug 174280
diff --git a/net-dialup/xl2tpd/files/digest-xl2tpd-1.1.10 b/net-dialup/xl2tpd/files/digest-xl2tpd-1.1.10
new file mode 100644
index 000000000000..2d434e6cc1fa
--- /dev/null
+++ b/net-dialup/xl2tpd/files/digest-xl2tpd-1.1.10
@@ -0,0 +1,3 @@
+MD5 d99c48b5f60ac4702b69055b0e504cc0 xl2tpd-1.1.10.tar.gz 164422
+RMD160 935e0e48251db058a00679bd610b51468caf362f xl2tpd-1.1.10.tar.gz 164422
+SHA256 a698273d886158b15d0f42455e3a4bd8b8c998b152c96321759b58915ba8cc6a xl2tpd-1.1.10.tar.gz 164422
diff --git a/net-dialup/xl2tpd/xl2tpd-1.1.10.ebuild b/net-dialup/xl2tpd/xl2tpd-1.1.10.ebuild
new file mode 100644
index 000000000000..b760ad697a8e
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.1.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.1.10.ebuild,v 1.1 2007/06/14 12:39:26 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/software/xl2tpd/"
+SRC_URI="ftp://ftp.xelerance.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-dialup/l2tpd
+ net-dialup/ppp"
+
+src_install() {
+ dosbin xl2tpd || die 'xl2tpd binary not found'
+ doman doc/*.[85]
+
+ dodoc CREDITS README.xl2tpd \
+ doc/README.patents doc/rfc2661.txt doc/*.sample
+
+ dodir /etc/xl2tpd
+ head -n 2 doc/l2tp-secrets.sample > "${D}/etc/xl2tpd/l2tp-secrets"
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+ newinitd "${FILESDIR}/xl2tpd-init" xl2tpd
+
+ keepdir /var/run/xl2tpd
+}
+
+#TODO: remove preinst and postinst functions some time around July 2007
+pkg_preinst() {
+ if has_version "<=${CATEGORY}/${PN}-1.1.05" && [[ -d "${ROOT}/etc/l2tpd" ]]; then
+ ebegin "Migrating /etc/l2tpd to /etc/xl2tpd"
+ if [[ -f "${ROOT}/etc/l2tpd/l2tpd.conf" ]] ; then
+ sed -i -e 's:/etc/l2tpd/:/etc/xl2tpd/:g' "${ROOT}/etc/l2tpd/l2tpd.conf"
+ mv "${ROOT}/etc/l2tpd/l2tpd.conf" "${ROOT}/etc/l2tpd/xl2tpd.conf"
+ fi
+ mv -f "${ROOT}/etc/l2tpd" "${ROOT}/etc/xl2tpd"
+ eend
+ fi
+}
+
+pkg_postinst() {
+ if has_version "<=${CATEGORY}/${PN}-1.1.05"; then
+ ewarn "The daemon and service have been renamed from l2tpd to xl2tpd."
+ ewarn "Please remove the old init script and configure your system to use"
+ ewarn "the new init script:"
+ ewarn " /etc/init.d/l2tpd stop"
+ ewarn " rc-update del l2tpd"
+ ewarn " rm /etc/init.d/l2tpd"
+ ewarn " rc-update add xl2tpd"
+ ewarn " /etc/init.d/xl2tpd start"
+ ebeep
+ fi
+}