summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-03-02 17:25:35 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-03-02 17:25:35 +0000
commit20af9c94fcaa7140b64d1e777f80e11d75148dae (patch)
tree8b31c76d2e8713b59974cb11588edf35230d7f35 /net-dialup/xc
parentFix build and install problems with XEmacs, bug 459172. The ebuild now suppor... (diff)
downloadgentoo-2-20af9c94fcaa7140b64d1e777f80e11d75148dae.tar.gz
gentoo-2-20af9c94fcaa7140b64d1e777f80e11d75148dae.tar.bz2
gentoo-2-20af9c94fcaa7140b64d1e777f80e11d75148dae.zip
Revision bump: respect AR and RANLIB, fix building with sys-libs/ncurses[tinfo] wrt bug #459796
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-dialup/xc')
-rw-r--r--net-dialup/xc/ChangeLog11
-rw-r--r--net-dialup/xc/files/xc-4.3.2-gentoo.patch21
-rw-r--r--net-dialup/xc/xc-4.3.2-r3.ebuild42
3 files changed, 71 insertions, 3 deletions
diff --git a/net-dialup/xc/ChangeLog b/net-dialup/xc/ChangeLog
index 39c9b6adfd4e..1f9cabbec542 100644
--- a/net-dialup/xc/ChangeLog
+++ b/net-dialup/xc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/xc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/ChangeLog,v 1.24 2011/03/21 00:37:24 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/ChangeLog,v 1.25 2013/03/02 17:25:35 pinkbyte Exp $
+
+*xc-4.3.2-r3 (02 Mar 2013)
+
+ 02 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> +xc-4.3.2-r3.ebuild,
+ files/xc-4.3.2-gentoo.patch:
+ Revision bump: respect AR and RANLIB, fix building with
+ sys-libs/ncurses[tinfo] wrt bug #459796
21 Mar 2011; Mike Frysinger <vapier@gentoo.org> xc-4.3.2-r2.ebuild:
Stabilize for all.
diff --git a/net-dialup/xc/files/xc-4.3.2-gentoo.patch b/net-dialup/xc/files/xc-4.3.2-gentoo.patch
index 8eb366059a62..7c0c559958d9 100644
--- a/net-dialup/xc/files/xc-4.3.2-gentoo.patch
+++ b/net-dialup/xc/files/xc-4.3.2-gentoo.patch
@@ -37,7 +37,7 @@
INSTALL = install
-LDFLAGS = -ltermcap editline/libedit.a
-+LIBS = -lncurses editline/libedit.a
++LIBS += -lncurses editline/libedit.a
NROFF = groff -mandoc
# defines for use with cextract under Linux
@@ -101,3 +101,22 @@ add simple usage
if (argc > 1) {
if (!strcmp(argv[1], "-x")) {
Block = 128;
+--- xc-4.3.2/editline/Makefile.orig 2013-03-02 21:15:29.667344872 +0400
++++ xc-4.3.2/editline/Makefile 2013-03-02 21:15:38.434344313 +0400
+@@ -34,7 +34,7 @@
+ LDFLAGS = -ltermcap
+
+ ## Set ranlib as appropriate:
+-RANLIB = ranlib
++RANLIB ?= ranlib
+ #RANLIB = echo
+
+ ## End of configuration.
+@@ -70,6 +70,6 @@
+
+ libedit.a: $(OBJECTS)
+ @rm -f $@
+- ar r $@ $(OBJECTS)
++ $(AR) r $@ $(OBJECTS)
+ $(RANLIB) $@
+
diff --git a/net-dialup/xc/xc-4.3.2-r3.ebuild b/net-dialup/xc/xc-4.3.2-r3.ebuild
new file mode 100644
index 000000000000..fd9c7b4d955e
--- /dev/null
+++ b/net-dialup/xc/xc-4.3.2-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r3.ebuild,v 1.1 2013/03/02 17:25:35 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="unix dialout program"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-implicit-decl.patch
+ epatch "${FILESDIR}"/${P}-add-115200.patch
+
+ sed -i \
+ -e "/^libdir/s:/lib/:/$(get_libdir)/:" \
+ Makefile || die
+ # bug 459796
+ append-libs "$($(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ emake WARN="" all
+}
+
+src_install() {
+ default
+ insinto /usr/$(get_libdir)/xc
+ doins phonelist xc.init dotfiles/.[a-z]*
+}