summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-04-16 16:35:31 +0000
committerJeroen Roovers <jer@gentoo.org>2015-04-16 16:35:31 +0000
commit26cb64706fd06c634ee43de0a7eff58b0829ab90 (patch)
treea8d241ffe4635e7ea33fe486fbd20c4f4029e516 /net-analyzer/tcpreplay
parentVersion bump. (diff)
downloadgentoo-2-26cb64706fd06c634ee43de0a7eff58b0829ab90.tar.gz
gentoo-2-26cb64706fd06c634ee43de0a7eff58b0829ab90.tar.bz2
gentoo-2-26cb64706fd06c634ee43de0a7eff58b0829ab90.zip
Fix configure logic in disabling pcap_findalldevs() (bug #546762).
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/ChangeLog11
-rw-r--r--net-analyzer/tcpreplay/files/tcpreplay-4.1.0-enable-pcap_findalldevs.patch19
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.0.5-r1.ebuild (renamed from net-analyzer/tcpreplay/tcpreplay-4.0.5.ebuild)6
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.1.0-r1.ebuild (renamed from net-analyzer/tcpreplay/tcpreplay-4.1.0.ebuild)4
4 files changed, 36 insertions, 4 deletions
diff --git a/net-analyzer/tcpreplay/ChangeLog b/net-analyzer/tcpreplay/ChangeLog
index c3bc79ecd308..805aa3a682f7 100644
--- a/net-analyzer/tcpreplay/ChangeLog
+++ b/net-analyzer/tcpreplay/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-analyzer/tcpreplay
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/ChangeLog,v 1.59 2015/04/08 13:36:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/ChangeLog,v 1.60 2015/04/16 16:35:31 jer Exp $
+
+*tcpreplay-4.1.0-r1 (16 Apr 2015)
+*tcpreplay-4.0.5-r1 (16 Apr 2015)
+
+ 16 Apr 2015; Jeroen Roovers <jer@gentoo.org> -tcpreplay-4.0.5.ebuild,
+ +tcpreplay-4.0.5-r1.ebuild, -tcpreplay-4.1.0.ebuild,
+ +tcpreplay-4.1.0-r1.ebuild,
+ +files/tcpreplay-4.1.0-enable-pcap_findalldevs.patch:
+ Fix configure logic in disabling pcap_findalldevs() (bug #546762).
08 Apr 2015; Agostino Sarubbo <ago@gentoo.org> tcpreplay-4.0.5.ebuild:
Stable for amd64, wrt bug #545118
diff --git a/net-analyzer/tcpreplay/files/tcpreplay-4.1.0-enable-pcap_findalldevs.patch b/net-analyzer/tcpreplay/files/tcpreplay-4.1.0-enable-pcap_findalldevs.patch
new file mode 100644
index 000000000000..f45d14cd1da1
--- /dev/null
+++ b/net-analyzer/tcpreplay/files/tcpreplay-4.1.0-enable-pcap_findalldevs.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1499,6 +1499,8 @@
+ AC_MSG_WARN(Unable to do tests when cross-compiling)
+ fi
+
++disable_pcap_findalldevs=no
++
+ dnl Allows user to choose which nic to use for testing purposes
+ AC_ARG_WITH(testnic,
+ AC_HELP_STRING([--with-testnic=NIC], [Select which network card to use for testing]),
+@@ -1509,7 +1511,6 @@
+
+ dnl There's a bug in OS X which causes pcap_findalldevs() to make the wifi NIC to disassociate
+ dnl so under OSX we disable the interface list feature
+-disable_pcap_findalldevs=no
+
+ osx_frameworks=no
+ dnl these need to be dynamic based on OS
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.0.5.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.0.5-r1.ebuild
index 694d5ffa6ad0..97d24418a2ae 100644
--- a/net-analyzer/tcpreplay/tcpreplay-4.0.5.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-4.0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/tcpreplay-4.0.5.ebuild,v 1.2 2015/04/08 13:36:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/tcpreplay-4.0.5-r1.ebuild,v 1.1 2015/04/16 16:35:31 jer Exp $
EAPI=5
inherit autotools eutils flag-o-matic
@@ -11,7 +11,7 @@ LICENSE="BSD GPL-3"
SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
SLOT="0"
-KEYWORDS="amd64 ~sparc ~x86"
+KEYWORDS="~amd64 ~sparc ~x86"
IUSE="debug pcapnav +tcpdump"
DEPEND="
@@ -27,6 +27,8 @@ RDEPEND="${DEPEND}"
DOCS=( README docs/{CHANGELOG,CREDIT,HACKING,TODO} )
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.1.0-enable-pcap_findalldevs.patch
+
sed -i \
-e '/CFLAGS=/s|-ggdb -std=gnu99|-std=gnu99|g' \
-e 's|-O3||g' \
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.1.0.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.1.0-r1.ebuild
index 2731c6364b02..901eac60bdeb 100644
--- a/net-analyzer/tcpreplay/tcpreplay-4.1.0.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-4.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/tcpreplay-4.1.0.ebuild,v 1.1 2015/03/31 05:21:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/tcpreplay-4.1.0-r1.ebuild,v 1.1 2015/04/16 16:35:31 jer Exp $
EAPI=5
inherit autotools eutils flag-o-matic
@@ -27,6 +27,8 @@ RDEPEND="${DEPEND}"
DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.1.0-enable-pcap_findalldevs.patch
+
sed -i \
-e 's|-O3||g' \
-e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \