summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-02-15 22:37:02 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-02-15 22:37:02 +0000
commit312a065b98b2d42c15b761e87c59895742c7c66a (patch)
treeba716ded9480f75413f9d8770c84181fe954470d /net-analyzer/cutter
parentAdding ~amd64. (diff)
downloadgentoo-2-312a065b98b2d42c15b761e87c59895742c7c66a.tar.gz
gentoo-2-312a065b98b2d42c15b761e87c59895742c7c66a.tar.bz2
gentoo-2-312a065b98b2d42c15b761e87c59895742c7c66a.zip
Add patch from debian to fix bug #142772
(Portage version: 2.1.2-r8)
Diffstat (limited to 'net-analyzer/cutter')
-rw-r--r--net-analyzer/cutter/ChangeLog11
-rw-r--r--net-analyzer/cutter/cutter-1.02.ebuild24
-rw-r--r--net-analyzer/cutter/cutter-1.03-r1.ebuild34
-rw-r--r--net-analyzer/cutter/files/cutter-1.03-debian.patch362
-rw-r--r--net-analyzer/cutter/files/digest-cutter-1.021
-rw-r--r--net-analyzer/cutter/files/digest-cutter-1.03-r13
6 files changed, 408 insertions, 27 deletions
diff --git a/net-analyzer/cutter/ChangeLog b/net-analyzer/cutter/ChangeLog
index e61b00670d40..96808ed5f6f9 100644
--- a/net-analyzer/cutter/ChangeLog
+++ b/net-analyzer/cutter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/cutter
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cutter/ChangeLog,v 1.6 2006/02/25 23:41:20 vanquirius Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cutter/ChangeLog,v 1.7 2007/02/15 22:37:02 jokey Exp $
+
+*cutter-1.03-r1 (15 Feb 2007)
+
+ 15 Feb 2007; Markus Ullmann <jokey@gentoo.org>
+ +files/cutter-1.03-debian.patch, -cutter-1.02.ebuild,
+ +cutter-1.03-r1.ebuild:
+ Add patch from debian to fix bug #142772
26 Feb 2006; Marcelo Goes <vanquirius@gentoo.org> cutter-1.02.ebuild,
cutter-1.03.ebuild:
diff --git a/net-analyzer/cutter/cutter-1.02.ebuild b/net-analyzer/cutter/cutter-1.02.ebuild
deleted file mode 100644
index 4814ee4e5451..000000000000
--- a/net-analyzer/cutter/cutter-1.02.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cutter/cutter-1.02.ebuild,v 1.6 2006/02/25 23:41:20 vanquirius Exp $
-
-DESCRIPTION="TCP/IP Connection cutting on Linux Firewalls and Routers"
-SRC_URI="http://www.lowth.com/cutter/${P}.tgz"
-HOMEPAGE="http://www.lowth.com/cutter"
-LICENSE="GPL-2"
-DEPEND=""
-SLOT="0"
-IUSE=""
-KEYWORDS="x86"
-
-src_compile() {
- make || die
-}
-
-src_install () {
- # no make install yet, copy "cutter" to /usr/sbin
- dosbin cutter
-
- # Install documentation.
- dodoc README
-}
diff --git a/net-analyzer/cutter/cutter-1.03-r1.ebuild b/net-analyzer/cutter/cutter-1.03-r1.ebuild
new file mode 100644
index 000000000000..a778f38f7a5c
--- /dev/null
+++ b/net-analyzer/cutter/cutter-1.03-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cutter/cutter-1.03-r1.ebuild,v 1.1 2007/02/15 22:37:02 jokey Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TCP/IP Connection cutting on Linux Firewalls and Routers"
+SRC_URI="http://www.lowth.com/cutter/software/${P}.tgz"
+HOMEPAGE="http://www.lowth.com/cutter"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-debian.patch
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS} cutter.c -o cutter"
+ "$(tc-getCC)" ${CFLAGS} cutter.c -o cutter
+}
+
+src_install() {
+ dosbin cutter
+ dodoc README
+ doman debian/cutter.8
+}
diff --git a/net-analyzer/cutter/files/cutter-1.03-debian.patch b/net-analyzer/cutter/files/cutter-1.03-debian.patch
new file mode 100644
index 000000000000..e33612388476
--- /dev/null
+++ b/net-analyzer/cutter/files/cutter-1.03-debian.patch
@@ -0,0 +1,362 @@
+--- cutter-1.03.orig/Makefile
++++ cutter-1.03/Makefile
+@@ -1,5 +1,5 @@
+ cutter: cutter.c
+- cc cutter.c -o cutter
++ cc $(CFLAGS) cutter.c -o cutter
+
+ clean:
+ rm -f cutter.o cutter
+--- cutter-1.03.orig/cutter.c
++++ cutter-1.03/cutter.c
+@@ -57,6 +57,7 @@
+ #include <arpa/inet.h>
+ #include <net/if.h>
+ #include <errno.h>
++#include <time.h>
+
+ #define ETHHDR sizeof(struct ethhdr)
+ #define TCPHDR sizeof(struct tcphdr)
+@@ -149,7 +150,6 @@
+ int getmac(in_addr_t ip, uchar *mac)
+ {
+ FILE *id = fopen( "/proc/net/arp", "r" );
+- union { uchar c[4]; in_addr_t n; } ipu;
+ in_addr_t ipn;
+ int mac0, mac1, mac2, mac3, mac4, mac5;
+ int hwtype, flags;
+@@ -240,7 +240,7 @@
+ u_short toport
+ )
+ {
+- int i_result, raw_sock, rtn;
++ int i_result, raw_sock;
+ in_addr_t gateway_ip;
+ struct sockaddr_ll myaddr, hisaddr;
+ struct tpack tpack;
+@@ -377,7 +377,7 @@
+
+ for ( ; time(0) < tstart + 15; ) { // give the peer 15 seconds to respond
+ struct sockaddr_ll gotaddr;
+- int addrlen = sizeof(gotaddr);
++ unsigned int addrlen = sizeof(gotaddr);
+ fd_set readfds;
+ struct timeval tv;
+
+@@ -478,8 +478,7 @@
+ {
+ FILE *id = fopen( "/proc/net/ip_conntrack", "r" );
+ char src1[32], dst1[32], src2[32], dst2[32];
+- int sport1, dport1, sport2, dport2, i;
+- int packets1, packets2, bytes1, bytes2;
++ int sport1, dport1, sport2, dport2;
+ in_addr_t src1n, src2n, dst1n, dst2n;
+ char buff[1024], *p;
+ int found = 0;
+--- cutter-1.03.orig/debian/compat
++++ cutter-1.03/debian/compat
+@@ -0,0 +1 @@
++4
+--- cutter-1.03.orig/debian/dirs
++++ cutter-1.03/debian/dirs
+@@ -0,0 +1 @@
++usr/sbin
+--- cutter-1.03.orig/debian/rules
++++ cutter-1.03/debian/rules
+@@ -0,0 +1,79 @@
++#!/usr/bin/make -f
++# Sample debian/rules that uses debhelper.
++# GNU copyright 1997 to 1999 by Joey Hess.
++
++# Uncomment this to turn on verbose mode.
++#export DH_VERBOSE=1
++
++CFLAGS = -Wall -g
++
++ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
++ CFLAGS += -O0
++else
++ CFLAGS += -O2
++endif
++ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
++ INSTALL_PROGRAM += -s
++endif
++
++configure: configure-stamp
++configure-stamp:
++ dh_testdir
++ # Add here commands to configure the package.
++
++ touch configure-stamp
++
++
++build: build-stamp
++
++build-stamp: configure-stamp
++ dh_testdir
++
++ # Add here commands to compile the package.
++ $(MAKE) CFLAGS="$(CFLAGS)"
++
++ touch build-stamp
++
++clean:
++ dh_testdir
++ dh_testroot
++ rm -f build-stamp configure-stamp
++
++ # Add here commands to clean up after the build process.
++ -$(MAKE) clean
++
++ dh_clean
++
++install: build
++ dh_testdir
++ dh_testroot
++ dh_clean -k
++ dh_installdirs
++
++ dh_install cutter usr/sbin
++
++
++# Build architecture-independent files here.
++binary-indep: build install
++# We have nothing to do by default.
++
++# Build architecture-dependent files here.
++binary-arch: build install
++ dh_testdir
++ dh_testroot
++ dh_installchangelogs
++ dh_installdocs
++ dh_installexamples
++ dh_installman debian/cutter.8
++ dh_link
++ dh_strip
++ dh_compress
++ dh_fixperms
++ dh_installdeb
++ dh_shlibdeps
++ dh_gencontrol
++ dh_md5sums
++ dh_builddeb
++
++binary: binary-indep binary-arch
++.PHONY: build clean binary-indep binary-arch binary install configure
+--- cutter-1.03.orig/debian/docs
++++ cutter-1.03/debian/docs
+@@ -0,0 +1 @@
++README
+--- cutter-1.03.orig/debian/control
++++ cutter-1.03/debian/control
+@@ -0,0 +1,14 @@
++Source: cutter
++Section: net
++Priority: optional
++Maintainer: Aurélien GÉRÔME <ag@roxor.cx>
++Build-Depends: debhelper (>= 4.0.0)
++Standards-Version: 3.7.2
++
++Package: cutter
++Architecture: any
++Depends: ${shlibs:Depends}
++Description: disconnect routed IP connections
++ Cutter will send packets to both ends of a TCP/IP connection to close
++ the connection. It is designed to be used on a Linux router to disconnect
++ unwanted connections.
+--- cutter-1.03.orig/debian/copyright
++++ cutter-1.03/debian/copyright
+@@ -0,0 +1,27 @@
++This package was debianized by Blars Blarson <blarson@blars.org> on
++Sun, 26 Oct 2003 22:03:43 -0800.
++
++It was downloaded from http://www.lowth.com/cutter/
++
++Copyright Holder: 2003-2005 Chris Lowth <chris@lowth.com>
++
++License:
++
++ GNU GENERAL PUBLIC LICENSE Version 2, June 1991
++
++ This package is free software; you can redistribute it and/or modify
++ it under the terms of the GNU General Public License as published by
++ the Free Software Foundation; version 2 dated June, 1991.
++
++ This package is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ GNU General Public License for more details.
++
++ You should have received a copy of the GNU General Public License
++ along with this program; if not, write to the Free Software
++ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
++ 02110-1301 USA
++
++On Debian GNU/Linux systems, the complete text of the GNU General
++Public License can be found in `/usr/share/common-licenses/GPL'.
+--- cutter-1.03.orig/debian/cutter.8
++++ cutter-1.03/debian/cutter.8
+@@ -0,0 +1,124 @@
++.\" Hey, EMACS: -*- nroff -*-
++.TH CUTTER 8 "April, 2005"
++.SH NAME
++cutter \- cut tcp/ip connections
++.SH SYNOPSIS
++.B cutter
++.IR ipaddress1 \ [ \ port1 \ [ \ ipaddress2 \ [ \ port2
++\ ] \ ] \ ]
++.br
++.SH DESCRIPTION
++.B Cutter
++is an open source program that allows Linux firewall
++administrators to abort TCP/IP connections routed over the firewall or
++router on which it is run.
++.br
++.SH WARNING
++.B Cutter
++has been designed for use as a administrators tool for Linux
++firewalls. It's use (as is, or modified) for any other purpose is not
++sanctioned by the author. So - do not use this tool as a parachute, or
++to dry your cat, chill meat, answer your phone, drive you car, teach
++your kids to read or attack other people's computer systems or networks.
++.PP
++This software has been designed for
++.I legal
++and
++.I appropriate
++use
++by network security administrators and the like. It has been written as
++part of a larger Linux firewall project, targetting at controlling traffic
++from peer-to-peer software such as Kazaa, iMesh and others into and out of
++a private network. It is not designed as a tool for malicious use and the
++author in no way sanctions such use.
++.PP
++Users of the software should be aware that it's actions are easily detectable
++using a number of readily available network monitoring tools, and it makes no
++attempt to disguise it's actions. Malicious use of "cutter" could result in a
++jail sentance in a number of countries around the world.
++.PP
++The author is not responsible for the results of using this software. It
++is provided "as is" in the hope that it will be useful, but no garantees
++are made about it's use.
++.br
++.SH USAGE
++.B Cutter
++can be called using one of the following four syntaxes.
++
++.BI cutter \ ip-address
++
++.B Example:
++.RS
++.br
++.BI cutter \ 10.10.0.45
++
++Cuts all connections
++passing through the firewall
++between any ports on the specified ip-address (either a "private" or
++"public" address) and any other hosts. This can be used to close down
++all incoming connections to a particular server, all outgoing
++connections from a particular client or all outgoing connections to a
++server.
++.RE
++
++.B cutter
++.I ip-address port
++
++.B Example:
++.RS
++.br
++.B cutter
++.I 200.1.2.3 80
++
++Cuts all connections to or from the
++specified ip-address/port pair. This allows the user to be a little more
++specific than the previous example and allows targetting of specific
++services on specific hosts.
++.RE
++
++.B cutter
++.I ip-address-1 port-1 ip-address-2
++
++.B Example:
++.RS
++.br
++.B cutter
++.I 200.1.2.3 22 10.10.0.45
++
++Cuts all connections between
++ip-address-2 and ip-address-1/port-1. This allows the user to cut
++connections between a specified "client" and a particular service on a
++specified host. Our example closes host 10.10.0.45's SSH connection to
++server 200.1.2.3.
++.RE
++
++.B cutter
++.I ip-address-1 port-1 ip-address-2 port-2
++
++.B Example:
++.RS
++.br
++.B cutter
++.I 200.1.2.3 22 10.10.0.45 32451
++
++Cuts the specific connection between
++the two ip/port number pairs given.
++.RE
++.SH STATUS
++Cutter 1.03 should be considered
++.B EXPERIMENTAL.
++The author is releasing a
++tool that works on the systems he has access to (namely: IPCop and
++RedHat Linux), and he is seeking input on it's use on other systems,
++ideas for improvement, offers of sponsorship - etc.
++.PP
++.br
++.SH ADDITIONAL DOCUMENTATION
++This program is documented at
++.UR http://www.lowth.com/cutter/
++.I http://www.lowth.com/cutter/
++.UE
++.SH AUTHOR
++Blars Blarson addapted the README and web page written by Chris Lowth
++into this man page for debian package of cutter. This man page may be
++distribuated under the terms of the Gnu GPL version 2.
+--- cutter-1.03.orig/debian/changelog
++++ cutter-1.03/debian/changelog
+@@ -0,0 +1,36 @@
++cutter (1.03-2) unstable; urgency=low
++
++ * Adopt the package (Closes: #316195).
++ * Update the manpage cutter.8.
++ * Remove an old manpage manpage.1 left alone in the build system.
++
++ -- Aurélien GÉRÔME <ag@roxor.cx> Sat, 22 Jul 2006 20:00:30 +0200
++
++cutter (1.03-1) unstable; urgency=low
++
++ * QA Upload
++ * New upstream release.
++ * Move cutter.8 to debian/
++ * Conforms with new standards version
++ * Update debian/copyright (new FSF Address)
++ * Pass CFLAGS to Makefile
++ * Fix Manpage
++ + Most changes stripped from a patch provided by Christian
++ Aichinger, thanks. (Closes: #372251)
++
++ -- Michael Ablassmeier <abi@debian.org> Wed, 14 Jun 2006 09:37:08 +0200
++
++cutter (1.02-2) unstable; urgency=low
++
++ * Package is orphaned; set maintainer to QA group.
++ * Fix parsing of /proc/net/ip_conntrack for 2.6 kernels, unbreaking the
++ package for those; patch from Christian Aichinger. (Closes: #232058)
++
++ -- Steinar H. Gunderson <sesse@debian.org> Fri, 9 Jun 2006 21:08:56 +0200
++
++cutter (1.02-1) unstable; urgency=low
++
++ * Initial Release (Closes: #197698)
++ * write manpage based on readme and authors web page
++
++ -- Blars Blarson <blarson@blars.org> Sun, 26 Oct 2003 22:03:43 -0800
diff --git a/net-analyzer/cutter/files/digest-cutter-1.02 b/net-analyzer/cutter/files/digest-cutter-1.02
deleted file mode 100644
index 8a610994fd8e..000000000000
--- a/net-analyzer/cutter/files/digest-cutter-1.02
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e0eb377840b01e11e5cd008ae9b7d2af cutter-1.02.tgz 12998
diff --git a/net-analyzer/cutter/files/digest-cutter-1.03-r1 b/net-analyzer/cutter/files/digest-cutter-1.03-r1
new file mode 100644
index 000000000000..8a6f8a063bbb
--- /dev/null
+++ b/net-analyzer/cutter/files/digest-cutter-1.03-r1
@@ -0,0 +1,3 @@
+MD5 50093db9b64277643969ee75b83ebbd1 cutter-1.03.tgz 13176
+RMD160 55b7db638f171b494a8cb812d79fbb72a843174f cutter-1.03.tgz 13176
+SHA256 4df4fac7c2208afafb279abb443005bf77d3dcf01af05fe1f2898213b9109615 cutter-1.03.tgz 13176