summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-02 17:26:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-02 17:26:49 +0000
commit60799db6f8042908103ffdab70136d45df8b1d1c (patch)
tree8dd5e32c2537672f6fd2d9e6c92bb6465a375038 /media-tv
parentDo not include compiler.h, bug #168791 (diff)
downloadgentoo-2-60799db6f8042908103ffdab70136d45df8b1d1c.tar.gz
gentoo-2-60799db6f8042908103ffdab70136d45df8b1d1c.tar.bz2
gentoo-2-60799db6f8042908103ffdab70136d45df8b1d1c.zip
Fix compilation with linux-headers-2.6.20, patch from Andreas Jochens, thanks to Nicolas Boichat <nicolas@boichat.ch> for reporting that in bug #168527
(Portage version: 2.1.2-r13)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/xawtv/ChangeLog10
-rw-r--r--media-tv/xawtv/files/xawtv-3.95-pagemask-fix.patch44
-rw-r--r--media-tv/xawtv/xawtv-3.95-r1.ebuild5
3 files changed, 55 insertions, 4 deletions
diff --git a/media-tv/xawtv/ChangeLog b/media-tv/xawtv/ChangeLog
index 29299551a642..c694b2359acf 100644
--- a/media-tv/xawtv/ChangeLog
+++ b/media-tv/xawtv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/xawtv
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/ChangeLog,v 1.55 2006/12/31 18:07:46 beandog Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/ChangeLog,v 1.56 2007/03/02 17:26:49 aballier Exp $
+
+ 02 Mar 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/xawtv-3.95-pagemask-fix.patch, xawtv-3.95-r1.ebuild:
+ Fix compilation with linux-headers-2.6.20, patch from Andreas Jochens,
+ thanks to Nicolas Boichat <nicolas@boichat.ch> for reporting that in bug
+ #168527
31 Dec 2006; Steve Dibb <beandog@gentoo.org> xawtv-3.95-r1.ebuild:
Fix libpng dep, bug 150826
diff --git a/media-tv/xawtv/files/xawtv-3.95-pagemask-fix.patch b/media-tv/xawtv/files/xawtv-3.95-pagemask-fix.patch
new file mode 100644
index 000000000000..ab635f73a9ac
--- /dev/null
+++ b/media-tv/xawtv/files/xawtv-3.95-pagemask-fix.patch
@@ -0,0 +1,44 @@
+Patch from Andreas Jochens
+http://lists.debian.org/debian-qa-packages/2006/08/msg00519.html
+
+diff -urN ../tmp-orig/xawtv-3.95/console/fbtools.c ./console/fbtools.c
+--- ../tmp-orig/xawtv-3.95/console/fbtools.c 2003-02-14 14:14:04.000000000 +0000
++++ ./console/fbtools.c 2006-08-23 10:57:40.000000000 +0000
+@@ -21,8 +21,6 @@
+ #include <linux/vt.h>
+ #include <linux/fb.h>
+
+-#include <asm/page.h>
+-
+ #include "fbtools.h"
+
+ /* -------------------------------------------------------------------- */
+@@ -424,7 +422,7 @@
+ goto err;
+ }
+ #endif
+- fb_mem_offset = (unsigned long)(fb_fix.smem_start) & (~PAGE_MASK);
++ fb_mem_offset = (unsigned long)(fb_fix.smem_start) & ~(sysconf(_SC_PAGE_SIZE)-1);
+ fb_mem = mmap(NULL,fb_fix.smem_len+fb_mem_offset,
+ PROT_READ|PROT_WRITE,MAP_SHARED,fb,0);
+ if (-1L == (long)fb_mem) {
+diff -urN ../tmp-orig/xawtv-3.95/console/matrox.c ./console/matrox.c
+--- ../tmp-orig/xawtv-3.95/console/matrox.c 2005-02-03 10:40:41.000000000 +0000
++++ ./console/matrox.c 2006-08-23 11:09:51.000000000 +0000
+@@ -9,7 +9,6 @@
+ #include <sys/ioctl.h>
+ #include <sys/mman.h>
+
+-#include <asm/page.h> /* PAGE_SIZE */
+ #include <linux/fb.h>
+
+ #include "byteswap.h"
+@@ -226,7 +225,7 @@
+ return -1;
+ }
+ off = (unsigned long)fb_fix.mmio_start -
+- ((unsigned long)fb_fix.mmio_start & ~(PAGE_SIZE-1));
++ ((unsigned long)fb_fix.mmio_start & ~(sysconf(_SC_PAGE_SIZE)-1));
+ bmmio += off;
+ mmio = (uint32_t*)bmmio;
+ return 0;
diff --git a/media-tv/xawtv/xawtv-3.95-r1.ebuild b/media-tv/xawtv/xawtv-3.95-r1.ebuild
index 796b035999f3..73a84f7d0b4f 100644
--- a/media-tv/xawtv/xawtv-3.95-r1.ebuild
+++ b/media-tv/xawtv/xawtv-3.95-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.95-r1.ebuild,v 1.21 2006/12/31 18:07:46 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.95-r1.ebuild,v 1.22 2007/03/02 17:26:49 aballier Exp $
WANT_AUTOMAKE="latest"
WANT_AUTOCONF="latest"
@@ -78,6 +78,7 @@ src_unpack() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
epatch "${FILESDIR}/${P}-libquicktime-compat.patch"
+ epatch "${FILESDIR}/${P}-pagemask-fix.patch"
eautoreconf
}