summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-05 16:00:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-05 16:00:11 +0000
commit793f425bb96ccc5c3cc1fb772572696c5e7f4327 (patch)
tree1eafd360209f79ae6bc15ca181cdb550d8092434 /media-sound/xineadump
parentamd64 stable, bug #274397 (diff)
downloadgentoo-2-793f425bb96ccc5c3cc1fb772572696c5e7f4327.tar.gz
gentoo-2-793f425bb96ccc5c3cc1fb772572696c5e7f4327.tar.bz2
gentoo-2-793f425bb96ccc5c3cc1fb772572696c5e7f4327.zip
Fix building with GCC 4.4 and force revision bump because previous ebuild was missing entire src_install.
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'media-sound/xineadump')
-rw-r--r--media-sound/xineadump/ChangeLog9
-rw-r--r--media-sound/xineadump/files/xineadump-0.1-gcc-4.4.patch11
-rw-r--r--media-sound/xineadump/xineadump-0.1-r1.ebuild31
-rw-r--r--media-sound/xineadump/xineadump-0.1.ebuild21
4 files changed, 64 insertions, 8 deletions
diff --git a/media-sound/xineadump/ChangeLog b/media-sound/xineadump/ChangeLog
index 2ad8a5dc9630..77fa22af95d3 100644
--- a/media-sound/xineadump/ChangeLog
+++ b/media-sound/xineadump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/xineadump
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xineadump/ChangeLog,v 1.4 2009/04/30 19:31:14 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xineadump/ChangeLog,v 1.5 2009/07/05 16:00:11 ssuominen Exp $
+
+*xineadump-0.1-r1 (05 Jul 2009)
+
+ 05 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> xineadump-0.1.ebuild,
+ +xineadump-0.1-r1.ebuild, +files/xineadump-0.1-gcc-4.4.patch:
+ Fix building with GCC 4.4 and force revision bump because previous ebuild
+ was missing entire src_install.
30 Apr 2009; Brent Baude <ranger@gentoo.org> xineadump-0.1.ebuild:
Marking xineadump-0.1 ppc for bug 252691
diff --git a/media-sound/xineadump/files/xineadump-0.1-gcc-4.4.patch b/media-sound/xineadump/files/xineadump-0.1-gcc-4.4.patch
new file mode 100644
index 000000000000..f8e1ca1ef848
--- /dev/null
+++ b/media-sound/xineadump/files/xineadump-0.1-gcc-4.4.patch
@@ -0,0 +1,11 @@
+diff -ur xineadump.orig/src/waveencoder.cpp xineadump/src/waveencoder.cpp
+--- xineadump.orig/src/waveencoder.cpp 2007-08-05 02:39:36.000000000 +0300
++++ xineadump/src/waveencoder.cpp 2009-07-05 18:57:47.000000000 +0300
+@@ -19,6 +19,7 @@
+ ***************************************************************************/
+
+ #include "waveencoder.h"
++#include <cstdio>
+
+ #define WAVE_HEADER_SIZE 44
+ #define PCM_BUFFER_SIZE 0x10000 // 64KB
diff --git a/media-sound/xineadump/xineadump-0.1-r1.ebuild b/media-sound/xineadump/xineadump-0.1-r1.ebuild
new file mode 100644
index 000000000000..30442ff211f7
--- /dev/null
+++ b/media-sound/xineadump/xineadump-0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xineadump/xineadump-0.1-r1.ebuild,v 1.1 2009/07/05 16:00:11 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Utility for Xine decoding support in transKode"
+HOMEPAGE="http://sourceforge.net/projects/transkode"
+SRC_URI="mirror://sourceforge/transkode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/xine-lib
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-gcc-4.4.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS
+}
diff --git a/media-sound/xineadump/xineadump-0.1.ebuild b/media-sound/xineadump/xineadump-0.1.ebuild
index de961a0165f8..caefe872cb57 100644
--- a/media-sound/xineadump/xineadump-0.1.ebuild
+++ b/media-sound/xineadump/xineadump-0.1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xineadump/xineadump-0.1.ebuild,v 1.4 2009/04/30 19:31:14 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xineadump/xineadump-0.1.ebuild,v 1.5 2009/07/05 16:00:11 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Utility for Xine decoding support in transKode"
@@ -13,12 +14,18 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND="media-libs/xine-lib"
+RDEPEND="media-libs/xine-lib
+ media-libs/alsa-lib"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-gcc-4.4.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS
}