summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-03 13:10:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-03 13:10:07 +0000
commit98dccff08b2ac751c96c03fd6856dbb8503d1708 (patch)
tree464a1b84af07c7d8cce82583eeaea76bde5cde6a /media-sound/tapestrea
parentQuoting (diff)
downloadgentoo-2-98dccff08b2ac751c96c03fd6856dbb8503d1708.tar.gz
gentoo-2-98dccff08b2ac751c96c03fd6856dbb8503d1708.tar.bz2
gentoo-2-98dccff08b2ac751c96c03fd6856dbb8503d1708.zip
Workaround invalid repoman warning
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/tapestrea')
-rw-r--r--media-sound/tapestrea/tapestrea-0.1.0.4.ebuild82
-rw-r--r--media-sound/tapestrea/tapestrea-0.1.0.5.ebuild15
2 files changed, 7 insertions, 90 deletions
diff --git a/media-sound/tapestrea/tapestrea-0.1.0.4.ebuild b/media-sound/tapestrea/tapestrea-0.1.0.4.ebuild
deleted file mode 100644
index b189bed45d9c..000000000000
--- a/media-sound/tapestrea/tapestrea-0.1.0.4.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tapestrea/tapestrea-0.1.0.4.ebuild,v 1.1 2008/03/30 00:52:47 cedk Exp $
-
-EAPI="1"
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="Techniques + Paradigms for Expressive Synthesis, Transformation, Rendering of Environmental Audio"
-HOMEPAGE="http://taps.cs.princeton.edu/"
-SRC_URI="http://taps.cs.princeton.edu/release/files/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="oss jack +alsa doc"
-
-RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
- alsa? ( >=media-libs/alsa-lib-0.9 )
- media-libs/libsndfile
- virtual/glut
- virtual/opengl
- virtual/glu
- >=x11-libs/gtk+-2"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- local cnt=0
- use jack && cnt="$((${cnt} + 1))"
- use alsa && cnt="$((${cnt} + 1))"
- use oss && cnt="$((${cnt} + 1))"
- if [[ "${cnt}" -eq 0 ]] ; then
- eerror "One of the following USE flags is needed: jack, alsa or oss"
- die "Please set one audio engine type"
- elif [[ "${cnt}" -ne 1 ]] ; then
- ewarn "You have set ${P} to use multiple audio engine."
- fi
-}
-
-src_compile() {
- local backend
- if use jack; then
- backend="jack"
- elif use alsa; then
- backend="alsa"
- elif use oss; then
- backend="oss"
- fi
- einfo "Compiling against ${backend}"
-
- # when compile with athlon or athlon-xp flags
- # chuck crashes on removing a shred with a double free or corruption
- # it happens in Chuck_VM_Stack::shutdown() on the line
- # SAFE_DELETE_ARRAY( stack );
- replace-cpu-flags athlon athlon-xp i686
-
- cd "${S}/scripting/chuck-1.2.0.8/src"
- emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
-
- cd "${S}/src"
- emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
-}
-
-src_install() {
- dobin src/taps
-
- dodoc AUTHORS BUGS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
- if use doc; then
- for dir in `find examples/* -type d -maxdepth 0`; do
- docinto $dir
- dodoc `find $dir/* -type f -maxdepth 0`
- for dir2 in `find $dir/* -type d -maxdepth 0`; do
- docinto $dir2
- dodoc `find $dir2/* -type f -maxdepth 0`
- done
- done
- docinto doc
- dodoc doc/*
- fi
-}
diff --git a/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild b/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild
index 17988d33c5d1..da71e86aaaa2 100644
--- a/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild
+++ b/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild,v 1.1 2009/06/28 23:16:25 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild,v 1.2 2009/08/03 13:10:07 ssuominen Exp $
EAPI="1"
@@ -41,7 +41,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
-
cd "${S}"
epatch "${FILESDIR}/${P}-gcc44.patch"
}
@@ -75,12 +74,12 @@ src_install() {
dodoc AUTHORS BUGS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
if use doc; then
- for dir in `find examples/* -type d -maxdepth 0`; do
- docinto $dir
- dodoc `find $dir/* -type f -maxdepth 0`
- for dir2 in `find $dir/* -type d -maxdepth 0`; do
- docinto $dir2
- dodoc `find $dir2/* -type f -maxdepth 0`
+ for tapedir in `find examples/* -type d -maxdepth 0`; do
+ docinto $tapedir
+ dodoc `find $tapedir/* -type f -maxdepth 0`
+ for tapedir2 in `find $tapedir/* -type d -maxdepth 0`; do
+ docinto $tapedir2
+ dodoc `find $tapedir2/* -type f -maxdepth 0`
done
done
docinto doc