summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-08-10 15:57:25 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-08-10 15:57:25 +0000
commitb8fa15a2915af62910c4d834eb8a9fe1b2c4e9b5 (patch)
tree6310348f1b556e42b75da2d7ff71ec233ad37fdb /media-sound/audacious
parentStable for HPPA (bug #323729). (diff)
downloadgentoo-2-b8fa15a2915af62910c4d834eb8a9fe1b2c4e9b5.tar.gz
gentoo-2-b8fa15a2915af62910c4d834eb8a9fe1b2c4e9b5.tar.bz2
gentoo-2-b8fa15a2915af62910c4d834eb8a9fe1b2c4e9b5.zip
The first release candidate. Bugs still go upstream. Thank you.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-2.4_rc1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 83ac4f8873f4..18ca21c959ff 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.207 2010/08/02 21:01:04 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.208 2010/08/10 15:57:25 chainsaw Exp $
+
+*audacious-2.4_rc1 (10 Aug 2010)
+
+ 10 Aug 2010; <chainsaw@gentoo.org> +audacious-2.4_rc1.ebuild:
+ The first release candidate. Bugs still go upstream. Thank you.
*audacious-2.4_beta2 (02 Aug 2010)
diff --git a/media-sound/audacious/audacious-2.4_rc1.ebuild b/media-sound/audacious/audacious-2.4_rc1.ebuild
new file mode 100644
index 000000000000..5a804801963a
--- /dev/null
+++ b/media-sound/audacious/audacious-2.4_rc1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-2.4_rc1.ebuild,v 1.1 2010/08/10 15:57:25 chainsaw Exp $
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="altivec chardet debug nls session sse2"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ >=dev-libs/libmcs-0.7.1-r2
+ >=dev-libs/libmowgli-0.7.0
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/gtk+-2.14
+ >=x11-libs/pango-1.8.0
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-2.4_rc1"
+
+src_compile() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable altivec) \
+ $(use_enable chardet) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable session sm) \
+ $(use_enable sse2) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}