summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-02-02 04:02:02 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-02-02 04:02:02 +0000
commit3d13c700283f0bbc89950a7bcd2c25657d208561 (patch)
treeb694ae6ad104e28d0975c47dec483113b9730c26 /media-sound/audacious
parentVersion bump. New ebuild also includes many improvements such as gtk+:2 suppo... (diff)
downloadgentoo-2-3d13c700283f0bbc89950a7bcd2c25657d208561.tar.gz
gentoo-2-3d13c700283f0bbc89950a7bcd2c25657d208561.tar.bz2
gentoo-2-3d13c700283f0bbc89950a7bcd2c25657d208561.zip
Version bump. New ebuild also includes many improvements such as gtk+:2 support re-added, old configure switches dropped and more. Fixes bugs #393371 and #401293. Also, set myself as the new maintainer.
(Portage version: 2.2.0_alpha84/cvs/Linux i686)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog10
-rw-r--r--media-sound/audacious/audacious-3.2.ebuild61
-rw-r--r--media-sound/audacious/metadata.xml5
3 files changed, 73 insertions, 3 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 8be81a325f7c..4917eb6bb5dd 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.250 2012/01/17 13:22:00 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.251 2012/02/02 04:02:02 jdhore Exp $
+
+*audacious-3.2 (02 Feb 2012)
+
+ 02 Feb 2012; Jeff Horelick <jdhore@gentoo.org> +audacious-3.2.ebuild,
+ metadata.xml:
+ Version bump. New ebuild also includes many improvements such as gtk+:2
+ support re-added, old configure switches dropped and more. Fixes bugs #393371
+ and #401293. Also, set myself as the new maintainer.
17 Jan 2012; Tobias Klausmann <klausman@gentoo.org> audacious-3.1.ebuild:
Stable on alpha, bug #383991
diff --git a/media-sound/audacious/audacious-3.2.ebuild b/media-sound/audacious/audacious-3.2.ebuild
new file mode 100644
index 000000000000..11c8d131fe0b
--- /dev/null
+++ b/media-sound/audacious/audacious-3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.2.ebuild,v 1.1 2012/02/02 04:02:02 jdhore Exp $
+
+EAPI=4
+inherit eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="chardet +gtk gtk3 nls session"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/pango-1.8.0
+ gtk? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ chardet? ( >=app-i18n/libguess-1.1 )
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-3.2"
+REQUIRED_USE="^^ ( gtk gtk3 )"
+
+src_configure() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ # Use of GTK+2 causes plugin build failures, bug #384185
+ econf \
+ --enable-dbus \
+ $(use_enable gtk3) \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable session sm)
+}
+
+src_install() {
+ default
+ dodoc AUTHORS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
diff --git a/media-sound/audacious/metadata.xml b/media-sound/audacious/metadata.xml
index 1cd8056dd368..86b32ab617a0 100644
--- a/media-sound/audacious/metadata.xml
+++ b/media-sound/audacious/metadata.xml
@@ -3,10 +3,11 @@
<pkgmetadata>
<herd>sound</herd>
<maintainer>
- <email>chainsaw@gentoo.org</email>
- <name>Tony Vroon</name>
+ <email>jdhore@gentoo.org</email>
+ <name>Jeff Horelick</name>
</maintainer>
<use>
<flag name="chardet">Try to handle non-UTF8 chinese/japanese/korean ID3 tags</flag>
+ <flag name="gtk3">Link against version 3 of the GIMP Toolkit instead of version 2 (x11-libs/gtk+)</flag>
</use>
</pkgmetadata>