summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-12 07:52:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-12 07:52:53 +0000
commit9c1160d0281234b8b864e06b48896ddd06ddc65b (patch)
tree7853b1afaa8b22a56043031ebcc60232b244bbda /media-libs/vigra
parent2.2.0_alpha172 version bump. This includes all of the fixes in 2.1.11.62. (diff)
downloadgentoo-2-9c1160d0281234b8b864e06b48896ddd06ddc65b.tar.gz
gentoo-2-9c1160d0281234b8b864e06b48896ddd06ddc65b.tar.bz2
gentoo-2-9c1160d0281234b8b864e06b48896ddd06ddc65b.zip
Use python-single-r1.eclass instead of python.eclass. This ebuild should be converted to python-r1.eclass if upstream gets Python 3.x support working in the future. Use eutils.eclass instead of base.eclass for patching. Always pull in dev-lang/python:2.7 and correct shebang for /usr/bin/vigra-config wrt #465510, Comment #1 by Vicente Olivert Riera
(Portage version: 2.2.0_alpha172/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/vigra')
-rw-r--r--media-libs/vigra/ChangeLog11
-rw-r--r--media-libs/vigra/vigra-1.8.0-r1.ebuild111
2 files changed, 121 insertions, 1 deletions
diff --git a/media-libs/vigra/ChangeLog b/media-libs/vigra/ChangeLog
index d9ca6c5d20b4..5cc953e79ca7 100644
--- a/media-libs/vigra/ChangeLog
+++ b/media-libs/vigra/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/vigra
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/ChangeLog,v 1.57 2013/04/11 17:35:21 vincent Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/ChangeLog,v 1.58 2013/04/12 07:52:53 ssuominen Exp $
+
+*vigra-1.8.0-r1 (12 Apr 2013)
+
+ 12 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> +vigra-1.8.0-r1.ebuild:
+ Use python-single-r1.eclass instead of python.eclass. This ebuild should be
+ converted to python-r1.eclass if upstream gets Python 3.x support working in
+ the future. Use eutils.eclass instead of base.eclass for patching. Always
+ pull in dev-lang/python:2.7 and correct shebang for /usr/bin/vigra-config wrt
+ #465510, Comment #1 by Vicente Olivert Riera
11 Apr 2013; Vicente Olivert Riera <vincent@gentoo.org> vigra-1.8.0.ebuild:
amd64, ppc, ppc64 and x86 stable, wrt bug #465510
diff --git a/media-libs/vigra/vigra-1.8.0-r1.ebuild b/media-libs/vigra/vigra-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..595eb13d8034
--- /dev/null
+++ b/media-libs/vigra/vigra-1.8.0-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/vigra-1.8.0-r1.ebuild,v 1.1 2013/04/12 07:52:53 ssuominen Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,xml"
+
+# This ebuild could use python-r1 in the future when upstream gets Python 3.x
+# support working
+inherit cmake-utils eutils multilib python-single-r1
+
+MY_P=${P}-src
+
+DESCRIPTION="C++ computer vision library with emphasize on customizable algorithms and data structures"
+HOMEPAGE="http://hci.iwr.uni-heidelberg.de/vigra/"
+SRC_URI="http://hci.iwr.uni-heidelberg.de/vigra/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc +fftw +hdf5 +jpeg openexr +png +python test +tiff"
+
+# Pull in dev-lang/python:2.7 for vigra-config which is always installed
+RDEPEND="dev-lang/python:2.7
+ >=dev-libs/boost-1.52.0-r6[python?,${PYTHON_USEDEP}]
+ fftw? ( sci-libs/fftw:3.0 )
+ hdf5? ( sci-libs/hdf5 )
+ jpeg? ( virtual/jpeg )
+ openexr? ( media-libs/openexr:= )
+ png? ( media-libs/libpng:0= )
+ python? ( ${PYTHON_DEPS} )
+ tiff? ( media-libs/tiff:0= )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ python? ( >=dev-python/sphinx-1.1.3-r5[${PYTHON_USEDEP}] )
+ )
+ test? (
+ python? ( >=dev-python/nose-1.1.2-r1[${PYTHON_USEDEP}] )
+ )"
+REQUIRED_USE="doc? ( hdf5 fftw )
+ python? ( hdf5 )
+ test? ( hdf5 python fftw )"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-automagicness.patch \
+ "${FILESDIR}"/${P}-numpy_doc.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ # Don't build nor install API docs when not requested
+ use doc || { sed -i -e '/ADD_SUBDIRECTORY(docsrc)/d' CMakeLists.txt || die; }
+
+ # Don't use python_fix_shebang because we can't put this behind USE="python"
+ sed -i -e '/env/s:python:python2:' config/vigra-config.in || die
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+
+ # required for ddocdir
+ _check_build_dir init
+ # vigranumpy needs python and if enabled it ooms
+ # doc needs doxygen and python
+ # walgrind no use for us since we restrict test
+ # $(cmake-utils_use_with valgrind VALGRIND)
+ local mycmakeargs=(
+ -DDOCDIR="${CMAKE_BUILD_DIR}"/doc
+ -DLIBDIR_SUFFIX=${libdir/lib}
+ -DDOCINSTALL=share/doc/${PF}
+ -DWITH_VALGRIND=OFF
+ $(cmake-utils_use_with python VIGRANUMPY)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with openexr)
+ $(cmake-utils_use_with tiff)
+ $(cmake-utils_use_with fftw FFTW3)
+ $(cmake-utils_use_with hdf5)
+ $(cmake-utils_use_build test TESTING)
+ $(cmake-utils_use test CREATE_CTEST_TARGETS)
+ $(cmake-utils_use test AUTOBUILD_TESTS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_make doc
+}
+
+src_test() { :; } #390447
+
+src_install() {
+ cmake-utils_src_install
+
+ use python && python_optimize
+
+ # drop useless cmake files from libdir
+ rm -rf "${ED}"/usr/$(get_libdir)/${PN}
+}