summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-10-13 10:27:45 +0000
committerJohannes Huber <johu@gentoo.org>2013-10-13 10:27:45 +0000
commit26a4b235b6af860fc5c3f6a124de03453a46b40a (patch)
tree9b5c33057b3fbd7e50a05b0824afd8b4f330f37d /media-libs/taglib
parentUpdated Nikoli's e-mail address for easier automatic assignment. (diff)
downloadgentoo-2-26a4b235b6af860fc5c3f6a124de03453a46b40a.tar.gz
gentoo-2-26a4b235b6af860fc5c3f6a124de03453a46b40a.tar.bz2
gentoo-2-26a4b235b6af860fc5c3f6a124de03453a46b40a.zip
Version bump wrt bug #487446.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'media-libs/taglib')
-rw-r--r--media-libs/taglib/ChangeLog7
-rw-r--r--media-libs/taglib/taglib-1.9.1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/media-libs/taglib/ChangeLog b/media-libs/taglib/ChangeLog
index a9056e23afb8..afc211030c1f 100644
--- a/media-libs/taglib/ChangeLog
+++ b/media-libs/taglib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/taglib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.146 2013/08/27 19:19:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.147 2013/10/13 10:27:45 johu Exp $
+
+*taglib-1.9.1 (13 Oct 2013)
+
+ 13 Oct 2013; Johannes Huber <johu@gentoo.org> +taglib-1.9.1.ebuild:
+ Version bump wrt bug #487446.
27 Aug 2013; Alexis Ballier <aballier@gentoo.org> taglib-1.8-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/taglib/taglib-1.9.1.ebuild b/media-libs/taglib/taglib-1.9.1.ebuild
new file mode 100644
index 000000000000..3432ffda0456
--- /dev/null
+++ b/media-libs/taglib/taglib-1.9.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/taglib-1.9.1.ebuild,v 1.1 2013/10/13 10:27:45 johu Exp $
+
+EAPI=5
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake-utils
+
+DESCRIPTION="A library for reading and editing audio meta data"
+HOMEPAGE="http://developer.kde.org/~wheeler/taglib.html"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+SLOT="0"
+IUSE="+asf debug examples +mp4 test"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-install-examples.patch
+)
+
+DOCS=( AUTHORS NEWS )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build examples)
+ $(cmake-utils_use_build test TESTS)
+ $(cmake-utils_use_with asf)
+ $(cmake-utils_use_with mp4)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # ctest does not work
+ default
+}
+
+pkg_postinst() {
+ if ! use asf; then
+ elog "You've chosen to disable the asf use flag, thus taglib won't include"
+ elog "support for Microsoft's 'advanced systems format' media container"
+ fi
+ if ! use mp4; then
+ elog "You've chosen to disable the mp4 use flag, thus taglib won't include"
+ elog "support for the MPEG-4 part 14 / MP4 media container"
+ fi
+}