summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2009-07-05 12:24:53 +0000
committerMarkus Meier <maekke@gentoo.org>2009-07-05 12:24:53 +0000
commitc562fcfcdb155e3721ecc270c481784dcec7ea7b (patch)
treeb64bb184965eba64a779fe20b2e79c7a2994bfe4 /media-gfx/tic98
parentVersion bump wrt #273422. (diff)
downloadgentoo-2-c562fcfcdb155e3721ecc270c481784dcec7ea7b.tar.gz
gentoo-2-c562fcfcdb155e3721ecc270c481784dcec7ea7b.tar.bz2
gentoo-2-c562fcfcdb155e3721ecc270c481784dcec7ea7b.zip
fix building with glibc-2.10 wrt bug #273178, assign empty RDEPEND
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'media-gfx/tic98')
-rw-r--r--media-gfx/tic98/ChangeLog8
-rw-r--r--media-gfx/tic98/files/tic98-1.01-glibc-2.10.patch20
-rw-r--r--media-gfx/tic98/tic98-1.01-r3.ebuild6
3 files changed, 30 insertions, 4 deletions
diff --git a/media-gfx/tic98/ChangeLog b/media-gfx/tic98/ChangeLog
index 1784ee88dc1f..6cffdf8f9976 100644
--- a/media-gfx/tic98/ChangeLog
+++ b/media-gfx/tic98/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/tic98
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/tic98/ChangeLog,v 1.13 2008/11/15 17:12:12 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tic98/ChangeLog,v 1.14 2009/07/05 12:24:52 maekke Exp $
+
+ 05 Jul 2009; Markus Meier <maekke@gentoo.org> tic98-1.01-r3.ebuild,
+ +files/tic98-1.01-glibc-2.10.patch:
+ fix building with glibc-2.10 wrt bug #273178, assign empty RDEPEND
15 Nov 2008; Markus Meier <maekke@gentoo.org> -tic98-1.01-r2.ebuild:
old
diff --git a/media-gfx/tic98/files/tic98-1.01-glibc-2.10.patch b/media-gfx/tic98/files/tic98-1.01-glibc-2.10.patch
new file mode 100644
index 000000000000..32caf5e43477
--- /dev/null
+++ b/media-gfx/tic98/files/tic98-1.01-glibc-2.10.patch
@@ -0,0 +1,20 @@
+--- tic98.orig/ppmd_enc.c 2009-07-05 14:15:53.000000000 +0200
++++ tic98/ppmd_enc.c 2009-07-05 14:18:47.000000000 +0200
+@@ -63,7 +63,7 @@
+ }
+
+ int
+-getline (FILE *fp, char *s, int max)
++tic98_getline (FILE *fp, char *s, int max)
+ /* Read line from FP into S; return its length (maximum length = MAX). */
+ {
+ int i;
+@@ -111,7 +111,7 @@
+ ppm_start_encoding (max_order, max_symbol);
+
+ /* Read in the integers */
+- while ((len = getline (fp, line, MAX_LINE)) != EOF)
++ while ((len = tic98_getline (fp, line, MAX_LINE)) != EOF)
+ {
+ count++;
+ if ((debugProgress) && ((count % debugProgress) == 0))
diff --git a/media-gfx/tic98/tic98-1.01-r3.ebuild b/media-gfx/tic98/tic98-1.01-r3.ebuild
index e5bdf79c3605..bdaf06587cd8 100644
--- a/media-gfx/tic98/tic98-1.01-r3.ebuild
+++ b/media-gfx/tic98/tic98-1.01-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/tic98/tic98-1.01-r3.ebuild,v 1.4 2008/11/15 17:10:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tic98/tic98-1.01-r3.ebuild,v 1.5 2009/07/05 12:24:52 maekke Exp $
inherit eutils
@@ -14,6 +14,7 @@ KEYWORDS="amd64 x86"
IUSE=""
DEPEND=""
+RDEPEND=""
RESTRICT="test"
S="${WORKDIR}/${PN}"
@@ -23,6 +24,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-macos.patch
cd "${S}"
epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
# respect CFLAGS and LDFLAGS
sed -i -e "s:CFLAGS= -O -Wall -Wno-unused:CFLAGS=${CFLAGS}:" \