summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-01 12:49:08 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-01 12:49:08 +0000
commita3735c8de3cd07317b06246845b8d9b2115b86fb (patch)
treee865c24f2f741b1dda1a0f9b8c94744a48fa6441 /media-gfx/iscan
parentAdd src_test stub. libtai check.c confuses default src_test function (diff)
downloadgentoo-2-a3735c8de3cd07317b06246845b8d9b2115b86fb.tar.gz
gentoo-2-a3735c8de3cd07317b06246845b8d9b2115b86fb.tar.bz2
gentoo-2-a3735c8de3cd07317b06246845b8d9b2115b86fb.zip
Add patch to fix building with libpng 1.5. Thanks to Stefano for the patch, closes bug #419729.
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/iscan')
-rw-r--r--media-gfx/iscan/ChangeLog8
-rw-r--r--media-gfx/iscan/files/iscan-2.28.1.3+libpng-1.5.patch48
-rw-r--r--media-gfx/iscan/iscan-2.28.1.3.ebuild3
3 files changed, 56 insertions, 3 deletions
diff --git a/media-gfx/iscan/ChangeLog b/media-gfx/iscan/ChangeLog
index af87ae1a9f8f..0d7764545bc4 100644
--- a/media-gfx/iscan/ChangeLog
+++ b/media-gfx/iscan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/iscan
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/ChangeLog,v 1.49 2012/06/04 21:11:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/ChangeLog,v 1.50 2012/07/01 12:49:08 flameeyes Exp $
+
+ 01 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/iscan-2.28.1.3+libpng-1.5.patch, iscan-2.28.1.3.ebuild:
+ Add patch to fix building with libpng 1.5. Thanks to Stefano for the patch,
+ closes bug #419729.
*iscan-2.28.1.3 (04 Jun 2012)
@@ -231,4 +236,3 @@
24 Nov 2005; Stefan Briesenick <sbriesen@gentoo.org> +metadata.xml,
+iscan-1.17.0.ebuild:
initial commit.
-
diff --git a/media-gfx/iscan/files/iscan-2.28.1.3+libpng-1.5.patch b/media-gfx/iscan/files/iscan-2.28.1.3+libpng-1.5.patch
new file mode 100644
index 000000000000..7205028d8248
--- /dev/null
+++ b/media-gfx/iscan/files/iscan-2.28.1.3+libpng-1.5.patch
@@ -0,0 +1,48 @@
+--- lib/pngstream.cc 2011-12-01 02:30:53.000000000 +0100
++++ lib/pngstream.cc 2012-02-06 03:06:22.000000000 +0100
+@@ -83,7 +83,12 @@
+ #if HAVE_PNG_H
+ set_error_handler (_png, _info);
+
++/* when not interlacing (ie, only one pass), number of rows is image height: _v_sz */
++#if PNG_LIBPNG_VER > 10499
++ if (!_footer && _v_sz == lib->get_current_row_number(_png))
++#else
+ if (_header && !_footer && _png->num_rows == _png->flush_rows)
++#endif
+ {
+ lib->write_end (_png, _info);
+ _footer = true;
+@@ -167,6 +172,9 @@
+ funcsym (write_row);
+ funcsym (write_flush);
+ funcsym (write_end);
++#if PNG_LIBPNG_VER > 10499
++ funcsym (get_current_row_number);
++#endif
+
+ if (lib->access_version_number
+ && lib->create_write_struct
+@@ -176,6 +184,9 @@
+ && lib->set_IHDR
+ && lib->set_pHYs
+ && lib->set_invert_mono
++#if PNG_LIBPNG_VER > 10499
++ && lib->get_current_row_number
++#endif
+ && lib->write_info
+ && lib->write_row
+ && lib->write_flush
+--- lib/pngstream.hh 2011-12-01 02:30:53.000000000 +0100
++++ lib/pngstream.hh 2012-02-06 03:09:09.000000000 +0100
+@@ -108,6 +108,10 @@
+ png_structp);
+ fundecl (void, write_end,
+ png_structp, png_infop);
++#if PNG_LIBPNG_VER > 10499
++ fundecl (png_uint_32, get_current_row_number,
++ png_structp);
++#endif
+ #endif /* HAVE_PNG_H */
+ };
+ static png_lib_handle *lib;
diff --git a/media-gfx/iscan/iscan-2.28.1.3.ebuild b/media-gfx/iscan/iscan-2.28.1.3.ebuild
index 625dac5d026a..16a1b47b2933 100644
--- a/media-gfx/iscan/iscan-2.28.1.3.ebuild
+++ b/media-gfx/iscan/iscan-2.28.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/iscan-2.28.1.3.ebuild,v 1.1 2012/06/04 21:11:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/iscan-2.28.1.3.ebuild,v 1.2 2012/07/01 12:49:08 flameeyes Exp $
EAPI="4"
@@ -82,6 +82,7 @@ src_prepare() {
epatch "${FILESDIR}"/iscan-2.25.0-drop-ltdl.patch
epatch "${FILESDIR}"/iscan-2.25.0-fix-g++-test.patch
+ epatch "${FILESDIR}"/iscan-2.28.1.3+libpng-1.5.patch
eautoreconf
}