summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2010-06-01 14:18:05 +0000
committerJoseph Jezak <josejx@gentoo.org>2010-06-01 14:18:05 +0000
commit3219756c860619be75f7a499431ea01fcfc70c07 (patch)
tree8446bc26e0430891c442008fca6a7a340b5c6029 /media-gfx/flphoto
parentx86 stable wrt bug #321943 (diff)
downloadgentoo-2-3219756c860619be75f7a499431ea01fcfc70c07.tar.gz
gentoo-2-3219756c860619be75f7a499431ea01fcfc70c07.tar.bz2
gentoo-2-3219756c860619be75f7a499431ea01fcfc70c07.zip
Added patch to fix segfault during translation, marked ppc stable for bug #288745. Pruned old versions.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/flphoto')
-rw-r--r--media-gfx/flphoto/ChangeLog7
-rw-r--r--media-gfx/flphoto/files/espmsg.patch35
-rw-r--r--media-gfx/flphoto/flphoto-1.2.ebuild35
-rw-r--r--media-gfx/flphoto/flphoto-1.3.1-r1.ebuild6
-rw-r--r--media-gfx/flphoto/flphoto-1.3.1.ebuild35
5 files changed, 45 insertions, 73 deletions
diff --git a/media-gfx/flphoto/ChangeLog b/media-gfx/flphoto/ChangeLog
index f0b9fb490774..8ebe45557093 100644
--- a/media-gfx/flphoto/ChangeLog
+++ b/media-gfx/flphoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/flphoto
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/ChangeLog,v 1.18 2010/04/16 18:47:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/ChangeLog,v 1.19 2010/06/01 14:18:04 josejx Exp $
+
+ 01 Jun 2010; Joseph Jezak <josejx@gentoo.org> -flphoto-1.2.ebuild,
+ -flphoto-1.3.1.ebuild, flphoto-1.3.1-r1.ebuild, +files/espmsg.patch:
+ Added patch to fix segfault during translation, marked ppc stable for bug
+ #288745. Pruned old versions.
16 Apr 2010; Markos Chandras <hwoarang@gentoo.org>
flphoto-1.3.1-r1.ebuild:
diff --git a/media-gfx/flphoto/files/espmsg.patch b/media-gfx/flphoto/files/espmsg.patch
new file mode 100644
index 000000000000..7be3c29ce161
--- /dev/null
+++ b/media-gfx/flphoto/files/espmsg.patch
@@ -0,0 +1,35 @@
+--- espmsg.c 2005-01-23 03:52:44.000000000 +0000
++++ espmsg.c 2010-06-01 14:06:06.983548480 +0000
+@@ -270,14 +270,18 @@
+ compile_messages(const char *filename) /* I - Message filename */
+ {
+ int i; /* Looping var */
+- char msgname[1024], /* Message filename */
+- orig[1024], /* Original message text */
+- text[1024], /* Message text */
++ char *msgname, /* Message filename */
++ *orig, /* Original message text */
++ *text, /* Message text */
+ *ptr; /* Pointer into filename */
+ int num_msgs; /* Number of messages */
+ espmsg_t *msgs; /* Messages */
+ message_t *temp; /* Current message */
+
++ msgname = (char *)malloc(4096);
++ orig = (char *)malloc(4096);
++ text = (char *)malloc(4096);
++
+
+ num_msgs = 0;
+ msgs = NULL;
+@@ -307,6 +311,10 @@
+ strerror(errno));
+ else
+ printf("espmsg: Compiled %d messages into \"%s\".\n", num_msgs, msgname);
++
++ free(msgname);
++ free(orig);
++ free(text);
+ }
+
+
diff --git a/media-gfx/flphoto/flphoto-1.2.ebuild b/media-gfx/flphoto/flphoto-1.2.ebuild
deleted file mode 100644
index 5827fda07cec..000000000000
--- a/media-gfx/flphoto/flphoto-1.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.2.ebuild,v 1.8 2008/11/23 20:25:34 halcy0n Exp $
-
-EAPI=1
-
-inherit eutils
-
-DESCRIPTION="Basic image management and display program based on the FLTK toolkit"
-HOMEPAGE="http://www.easysw.com/~mike/flphoto/"
-SRC_URI="mirror://sourceforge/fltk/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE="cups gphoto2"
-
-DEPEND=">=x11-libs/fltk-1.1.4:1.1
- cups? ( net-print/cups )
- gphoto2? ( media-gfx/gphoto2 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/flphoto-1.3.1-glibc28.patch
-}
-
-src_compile() {
- econf || die
- emake -j1 || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-}
diff --git a/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild b/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild
index 77ebcaf86697..b3a09fd78e39 100644
--- a/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild
+++ b/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild,v 1.4 2010/04/16 18:47:46 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1-r1.ebuild,v 1.5 2010/06/01 14:18:04 josejx Exp $
EAPI=1
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/fltk/${P}-source.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
+KEYWORDS="amd64 ppc x86"
IUSE="cups gphoto2"
DEPEND=">=x11-libs/fltk-1.1.4:1.1
@@ -30,6 +30,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/flphoto-1.3.1-glibc28.patch
+ ### Patch to fix segfault on PowerPC
+ epatch "${FILESDIR}"/espmsg.patch
}
src_compile() {
diff --git a/media-gfx/flphoto/flphoto-1.3.1.ebuild b/media-gfx/flphoto/flphoto-1.3.1.ebuild
deleted file mode 100644
index 1a21cb2da172..000000000000
--- a/media-gfx/flphoto/flphoto-1.3.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1.ebuild,v 1.4 2010/01/19 12:14:06 cla Exp $
-
-EAPI=1
-
-inherit eutils
-
-DESCRIPTION="Basic image management and display program based on the FLTK toolkit"
-HOMEPAGE="http://www.easysw.com/~mike/flphoto/"
-SRC_URI="mirror://sourceforge/fltk/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="cups gphoto2"
-
-DEPEND=">=x11-libs/fltk-1.1.4:1.1
- cups? ( net-print/cups )
- gphoto2? ( media-gfx/gphoto2 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/flphoto-1.3.1-glibc28.patch
-}
-
-src_compile() {
- econf --with-docdir=/usr/share/doc/${PF} || die
- emake -j1 || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-}