summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-08-02 07:51:15 +0000
committerTorsten Veller <tove@gentoo.org>2009-08-02 07:51:15 +0000
commit32b91993344ba373c12eff834d355d6540b190cf (patch)
tree9932eb5c32f40b51e4c3c135aababbc9a6564fac /mail-filter/bogofilter
parentformat like the other games eclasses (diff)
downloadgentoo-2-32b91993344ba373c12eff834d355d6540b190cf.tar.gz
gentoo-2-32b91993344ba373c12eff834d355d6540b190cf.tar.bz2
gentoo-2-32b91993344ba373c12eff834d355d6540b190cf.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter/bogofilter')
-rw-r--r--mail-filter/bogofilter/ChangeLog7
-rw-r--r--mail-filter/bogofilter/bogofilter-1.2.1.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index 87cf34be8be4..3e2ba02a1a91 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.119 2009/05/02 14:48:26 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.120 2009/08/02 07:51:15 tove Exp $
+
+*bogofilter-1.2.1 (02 Aug 2009)
+
+ 02 Aug 2009; Torsten Veller <tove@gentoo.org> +bogofilter-1.2.1.ebuild:
+ Version bump
02 May 2009; Torsten Veller <tove@gentoo.org> -bogofilter-1.1.7.ebuild:
Cleanup
diff --git a/mail-filter/bogofilter/bogofilter-1.2.1.ebuild b/mail-filter/bogofilter/bogofilter-1.2.1.ebuild
new file mode 100644
index 000000000000..a8c4b33659b8
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-1.2.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.2.1.ebuild,v 1.1 2009/08/02 07:51:15 tove Exp $
+
+inherit db-use flag-o-matic
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb sqlite"
+
+DEPEND="virtual/libiconv
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.5.4 )
+ !sqlite? ( >=sys-libs/db-3.2 ) )
+ sci-libs/gsl"
+# app-arch/pax" # only needed for bf_tar
+
+src_compile() {
+ local myconf="" berkdb=true
+ myconf="--without-included-gsl"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ elog "Both useflags berkdb and sqlite are in USE:"
+ elog "Using berkdb as database backend."
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ berkdb=false
+ elif ! use berkdb ; then
+ elog "Neither berkdb nor sqlite are in USE:"
+ elog "Using berkdb as database backend."
+ fi
+
+ # Include the right berkdb headers for FreeBSD
+ if ${berkdb} ; then
+ append-flags "-I$(db_includedir)"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl || die "doexec failed"
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/vm-bogofilter.el \
+ contrib/{trainbogo,scramble}.sh || die "doins failed"
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite} || die "dodoc failed"
+
+ dohtml doc/*.html
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/
+ rmdir "${D}"/etc
+}
+
+pkg_postinst() {
+ echo
+ elog "If you need \"${ROOT}usr/bin/bf_tar\" please install app-arch/pax."
+ echo
+}