summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-07-29 14:44:12 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-07-29 14:44:12 +0000
commit6fde6bb45a5966bda384e86a2b6d8d296afc4510 (patch)
treedf745d3fa62b832d012353d7815255b85034f68f /lxde-base
parentAdded media-gfx/imagemagick do RDEPEND. (diff)
downloadgentoo-2-6fde6bb45a5966bda384e86a2b6d8d296afc4510.tar.gz
gentoo-2-6fde6bb45a5966bda384e86a2b6d8d296afc4510.tar.bz2
gentoo-2-6fde6bb45a5966bda384e86a2b6d8d296afc4510.zip
Version bump to 0.5.6 , includes bugfixes and translations
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxpanel/ChangeLog7
-rw-r--r--lxde-base/lxpanel/lxpanel-0.5.6.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/lxde-base/lxpanel/ChangeLog b/lxde-base/lxpanel/ChangeLog
index bc885f1cddef..fac63e0f3485 100644
--- a/lxde-base/lxpanel/ChangeLog
+++ b/lxde-base/lxpanel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for lxde-base/lxpanel
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.20 2010/02/28 18:35:47 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.21 2010/07/29 14:44:12 vostorga Exp $
+
+*lxpanel-0.5.6 (29 Jul 2010)
+
+ 29 Jul 2010; Víctor Ostorga <vostorga@gentoo.org> +lxpanel-0.5.6.ebuild:
+ Version bump to 0.5.6 , includes bugfixes and translations
28 Feb 2010; nixnut <nixnut@gentoo.org> lxpanel-0.5.5.ebuild:
ppc stable #306433
diff --git a/lxde-base/lxpanel/lxpanel-0.5.6.ebuild b/lxde-base/lxpanel/lxpanel-0.5.6.ebuild
new file mode 100644
index 000000000000..e6534012689f
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.5.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.5.6.ebuild,v 1.1 2010/07/29 14:44:12 vostorga Exp $
+
+EAPI="2"
+inherit eutils autotools
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="http://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="+alsa"
+RESTRICT="test" # bug 249598
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/libXpm
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.1-sandbox.patch
+ eautoreconf
+}
+
+src_configure() {
+ local plugins=all
+ [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
+
+ econf $(use_enable alsa) --with-x --with-plugins=${plugins}
+ # the gtk+ dep already pulls in libX11, so we might as well hardcode with-x
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}