summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
committerChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
commit461c1af9ab4c8cfbdc911a491f7c86af2ef043dd (patch)
tree05608ce8b58bb6826c888fa542fb8c351b8e650b /kde-base/kmail
parentUse QA_PREBUILT, fix minor QA issues, wrt bug #430026 (diff)
downloadgentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.gz
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.bz2
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.zip
Version bump KDE SC 4.9.5
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog9
-rw-r--r--kde-base/kmail/kmail-4.9.5.ebuild87
2 files changed, 94 insertions, 2 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index fc70aa4b4d37..6fc7c2d6b16b 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.322 2012/12/23 12:13:38 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.323 2013/01/05 20:18:58 creffett Exp $
+
+*kmail-4.9.5 (05 Jan 2013)
+
+ 05 Jan 2013; <creffett@gentoo.org> +kmail-4.9.5.ebuild:
+ Version bump KDE SC 4.9.5
23 Dec 2012; Markus Meier <maekke@gentoo.org> kmail-4.9.4.ebuild:
add ~arm
diff --git a/kde-base/kmail/kmail-4.9.5.ebuild b/kde-base/kmail/kmail-4.9.5.ebuild
new file mode 100644
index 000000000000..61034ed4b4d4
--- /dev/null
+++ b/kde-base/kmail/kmail-4.9.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.9.5.ebuild,v 1.1 2013/01/05 20:18:58 creffett Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+VIRTUALX_REQUIRED=test
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# bug 393147
+
+KMEXTRACTONLY="
+ akonadi_next/
+ archivemailagent/
+ calendarsupport/
+ korganizer/
+ kresources/
+ libkleo/
+ libkpgp/
+ libkdepimdbusinterfaces/
+ kdgantt2/
+"
+KMCOMPILEONLY="
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ templateparser/
+ incidenceeditor-ng/
+ calendarsupport/
+"
+KMEXTRA="
+ archivemailagent/
+ backupmail/
+ kmailcvt/
+ ksendemail/
+ importwizard/
+ libksieve/
+ mailcommon/
+ mailfilteragent/
+ mailimporter/
+ ontologies/
+ plugins/messageviewer/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+}