summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-02-22 13:52:51 +0000
committerAron Griffis <agriffis@gentoo.org>2006-02-22 13:52:51 +0000
commit7961e2b1e125693f43107a347f7d2d037adea583 (patch)
tree7de10c7f09c2dd50a1b36657f8b74d6c40bd8333 /gnome-base/gconf
parentVersion bump. (diff)
downloadgentoo-2-7961e2b1e125693f43107a347f7d2d037adea583.tar.gz
gentoo-2-7961e2b1e125693f43107a347f7d2d037adea583.tar.bz2
gentoo-2-7961e2b1e125693f43107a347f7d2d037adea583.zip
Fix compilation with gcc-4. Add patch to fix compilation when LINGUAS
contains zh #114805 (Portage version: 2.1_pre4-r1)
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog8
-rw-r--r--gnome-base/gconf/files/gconf-1.0.9-gcc4.patch23
-rw-r--r--gnome-base/gconf/files/gconf-1.0.9-linguas.patch14
-rw-r--r--gnome-base/gconf/gconf-1.0.9.ebuild6
4 files changed, 48 insertions, 3 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 4c3ae1c3de05..140b17a4a56f 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.134 2006/02/03 17:14:43 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.135 2006/02/22 13:52:51 agriffis Exp $
+
+ 22 Feb 2006; Aron Griffis <agriffis@gentoo.org>
+ +files/gconf-1.0.9-gcc4.patch, +files/gconf-1.0.9-linguas.patch,
+ gconf-1.0.9.ebuild:
+ Fix compilation with gcc-4. Add patch to fix compilation when LINGUAS
+ contains zh #114805
03 Feb 2006; Guy Martin <gmsoft@gentoo.org> gconf-2.12.1.ebuild:
Stable on hppa.
diff --git a/gnome-base/gconf/files/gconf-1.0.9-gcc4.patch b/gnome-base/gconf/files/gconf-1.0.9-gcc4.patch
new file mode 100644
index 000000000000..0d02cb359ef1
--- /dev/null
+++ b/gnome-base/gconf/files/gconf-1.0.9-gcc4.patch
@@ -0,0 +1,23 @@
+These functions are declared external in a header file, then defined with
+static, the mismatch is an error with gcc4
+
+--- GConf-1.0.9/backends/bdb.c.agriffis 2006-02-21 08:55:42.000000000 -0500
++++ GConf-1.0.9/backends/bdb.c 2006-02-21 08:55:51.000000000 -0500
+@@ -331,7 +331,7 @@
+
+ /* } */
+
+-static guint32
++guint32
+ get_dir_id (BDB_Store * bdb, const char *dir)
+ {
+ int ret;
+@@ -405,7 +405,7 @@
+
+ /* { Functions to create directories and maintain the dir hierarchy */
+
+-static guint32
++guint32
+ get_or_create_dir (BDB_Store * bdb, const char *dir)
+ {
+ guint32 parent_id;
diff --git a/gnome-base/gconf/files/gconf-1.0.9-linguas.patch b/gnome-base/gconf/files/gconf-1.0.9-linguas.patch
new file mode 100644
index 000000000000..9f28a1dc613a
--- /dev/null
+++ b/gnome-base/gconf/files/gconf-1.0.9-linguas.patch
@@ -0,0 +1,14 @@
+Fix bug 114805: gnome-base/gconf-1.0.9 fails to compile if LINGUAS contains zh
+
+diff -ruN GConf-1.0.9.orig/configure GConf-1.0.9/configure
+--- GConf-1.0.9.orig/configure 2005-12-07 14:50:19.000000000 -0800
++++ GConf-1.0.9/configure 2005-12-07 14:51:26.000000000 -0800
+@@ -10475,7 +10475,7 @@
+ NEW_LINGUAS=
+ for lang in ${LINGUAS=$ALL_LINGUAS}; do
+ case "$ALL_LINGUAS" in
+- *$lang*) NEW_LINGUAS="$NEW_LINGUAS $lang" ;;
++ $lang|*\ $lang|$lang\ *|*\ $lang\ *) NEW_LINGUAS="$NEW_LINGUAS $lang" ;;
+ esac
+ done
+ LINGUAS=$NEW_LINGUAS
diff --git a/gnome-base/gconf/gconf-1.0.9.ebuild b/gnome-base/gconf/gconf-1.0.9.ebuild
index 86ebe598fc6f..11ec48935c13 100644
--- a/gnome-base/gconf/gconf-1.0.9.ebuild
+++ b/gnome-base/gconf/gconf-1.0.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.9.ebuild,v 1.18 2005/07/09 15:58:38 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.9.ebuild,v 1.19 2006/02/22 13:52:51 agriffis Exp $
inherit libtool gnome.org eutils gnuconfig
@@ -33,6 +33,8 @@ src_unpack() {
unpack ${A}
EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/gconfd-2-fix.patch
epatch ${FILESDIR}/${P}-locallock_mdk.patch
+ epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch ${FILESDIR}/${P}-linguas.patch
mkdir ${S}/intl
touch ${S}/intl/libgettext.h