summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-07-16 17:13:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-07-16 17:13:05 +0000
commit00973845ae24533039f74075a7219610ffbeb578 (patch)
tree6fcb0f5dafba2976654c5e108fb3364c4fe51265 /games-sports
parentmarked x86 per bug 426840 (diff)
downloadgentoo-2-00973845ae24533039f74075a7219610ffbeb578.tar.gz
gentoo-2-00973845ae24533039f74075a7219610ffbeb578.tar.bz2
gentoo-2-00973845ae24533039f74075a7219610ffbeb578.zip
version bump (bug #426216)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/xmoto/ChangeLog8
-rw-r--r--games-sports/xmoto/files/xmoto-0.5.10-gcc47.patch10
-rw-r--r--games-sports/xmoto/files/xmoto-0.5.10-utf8.patch15
-rw-r--r--games-sports/xmoto/xmoto-0.5.10.ebuild94
4 files changed, 126 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index 86f8cedc4360..eb8339ddb9ed 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.64 2012/06/12 18:15:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.65 2012/07/16 17:13:05 mr_bones_ Exp $
+
+*xmoto-0.5.10 (16 Jul 2012)
+
+ 16 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org> +xmoto-0.5.10.ebuild,
+ +files/xmoto-0.5.10-gcc47.patch, +files/xmoto-0.5.10-utf8.patch:
+ version bump (bug #426216)
12 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> xmoto-0.5.9.ebuild,
+files/xmoto-0.5.9-gcc47.patch:
diff --git a/games-sports/xmoto/files/xmoto-0.5.10-gcc47.patch b/games-sports/xmoto/files/xmoto-0.5.10-gcc47.patch
new file mode 100644
index 000000000000..eb0843ef35ba
--- /dev/null
+++ b/games-sports/xmoto/files/xmoto-0.5.10-gcc47.patch
@@ -0,0 +1,10 @@
+--- src/helpers/System.cpp.old 2012-06-12 11:01:24.332083600 +0200
++++ src/helpers/System.cpp 2012-06-12 11:01:35.335083715 +0200
+@@ -24,6 +24,7 @@
+ #include "Log.h"
+ #include "VExcept.h"
+ #include <sstream>
++#include <unistd.h>
+
+ std::vector<std::string>* System::getDisplayModes(int windowed) {
+ std::vector<std::string>* modes = new std::vector<std::string>;
diff --git a/games-sports/xmoto/files/xmoto-0.5.10-utf8.patch b/games-sports/xmoto/files/xmoto-0.5.10-utf8.patch
new file mode 100644
index 000000000000..5a9c5a499f93
--- /dev/null
+++ b/games-sports/xmoto/files/xmoto-0.5.10-utf8.patch
@@ -0,0 +1,15 @@
+http://todo.xmoto.tuxfamily.org/index.php?do=details&task_id=778
+
+--- src/helpers/utf8.h.orig
++++ src/helpers/utf8.h
+@@ -18,8 +18,8 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ =============================================================================*/
+
+-#ifndef __UTF8_H__
+-#define __UTF8_H__
++#ifndef __XMOTO_UTF8_H__
++#define __XMOTO_UTF8_H__
+
+ #include <vector>
+ #include <string>
diff --git a/games-sports/xmoto/xmoto-0.5.10.ebuild b/games-sports/xmoto/xmoto-0.5.10.ebuild
new file mode 100644
index 000000000000..5612619221ca
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.5.10.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.5.10.ebuild,v 1.1 2012/07/16 17:13:05 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+LVL_PV="0.7.0" #they unfortunately don't release both at the same time, why ~ as separator :(
+LVL="inksmoto-${LVL_PV}"
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/xmoto/xmoto/${PV}/${P}-src.tar.gz
+ editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${LVL_PV}/${LVL}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="editor nls"
+
+RDEPEND="
+ dev-libs/libxdg-basedir
+ dev-db/sqlite:3
+ dev-games/ode
+ dev-lang/lua[deprecated]
+ virtual/jpeg
+ media-libs/libpng
+ dev-libs/libxml2
+ media-libs/libsdl[joystick,opengl]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ net-misc/curl
+ app-arch/bzip2
+ virtual/opengl
+ virtual/glu
+ media-fonts/dejavu
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ editor? ( media-gfx/inkscape )"
+
+src_prepare() {
+ use editor && rm -vf "${WORKDIR}"/extensions/{bezmisc,inkex}.py
+ sed -i \
+ -e '/^gettextsrcdir/s:=.*:= @localedir@/gettext/po:' \
+ po/Makefile.in.in || die
+
+ epatch \
+ "${FILESDIR}"/${P}-utf8.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ # bug #289792
+ filter-flags -DdDOUBLE
+ has_version 'dev-games/ode[double-precision]' && append-flags -DdDOUBLE
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-threads=posix \
+ $(use_enable nls) \
+ --localedir=/usr/share/locale \
+ --with-localesdir=/usr/share/locale \
+ --with-renderer-sdlGfx=0 \
+ --with-renderer-openGl=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README TODO NEWS ChangeLog || die
+
+ rm -f "${D}${GAMES_DATADIR}/xmoto"/Textures/Fonts/DejaVuSans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}/xmoto"/Textures/Fonts/DejaVuSans.ttf
+ doicon extra/xmoto.xpm
+ make_desktop_entry xmoto Xmoto
+
+ prepgamesdirs
+
+ if use editor; then
+ insinto /usr/share/inkscape/
+ doins -r "${WORKDIR}"/extensions/ || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use editor; then
+ elog "If you want to know how to create Xmoto levels"
+ elog "have a look at this Tutorial:"
+ elog " http://wiki.xmoto.tuxfamily.org/index.php?title=Inksmoto-${LVL_PV}"
+ elog "You can share your levels on the Xmoto homepage."
+ fi
+}