summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-03-09 18:30:11 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-03-09 18:30:11 +0000
commit26a2bf5136cefa6dd289e2a73eb58a595d46b193 (patch)
treeefce6011d57534673fe524cc9220f33985873b69 /games-fps/xonotic
parentStable 1.0.1 on both amd64 and x86 as it does what it should. (diff)
downloadgentoo-2-26a2bf5136cefa6dd289e2a73eb58a595d46b193.tar.gz
gentoo-2-26a2bf5136cefa6dd289e2a73eb58a595d46b193.tar.bz2
gentoo-2-26a2bf5136cefa6dd289e2a73eb58a595d46b193.zip
Version bump to 0.6.0. No factical changes apart from bumped dep on d0_blind_id and einfo on media-libs/libtxc_dxtn. Fixes bug#407531.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'games-fps/xonotic')
-rw-r--r--games-fps/xonotic/ChangeLog10
-rw-r--r--games-fps/xonotic/xonotic-0.6.0.ebuild108
2 files changed, 116 insertions, 2 deletions
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
index a6c5f04524ed..7b83033eaee8 100644
--- a/games-fps/xonotic/ChangeLog
+++ b/games-fps/xonotic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/xonotic
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.4 2011/11/11 09:20:06 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.5 2012/03/09 18:30:11 scarabeus Exp $
+
+*xonotic-0.6.0 (09 Mar 2012)
+
+ 09 Mar 2012; Tomáš Chvátal <scarabeus@gentoo.org> +xonotic-0.6.0.ebuild:
+ Version bump to 0.6.0. No factical changes apart from bumped dep on
+ d0_blind_id and einfo on media-libs/libtxc_dxtn. Fixes bug#407531.
11 Nov 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> xonotic-0.5.0.ebuild:
x86 stable wrt bug #389269
diff --git a/games-fps/xonotic/xonotic-0.6.0.ebuild b/games-fps/xonotic/xonotic-0.6.0.ebuild
new file mode 100644
index 000000000000..d920c264cb57
--- /dev/null
+++ b/games-fps/xonotic/xonotic-0.6.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.6.0.ebuild,v 1.1 2012/03/09 18:30:11 scarabeus Exp $
+
+EAPI=3
+inherit eutils check-reqs games
+
+MY_PN="${PN^}"
+DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
+HOMEPAGE="http://www.xonotic.org/"
+SRC_URI="http://dl.xonotic.org/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug dedicated doc sdl"
+
+UIRDEPEND="
+ media-libs/libogg
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/libmodplug
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ virtual/opengl
+ media-libs/freetype:2
+ alsa? ( media-libs/alsa-lib )
+ sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video,alsa?] )"
+UIDEPEND="
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto"
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg
+ media-libs/libpng
+ net-misc/curl
+ ~dev-libs/d0_blind_id-0.5
+ !dedicated? ( ${UIRDEPEND} )"
+DEPEND="${RDEPEND}
+ !dedicated? ( ${UIDEPEND} )"
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_setup() {
+ CHECKREQS_DISK_BUILD="1200M"
+ CHECKREQS_DISK_USR="950M"
+ check-reqs_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ rm -rf misc/buildfiles/ # use system libs
+
+ sed -i \
+ -e "/^EXE_/s:darkplaces:${PN}:" \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "/-lm/s:$: ${LDFLAGS}:" \
+ -e '/^STRIP/s/strip/true/' \
+ source/darkplaces/makefile.inc || die
+
+ if ! use alsa; then
+ sed -i \
+ -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
+ source/darkplaces/makefile || die
+ fi
+}
+
+src_compile() {
+ local t="$(use debug && echo debug || echo release)"
+ local d
+
+ for d in sv-${t} $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})")
+ do
+ emake \
+ DP_LINK_TO_LIBJPEG=1 DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
+ -C source/darkplaces ${d} || die
+ done
+}
+
+src_install() {
+ if ! use dedicated; then
+ dogamesbin source/darkplaces/${PN}-glx || die
+ newicon misc/logos/${PN}_icon.svg ${PN}.svg
+ make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
+
+ if use sdl; then
+ dogamesbin source/darkplaces/${PN}-sdl || die
+ make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
+ fi
+ fi
+ dogamesbin source/darkplaces/${PN}-dedicated || die
+
+ dodoc Docs/*.txt
+ use doc && dohtml -r Docs
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r key_0.d0pk server data || die
+ prepgamesdirs
+
+ einfo "If you are using opensource drivers you should condider installing: "
+ einfo " media-libs/libtxc_dxtn"
+}