summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-08-02 23:02:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-08-02 23:02:25 +0000
commita6cc0c306e50be7bd0433eca5654a71b91771979 (patch)
tree8edb5f00bda0a77d04aae1dc42f5eba75cd00fd7 /games-engines
parentVersion bump for dev channel release. This version builds with gcc-4.7.1, res... (diff)
downloadgentoo-2-a6cc0c306e50be7bd0433eca5654a71b91771979.tar.gz
gentoo-2-a6cc0c306e50be7bd0433eca5654a71b91771979.tar.bz2
gentoo-2-a6cc0c306e50be7bd0433eca5654a71b91771979.zip
add missing freetype to IUSE
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog8
-rw-r--r--games-engines/scummvm/metadata.xml1
-rw-r--r--games-engines/scummvm/scummvm-1.5.0.ebuild78
3 files changed, 86 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 75da2f22290d..0a72c57a7d08 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.113 2012/04/15 16:52:45 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.114 2012/08/02 23:02:25 mr_bones_ Exp $
+
+*scummvm-1.5.0 (02 Aug 2012)
+
+ 02 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> +scummvm-1.5.0.ebuild,
+ metadata.xml:
+ version bump
15 Apr 2012; Markus Meier <maekke@gentoo.org> scummvm-1.4.1.ebuild:
x86 stable, bug #411529
diff --git a/games-engines/scummvm/metadata.xml b/games-engines/scummvm/metadata.xml
index e3d97a7f3c63..52c07baf7d84 100644
--- a/games-engines/scummvm/metadata.xml
+++ b/games-engines/scummvm/metadata.xml
@@ -4,5 +4,6 @@
<herd>games</herd>
<use>
<flag name="fluidsynth">compile with support for fluidsynth</flag>
+ <flag name="freetype">use media-libs/freetype for font rendering</flag>
</use>
</pkgmetadata>
diff --git a/games-engines/scummvm/scummvm-1.5.0.ebuild b/games-engines/scummvm/scummvm-1.5.0.ebuild
new file mode 100644
index 000000000000..baf252994378
--- /dev/null
+++ b/games-engines/scummvm/scummvm-1.5.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.5.0.ebuild,v 1.1 2012/08/02 23:02:25 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="alsa debug flac fluidsynth freetype mp3 vorbis"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2[audio,joystick,video]
+ >media-libs/libmpeg2-0.3.1
+ sys-libs/zlib
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( media-libs/alsa-lib )
+ mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ freetype? ( media-libs/freetype:2 )
+ fluidsynth? ( media-sound/fluidsynth )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ configure || die
+ sed -i \
+ -e '/INSTALL.*doc/d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk || die
+}
+
+src_configure() {
+ local myconf
+
+ # bug #137547
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+
+ use x86 && append-ldflags -Wl,-z,noexecstack
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ ./configure \
+ --backend=sdl \
+ --host=$CHOST \
+ --enable-verbose-build \
+ --prefix=/usr \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}"/${PN} \
+ --libdir="${GAMES_LIBDIR}" \
+ --enable-zlib \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable vorbis) \
+ $(use_enable freetype freetype2) \
+ $(use_enable x86 nasm) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README TODO
+ doicon icons/scummvm.svg
+ make_desktop_entry scummvm ScummVM scummvm "Game;AdventureGame"
+ prepgamesdirs
+}