summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-02 18:53:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-02 18:53:11 +0000
commita47798f84bbdcf7742b8c8a22f4006b5d27ffe82 (patch)
tree0f98fc363d36c396140b363f7f2b3a9aac06e258 /games-engines
parentClosing #36445 (diff)
downloadgentoo-2-a47798f84bbdcf7742b8c8a22f4006b5d27ffe82.tar.gz
gentoo-2-a47798f84bbdcf7742b8c8a22f4006b5d27ffe82.tar.bz2
gentoo-2-a47798f84bbdcf7742b8c8a22f4006b5d27ffe82.zip
Add patch to compile against new Alsa (bug 36191)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog7
-rw-r--r--games-engines/scummvm/Manifest5
-rw-r--r--games-engines/scummvm/files/0.5.1-alsa.patch22
-rw-r--r--games-engines/scummvm/scummvm-0.5.1.ebuild14
4 files changed, 41 insertions, 7 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 53bf273afcc4..d675a703cc43 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/scummvm
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.3 2003/11/28 01:12:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.4 2004/01/02 18:53:00 mr_bones_ Exp $
+
+ 02 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org> scummvm-0.5.1.ebuild,
+ files/0.5.1-alsa.patch:
+ Add patch to compile against new Alsa; contributed by Danny van Dyk via bug
+ 36191
27 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> scummvm-0.5.1.ebuild:
fix mad depend (bug 34575)
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index 9cdb0c88bd0f..47a738609039 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1,4 +1,5 @@
-MD5 0cd5efaedf1c19ee4a62dfccef61596d ChangeLog 2645
-MD5 25e0cd7a2e18522be250f05b101e3193 scummvm-0.5.1.ebuild 1416
+MD5 295f121c8d01de8db47930432fdcbed2 ChangeLog 2835
+MD5 50e403116f0db8644ca90a60fafaafd8 scummvm-0.5.1.ebuild 1502
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 ece3781510db9d2d60fcabd88eb576a8 files/0.5.1-alsa.patch 777
MD5 a05cefcb4e86dbf7d1c4592029bf7195 files/digest-scummvm-0.5.1 67
diff --git a/games-engines/scummvm/files/0.5.1-alsa.patch b/games-engines/scummvm/files/0.5.1-alsa.patch
new file mode 100644
index 000000000000..37528000b51c
--- /dev/null
+++ b/games-engines/scummvm/files/0.5.1-alsa.patch
@@ -0,0 +1,22 @@
+--- backends/midi/alsa.cpp 2003-07-06 20:19:54.000000000 +0000
++++ backends/midi/alsa.cpp.patched 2004-01-02 17:13:45.268397592 +0000
+@@ -37,6 +37,11 @@
+ * (you really rox, you know?)
+ */
+
++#if SND_LIB_MAJOR >= 1
++#define snd_seq_flush_output(x) snd_seq_drain_output(x)
++#define snd_seq_set_client_group(x,name) /*nop */
++#define my_snd_seq_open(seqp) snd_seq_open(seqp, "hw", SND_SEQ_OPEN_OUTPUT, 0)
++#else
+ #if SND_LIB_MINOR >= 6
+ #define snd_seq_flush_output(x) snd_seq_drain_output(x)
+ #define snd_seq_set_client_group(x,name) /*nop */
+@@ -45,6 +50,7 @@
+ /* SND_SEQ_OPEN_OUT causes oops on early version of ALSA */
+ #define my_snd_seq_open(seqp) snd_seq_open(seqp, SND_SEQ_OPEN)
+ #endif
++#endif
+
+ /*
+ * parse address string
diff --git a/games-engines/scummvm/scummvm-0.5.1.ebuild b/games-engines/scummvm/scummvm-0.5.1.ebuild
index 8f7f568d2541..0bbd460a0151 100644
--- a/games-engines/scummvm/scummvm-0.5.1.ebuild
+++ b/games-engines/scummvm/scummvm-0.5.1.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.5.1.ebuild,v 1.3 2003/11/28 01:12:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.5.1.ebuild,v 1.4 2004/01/02 18:53:00 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
HOMEPAGE="http://scummvm.sourceforge.net/"
SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+KEYWORDS="x86 ppc"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
IUSE="alsa oggvorbis mad"
DEPEND="media-libs/libsdl
@@ -19,6 +19,12 @@ DEPEND="media-libs/libsdl
alsa? ( media-libs/alsa-lib )
mad? ( media-libs/libmad )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${PV}-alsa.patch"
+}
+
src_compile() {
egamesconf \
`use_with alsa` \