summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-12-26 20:22:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-12-26 20:22:09 +0000
commit79b55fa805eb830f9ceddb461f8e0f8cc8c58342 (patch)
tree5ebe23c69ca7c3cd9ade9b82902383eec219056e /games-emulation/snes9x
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-79b55fa805eb830f9ceddb461f8e0f8cc8c58342.tar.gz
gentoo-2-79b55fa805eb830f9ceddb461f8e0f8cc8c58342.tar.bz2
gentoo-2-79b55fa805eb830f9ceddb461f8e0f8cc8c58342.zip
tidy; error check
(Portage version: 2.0.53)
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/snes9x-1.43-r1.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/games-emulation/snes9x/snes9x-1.43-r1.ebuild b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
index 41eb30efe1fa..09a3aff80d9a 100644
--- a/games-emulation/snes9x/snes9x-1.43-r1.ebuild
+++ b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.4 2005/12/26 19:29:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.5 2005/12/26 20:22:09 mr_bones_ Exp $
# 3dfx support (glide) is disabled because it requires
# glide-v2 while we only provide glide-v3 in portage
@@ -35,15 +35,20 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"/snes9x
- epatch "${FILESDIR}"/nojoy.patch
- epatch "${FILESDIR}"/${P}-porting.patch
- epatch "${FILESDIR}"/${P}-key-bindings-fix.patch #81980
- sed -i 's:png_jmpbuf:png_write_info:g' configure
-
rm offsets # stupid prebuilt file
- sed -i -e 's:-lXext -lX11::' Makefile.in
- sed -i -e '/X_LDFLAGS=/d' configure
- epatch "${FILESDIR}"/${P}-build.patch
+ sed -i \
+ -e 's:-lXext -lX11::' Makefile.in \
+ || die "sed failed"
+ epatch \
+ "${FILESDIR}"/nojoy.patch \
+ "${FILESDIR}"/${P}-porting.patch \
+ "${FILESDIR}"/${P}-key-bindings-fix.patch \
+ "${FILESDIR}"/${P}-build.patch
+
+ sed -i \
+ -e 's:png_jmpbuf:png_write_info:g' \
+ -e '/X_LDFLAGS=/d' \
+ configure || die "sed failed"
autoconf || die
}