summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-01 22:50:44 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-01 22:50:44 +0000
commit5538b5f89296dfffe75bdca97696bcf17d794628 (patch)
treed5769a0736d961ef851cab7a2f8b1780dea6c8dd /games-emulation/snes9x
parentStable on Alpha, bug 152573. (diff)
downloadgentoo-2-5538b5f89296dfffe75bdca97696bcf17d794628.tar.gz
gentoo-2-5538b5f89296dfffe75bdca97696bcf17d794628.tar.bz2
gentoo-2-5538b5f89296dfffe75bdca97696bcf17d794628.zip
Use autotools eclass
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/ChangeLog5
-rw-r--r--games-emulation/snes9x/files/digest-snes9x-1.43-r12
-rw-r--r--games-emulation/snes9x/snes9x-1.43-r1.ebuild28
3 files changed, 19 insertions, 16 deletions
diff --git a/games-emulation/snes9x/ChangeLog b/games-emulation/snes9x/ChangeLog
index 0cfb71e38428..0b370c02229a 100644
--- a/games-emulation/snes9x/ChangeLog
+++ b/games-emulation/snes9x/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/snes9x
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.24 2006/04/13 20:33:52 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.25 2006/11/01 22:50:44 nyhm Exp $
+
+ 01 Nov 2006; Tristan Heaven <nyhm@gentoo.org> snes9x-1.43-r1.ebuild:
+ Use autotools eclass
13 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org> snes9x-1.43-r1.ebuild:
Moved games_pkg_setup to the beginning of pkg_setup.
diff --git a/games-emulation/snes9x/files/digest-snes9x-1.43-r1 b/games-emulation/snes9x/files/digest-snes9x-1.43-r1
index b8b43bedd773..ba95f02c5719 100644
--- a/games-emulation/snes9x/files/digest-snes9x-1.43-r1
+++ b/games-emulation/snes9x/files/digest-snes9x-1.43-r1
@@ -1 +1,3 @@
MD5 2b86716203b6ce1dbfe0395c66bb46b5 snes9x-1.43-src.tar.gz 1016251
+RMD160 d2003f7afb208109405b41f4eec586b93518f9b2 snes9x-1.43-src.tar.gz 1016251
+SHA256 cb60baaeabc28b68f7dfc8fd54453f6268b66aae33ea64eb1788c19df09be6f1 snes9x-1.43-src.tar.gz 1016251
diff --git a/games-emulation/snes9x/snes9x-1.43-r1.ebuild b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
index 583a401a9769..afd819811a62 100644
--- a/games-emulation/snes9x/snes9x-1.43-r1.ebuild
+++ b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.10 2006/10/19 14:55:38 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.11 2006/11/01 22:50:44 nyhm Exp $
# 3dfx support (glide) is disabled because it requires
# glide-v2 while we only provide glide-v3 in portage
# http://bugs.gentoo.org/show_bug.cgi?id=93097
-inherit eutils flag-o-matic multilib games
+WANT_AUTOCONF=latest
+inherit autotools eutils flag-o-matic multilib games
DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
HOMEPAGE="http://www.snes9x.com/"
@@ -15,24 +16,21 @@ SRC_URI="http://www.lysator.liu.se/snes9x/${PV}/snes9x-${PV}-src.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="opengl joystick zlib dga debug"
+IUSE="debug dga joystick opengl zlib"
-RDEPEND="|| ( ( x11-libs/libXext
- dga? ( x11-libs/libXxf86dga
- x11-libs/libXxf86vm ) )
- virtual/x11 )
+RDEPEND="x11-libs/libXext
+ dga? ( x11-libs/libXxf86dga
+ x11-libs/libXxf86vm )
media-libs/libpng
amd64? ( app-emulation/emul-linux-x86-xlibs )
- opengl? (
- virtual/opengl
+ opengl? ( virtual/opengl
virtual/glu )"
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )
- || ( ( x11-proto/xextproto
- x11-proto/xproto
- dga? ( x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto ) )
- virtual/x11 )"
+ x11-proto/xextproto
+ x11-proto/xproto
+ dga? ( x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto )"
S=${WORKDIR}/${P}-src
@@ -55,7 +53,7 @@ src_unpack() {
-e '/X_LDFLAGS=/d' \
configure.in || die "sed failed"
- autoconf || die
+ eautoconf
}
src_compile() {