summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-12 14:56:01 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-12 14:56:01 +0000
commitda4b59eada1874c68004a77a9ca1341520eabddc (patch)
tree855f3a1f69e670a8e7fc10edf0d2ea2d45c8193a /games-arcade/pachi
parentStable on sparc (diff)
downloadgentoo-2-da4b59eada1874c68004a77a9ca1341520eabddc.tar.gz
gentoo-2-da4b59eada1874c68004a77a9ca1341520eabddc.tar.bz2
gentoo-2-da4b59eada1874c68004a77a9ca1341520eabddc.zip
Install menu entry, bug #160240
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-arcade/pachi')
-rw-r--r--games-arcade/pachi/ChangeLog7
-rw-r--r--games-arcade/pachi/files/1.0-autotools.patch20
-rw-r--r--games-arcade/pachi/pachi-1.0.ebuild16
3 files changed, 24 insertions, 19 deletions
diff --git a/games-arcade/pachi/ChangeLog b/games-arcade/pachi/ChangeLog
index 3f4d30ab40f2..1a33fe760595 100644
--- a/games-arcade/pachi/ChangeLog
+++ b/games-arcade/pachi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/pachi
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pachi/ChangeLog,v 1.10 2006/09/20 16:46:54 blubb Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pachi/ChangeLog,v 1.11 2007/03/12 14:56:01 nyhm Exp $
+
+ 12 Mar 2007; Tristan Heaven <nyhm@gentoo.org> pachi-1.0.ebuild:
+ Install menu entry, bug #160240
20 Sep 2006; <blubb@gentoo.org> pachi-1.0.ebuild:
stable on amd64
diff --git a/games-arcade/pachi/files/1.0-autotools.patch b/games-arcade/pachi/files/1.0-autotools.patch
index 0dd52e7e336c..0d0185f142f3 100644
--- a/games-arcade/pachi/files/1.0-autotools.patch
+++ b/games-arcade/pachi/files/1.0-autotools.patch
@@ -1,16 +1,14 @@
-diff -ru PachiOrig/configure.in Pachi/configure.in
---- PachiOrig/configure.in 2002-12-01 19:24:03.000000000 +0100
-+++ Pachi/configure.in 2004-03-31 17:29:55.230515320 +0200
-@@ -1,5 +1,8 @@
+--- configure.in
++++ configure.in
+@@ -1,5 +1,7 @@
# Process this file with autoconf to produce a configure script.
+AC_PREREQ([2.54])
-+
AC_INIT(src/faes.cpp, 0.1, T-1000@Bigfoot.com)
+AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE(pachi, 0.1)
AM_CONFIG_HEADER(config.h)
-@@ -44,7 +47,7 @@
+@@ -44,7 +46,7 @@
SCOREDIR="."
else
DATADIR="$datadir/$PACKAGE"
@@ -19,9 +17,8 @@ diff -ru PachiOrig/configure.in Pachi/configure.in
fi
eval DATAPATH=`eval echo "$DATADIR"`
-diff -ru PachiOrig/data/Makefile.am Pachi/data/Makefile.am
---- PachiOrig/data/Makefile.am 2002-12-08 14:30:17.000000000 +0100
-+++ Pachi/data/Makefile.am 2004-03-31 16:53:10.424696752 +0200
+--- data/Makefile.am
++++ data/Makefile.am
@@ -10,13 +10,13 @@
objects_v2.dat \
rooms_v2.dat
@@ -42,3 +39,8 @@ diff -ru PachiOrig/data/Makefile.am Pachi/data/Makefile.am
+ for file in $(score_DATA_); do \
+ $(INSTALL) -g $(group) -m $(perms) $$file $(DESTDIR)$(scoredir); \
+ done
+--- Makefile.am
++++ Makefile.am
+@@ -1 +1 @@
+-SUBDIRS = src Tgfx data fonts music sounds docs
++SUBDIRS = src Tgfx data fonts music sounds
diff --git a/games-arcade/pachi/pachi-1.0.ebuild b/games-arcade/pachi/pachi-1.0.ebuild
index 3b32c857fc1e..01f4bc9ae2e2 100644
--- a/games-arcade/pachi/pachi-1.0.ebuild
+++ b/games-arcade/pachi/pachi-1.0.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pachi/pachi-1.0.ebuild,v 1.8 2006/10/17 02:45:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pachi/pachi-1.0.ebuild,v 1.9 2007/03/12 14:56:01 nyhm Exp $
-WANT_AUTOMAKE=latest
inherit autotools eutils games
DESCRIPTION="platform game inspired by games like Manic Miner and Jet Set Willy"
@@ -17,22 +16,23 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2
- media-libs/sdl-mixer
- sys-libs/zlib"
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer"
S=${WORKDIR}/Pachi
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PV}-autotools.patch"
+ epatch "${FILESDIR}"/${PV}-autotools.patch
+ rm -f missing
eautoreconf
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- rm -rf "${D}/usr/share/games/doc"
+ newicon Tgfx/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Pachi /usr/share/pixmaps/${PN}.bmp
dodoc AUTHORS ChangeLog README
prepgamesdirs
}