summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-04-14 18:43:46 +0000
committerMike Gilbert <floppym@gentoo.org>2012-04-14 18:43:46 +0000
commitd49050a27fccb6d914678df977494f5ea9054571 (patch)
tree419238747bbb1be472690f5aa64492d1b756c9a1 /dev-vcs
parentUpdate depends in >=0.5.60 ebuilds, thanks to 0xd34df00d (diff)
downloadgentoo-2-d49050a27fccb6d914678df977494f5ea9054571.tar.gz
gentoo-2-d49050a27fccb6d914678df977494f5ea9054571.tar.bz2
gentoo-2-d49050a27fccb6d914678df977494f5ea9054571.zip
Version bump. Add LINGUAS support.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog7
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index 26c782e32769..3a168ae9c565 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.12 2012/03/15 03:24:39 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.13 2012/04/14 18:43:46 floppym Exp $
+
+*tortoisehg-2.3.1 (14 Apr 2012)
+
+ 14 Apr 2012; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.3.1.ebuild:
+ Version bump. Add LINGUAS support.
15 Mar 2012; Mike Gilbert <floppym@gentoo.org> -tortoisehg-2.2.2-r1.ebuild,
-tortoisehg-2.2.2.ebuild, tortoisehg-2.3.ebuild, tortoisehg-9999.ebuild:
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild
new file mode 100644
index 000000000000..89662903b8cb
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild,v 1.1 2012/04/14 18:43:46 floppym Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-pypy-*"
+
+inherit distutils eutils multilib
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ KEYWORDS=""
+ SRC_URI=""
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc nautilus"
+
+RDEPEND="dev-python/iniparse
+ dev-python/pygments
+ dev-python/PyQt4
+ dev-python/qscintilla-python
+ >=dev-vcs/mercurial-2.0
+ nautilus? ( dev-python/nautilus-python )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+src_prepare() {
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+
+ if [[ ${LINGUAS+set} ]]; then
+ pushd i18n/tortoisehg > /dev/null || die
+ local x y
+ for x in *.po; do
+ keep=
+ for y in ${LINGUAS}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=1
+ break
+ fi
+ done
+ [[ ${keep} ]] || rm "${x}" || die
+ done
+ popd > /dev/null || die
+ fi
+
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO
+
+ if use doc ; then
+ dohtml -r doc/build/html || die
+ fi
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
+ domenu contrib/${PN}.desktop
+
+ if ! use nautilus; then
+ rm -r "${ED}usr/$(get_libdir)/nautilus" || die
+ fi
+}