summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-25 23:03:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-25 23:03:15 +0000
commit9fb549fe691dbc122b7136cdea636bad539657c6 (patch)
tree39d58f413d641cbd0c0ee93981f2b8da64d30a29 /dev-util
parentRemove unused local description. (diff)
downloadgentoo-2-9fb549fe691dbc122b7136cdea636bad539657c6.tar.gz
gentoo-2-9fb549fe691dbc122b7136cdea636bad539657c6.tar.bz2
gentoo-2-9fb549fe691dbc122b7136cdea636bad539657c6.zip
Version bump. Remove obsolete.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/boost-build/ChangeLog11
-rw-r--r--dev-util/boost-build/boost-build-1.46.1.ebuild111
-rw-r--r--dev-util/boost-build/boost-build-1.53.0_beta1.ebuild (renamed from dev-util/boost-build/boost-build-1.51.0.ebuild)33
3 files changed, 23 insertions, 132 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index 9e3bff50e099..703c336c8116 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/boost-build
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.111 2012/12/08 12:11:22 grobian Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.112 2013/01/25 23:03:15 flameeyes Exp $
+
+*boost-build-1.53.0_beta1 (25 Jan 2013)
+
+ 25 Jan 2013; Diego E. Pettenò <flameeyes@gentoo.org>
+ +boost-build-1.53.0_beta1.ebuild, -boost-build-1.46.1.ebuild,
+ -boost-build-1.51.0.ebuild:
+ Version bump. Remove obsolete.
08 Dec 2012; Fabian Groffen <grobian@gentoo.org>
+files/boost-build-1.49.0-darwin-gentoo-toolchain.patch,
diff --git a/dev-util/boost-build/boost-build-1.46.1.ebuild b/dev-util/boost-build/boost-build-1.46.1.ebuild
deleted file mode 100644
index 65771da0ca10..000000000000
--- a/dev-util/boost-build/boost-build-1.46.1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.46.1.ebuild,v 1.10 2012/10/31 16:32:18 flameeyes Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic toolchain-funcs versionator
-
-MY_PV=$(replace_all_version_separators _)
-MAJOR_PV="$(replace_all_version_separators _ $(get_version_component_range 1-2))"
-
-DESCRIPTION="A system for large project software construction, which is simple to use and powerful."
-HOMEPAGE="http://www.boost.org/doc/tools/build/index.html"
-SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
-LICENSE="Boost-1.0"
-SLOT=0
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="examples python"
-
-DEPEND="!<dev-libs/boost-1.34.0
- !<=dev-util/boost-build-1.35.0-r1
- python? ( dev-lang/python )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/boost_${MY_PV}/tools/build/v2"
-
-src_unpack() {
- tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build/v2 || die "unpacking tar failed"
-}
-
-src_prepare() {
- # TODO:
- # epatch "${FILESDIR}/boost-1.42-fix-mpich2-detection.patch"
-
- cd "${S}/engine"
- epatch "${FILESDIR}/${PN}-1.42-env-whitespace.patch" # 293652
-
- # Remove stripping option
- cd "${S}/engine/src"
- sed -i -e 's|-s\b||' \
- build.jam || die "sed failed"
-
- # Force regeneration
- rm jambase.c
-
- # This patch allows us to fully control optimization
- # and stripping flags when bjam is used as build-system
- # We simply extend the optimization and debug-symbols feature
- # with empty dummies called 'none'
- cd "${S}"
- sed -i \
- -e 's/\(off speed space\)/\1 none/' \
- -e 's/\(debug-symbols : on off\)/\1 none/' \
- tools/builtin.jam || die "sed failed"
-}
-
-src_compile() {
- cd engine/src
- local toolset
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- toolset=darwin
- else
- # Using boost's generic toolset here, which respects CC and CFLAGS
- toolset=cc
- fi
-
- append-flags -fno-strict-aliasing
-
- # For slotting
- sed -i \
- -e "s|/usr/share/boost-build|/usr/share/boost-build-${MAJOR_PV}|" \
- Jambase || die "sed failed"
-
- # The build.jam file for building bjam using a bootstrapped jam0 ignores
- # the LDFLAGS env var (bug #209794). We have now two options:
- # a) change the cc-target definition in build.jam to include separate compile
- # and link targets to make it use the LDFLAGS var, or
- # b) a simple dirty workaround by injecting the LDFLAGS in the LIBS env var
- # (which should not be set by us).
- if [[ -z "${LDFLAGS}" ]] ; then
- CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) \
- || die "building bjam failed"
- else
- LDFLAGS=$(echo ${LDFLAGS}) # 293652
- LIBS=${LDFLAGS} CC=$(tc-getCC) ./build.sh ${toolset} \
- $(use_with python) || die "building bjam failed"
- fi
-}
-
-src_install() {
- newbin engine/src/bin.*/bjam bjam-${MAJOR_PV}
-
- cd "${S}"
- insinto /usr/share/boost-build-${MAJOR_PV}
- doins -r boost-build.jam bootstrap.jam build-system.jam site-config.jam user-config.jam \
- build kernel options tools util || die
-
- dodoc changes.txt hacking.txt release_procedure.txt \
- notes/build_dir_option.txt notes/relative_source_paths.txt
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r example
- fi
-}
-
-src_test() {
- cd engine/test
- ./test.sh || die "tests failed"
-}
diff --git a/dev-util/boost-build/boost-build-1.51.0.ebuild b/dev-util/boost-build/boost-build-1.53.0_beta1.ebuild
index be900ec1a2a2..916740df39f0 100644
--- a/dev-util/boost-build/boost-build-1.51.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.53.0_beta1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.51.0.ebuild,v 1.2 2012/10/31 16:32:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.53.0_beta1.ebuild,v 1.1 2013/01/25 23:03:15 flameeyes Exp $
EAPI="5"
PYTHON_DEPEND="python? 2"
@@ -8,7 +8,6 @@ PYTHON_DEPEND="python? 2"
inherit eutils flag-o-matic python toolchain-funcs versionator
MY_PV=$(replace_all_version_separators _)
-MAJOR_PV="$(replace_all_version_separators _ $(get_version_component_range 1-2))"
DESCRIPTION="A system for large project software construction, which is simple to use and powerful."
HOMEPAGE="http://www.boost.org/doc/tools/build/index.html"
@@ -16,7 +15,7 @@ SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
LICENSE="Boost-1.0"
SLOT=0
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-aix ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="examples python test"
REQUIRED_USE="test? ( python )"
@@ -36,7 +35,7 @@ pkg_setup() {
}
src_unpack() {
- tar xjpf "${DISTDIR}/${A}" ./boost_${MY_PV}/tools/build/v2 || die "unpacking tar failed"
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build/v2 || die "unpacking tar failed"
}
src_prepare() {
@@ -44,7 +43,9 @@ src_prepare() {
"${FILESDIR}/${PN}-1.48.0-support_dots_in_python-buildid.patch" \
"${FILESDIR}/${PN}-1.48.0-disable_python_rpath.patch" \
"${FILESDIR}/${PN}-1.50.0-respect-c_ld-flags.patch" \
- "${FILESDIR}/${PN}-1.50.0-fix-test.patch"
+ "${FILESDIR}/${PN}-1.50.0-fix-test.patch" \
+ "${FILESDIR}/${PN}-1.49.0-darwin-gentoo-toolchain.patch" \
+ "${FILESDIR}/${PN}-1.52.0-darwin-no-python-framework.patch"
# Remove stripping option
cd "${S}/engine"
@@ -66,11 +67,6 @@ src_prepare() {
}
src_configure() {
- # For slotting
- sed -i \
- -e "s|/usr/share/boost-build|/usr/share/boost-build-${MAJOR_PV}|" \
- engine/Jambase || die "sed failed"
-
if use python; then
# replace versions by user-selected one (TODO: fix this when slot-op
# deps are available to always match the best version available)
@@ -92,21 +88,20 @@ src_compile() {
toolset=cc
fi
- CC=$(tc-getCC) ./build.sh ${toolset} -d+2 $(use_with python python /usr) || die "building bjam failed"
+ CC=$(tc-getCC) ./build.sh ${toolset} -d+2 $(use_with python python "${EROOT}"/usr) || die "building bjam failed"
}
src_install() {
- newbin engine/bin.*/bjam bjam-${MAJOR_PV}
- newbin engine/bin.*/b2 b2-${MAJOR_PV}
+ dobin engine/bin.*/{bjam,b2}
- insinto /usr/share/boost-build-${MAJOR_PV}
+ insinto /usr/share/boost-build
doins -r "${FILESDIR}/site-config.jam" \
boost-build.jam bootstrap.jam build-system.jam user-config.jam *.py \
build kernel options tools util
- rm "${D}/usr/share/boost-build-${MAJOR_PV}/build/project.ann.py" || die "removing faulty python file failed"
+ rm "${ED}/usr/share/boost-build/build/project.ann.py" || die "removing faulty python file failed"
if ! use python; then
- find "${D}/usr/share/boost-build-${MAJOR_PV}" -iname "*.py" -delete || die "removing experimental python files failed"
+ find "${ED}/usr/share/boost-build" -iname "*.py" -delete || die "removing experimental python files failed"
fi
dodoc changes.txt hacking.txt release_procedure.txt \
@@ -132,9 +127,9 @@ src_test() {
}
pkg_postinst() {
- use python && python_mod_optimize /usr/share/boost-build-${MAJOR_PV}
+ use python && python_mod_optimize /usr/share/boost-build
}
pkg_postrm() {
- use python && python_mod_cleanup /usr/share/boost-build-${MAJOR_PV}
+ use python && python_mod_cleanup /usr/share/boost-build
}