summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-07-13 18:23:13 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-07-13 18:23:13 +0000
commited82661efb51f2898d597e59fdbbfad102a52459 (patch)
tree4dec3d950ace75cc9e74acbb9279f4a2964bb97b /dev-tcltk
parentVersion bump. Added explicit casting to certain headers so that C++ applicati... (diff)
downloadgentoo-2-ed82661efb51f2898d597e59fdbbfad102a52459.tar.gz
gentoo-2-ed82661efb51f2898d597e59fdbbfad102a52459.tar.bz2
gentoo-2-ed82661efb51f2898d597e59fdbbfad102a52459.zip
bumps so that expect doesn't install mkpasswd, which net-misc/whois is supposed to install. The fixed ebuilds were given to us by: stan <stan@saticed.me.uk> in bug #51353 by Carsten Lohrke <carlo@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog10
-rw-r--r--dev-tcltk/expect/Manifest4
-rw-r--r--dev-tcltk/expect/expect-5.37.1-r2.ebuild106
-rw-r--r--dev-tcltk/expect/expect-5.40.0-r1.ebuild85
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.37.1-r21
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.40.0-r11
6 files changed, 206 insertions, 1 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 51dc44e53cca..f3ef6a07460d 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-tcltk/expect
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.19 2004/06/25 02:06:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.20 2004/07/13 18:23:13 seemant Exp $
+
+*expect-5.37.1-r2 (13 Jul 2004)
+
+ 13 Jul 2004; Seemant Kulleen <seemant@gentoo.org> +expect-5.37.1-r2.ebuild,
+ +expect-5.40.0-r1.ebuild:
+ bumps so that expect doesn't install mkpasswd, which net-misc/whois is
+ supposed to install. The fixed ebuilds were given to us by: stan
+ <stan@saticed.me.uk> in bug #51353 by Carsten Lohrke <carlo@gentoo.org>
31 May 2004; Tom Gall <tgall@gentoo.org> expect-5.40.0.ebuild:
stable on ppc64 bug #52630
diff --git a/dev-tcltk/expect/Manifest b/dev-tcltk/expect/Manifest
index f06abe91ee33..f1aa1a6acb43 100644
--- a/dev-tcltk/expect/Manifest
+++ b/dev-tcltk/expect/Manifest
@@ -1,6 +1,10 @@
MD5 b8e40d30c56383e32020464f83748a87 expect-5.40.0.ebuild 1782
+MD5 6cc8725c0704d6f85aebaa74e4802033 expect-5.37.1-r2.ebuild 3289
MD5 a15812d97737f672a6d9337ddd345e48 expect-5.37.1-r1.ebuild 1823
+MD5 1c0a4d5539d638846613f4449c44cbcd expect-5.40.0-r1.ebuild 2561
MD5 4352fe376b5eb159a5aff408fbb9ec58 ChangeLog 2895
MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
MD5 56f93170a590d0db63d826802dcc9847 files/digest-expect-5.40.0 65
MD5 f4bfc81e857154719e1924f00b505ea3 files/digest-expect-5.37.1-r1 65
+MD5 f4bfc81e857154719e1924f00b505ea3 files/digest-expect-5.37.1-r2 65
+MD5 56f93170a590d0db63d826802dcc9847 files/digest-expect-5.40.0-r1 65
diff --git a/dev-tcltk/expect/expect-5.37.1-r2.ebuild b/dev-tcltk/expect/expect-5.37.1-r2.ebuild
new file mode 100644
index 000000000000..9f41e9bb5e6f
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.37.1-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1-r2.ebuild,v 1.4 2004/07/13 18:23:13 seemant Exp $
+
+inherit gnuconfig
+
+#remove the trailing ".0" from the tarball version
+NON_MICRO_V=${P%.[0-9]}
+S=${WORKDIR}/${NON_MICRO_V}
+
+DESCRIPTION="tool for automating interactive applications"
+HOMEPAGE="http://expect.nist.gov/"
+SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha ~mips hppa amd64"
+IUSE="X doc"
+
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
+
+src_unpack() {
+ unpack ${A}
+ sed -i 's#/usr/local/bin#/usr/bin#' ${S}/expect.man
+ sed -i 's#/usr/local/bin#/usr/bin#' ${S}/expectk.man
+ #stops any example scripts being installed by default
+ sed -i 's/^SCRIPTS =/G_SCRIPTS =/' ${S}/Makefile.in
+ sed -i 's/^SCRIPTS_MANPAGES =/G_SCRIPTS_MANPAGES =/' ${S}/Makefile.in
+
+ cat >${WORKDIR}/sed.examples.gentoo <<HERE
+1s;#!\\.\\.;#!/usr/bin;
+1s;#!/depot/path;#!/usr/bin;
+HERE
+
+ cat >${WORKDIR}/Makefile.examples.gentoo <<HERE
+include Makefile
+
+gentoo_examples:
+ for i in \$(G_SCRIPTS) ; do \\
+ if [ -f \$(srcdir)/example/\$\$i ] ; then \\
+ \$(INSTALL_PROGRAM) \$(srcdir)/example/\$\$i \\
+ ${D}/usr/share/doc/${PF}/examples/\$\$i ; \\
+ sed -i -f ${WORKDIR}/sed.examples.gentoo \\
+ ${D}/usr/share/doc/${PF}/examples/\$\$i ; \\
+ fi ; \\
+ done
+
+ for i in \$(G_SCRIPTS_MANPAGES) ; do \\
+ if [ -f \$(srcdir)/example/\$\$i.man ] ; then \\
+ \$(INSTALL_DATA) \$(srcdir)/example/\$\$i.man \\
+ ${D}/usr/share/doc/${PF}/examples/\$\$i.1 ; \\
+ gzip ${D}/usr/share/doc/${PF}/examples/\$\$i.1 ; \\
+ fi ; \\
+ done
+
+HERE
+}
+
+src_compile() {
+ if [ "${ARCH}" == "amd64" ]; then
+ gnuconfig_update
+ fi
+
+ local myconf
+ local tclv
+ local tkv
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ #tkv isn't really needed, included for symmetry and the future
+ tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+
+ #configure needs to find the files tclConfig.sh and tclInt.h
+ myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
+
+ if use X; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=/usr/lib"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf --enable-shared || die
+ emake || die
+}
+
+src_install () {
+ make install INSTALL_ROOT=${D} || die
+
+ dodoc ChangeLog FAQ HISTORY NEWS README
+
+ local static_lib="lib${NON_MICRO_V/-/}.a"
+ rm ${D}/usr/lib/${NON_MICRO_V/-/}/${static_lib}
+
+ #install examples if 'doc' is set
+ if use doc; then
+ docinto examples
+ dodoc example/README
+ make -f ${WORKDIR}/Makefile.examples.gentoo gentoo_examples
+ fi
+}
diff --git a/dev-tcltk/expect/expect-5.40.0-r1.ebuild b/dev-tcltk/expect/expect-5.40.0-r1.ebuild
new file mode 100644
index 000000000000..611db74ae48c
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.40.0-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.40.0-r1.ebuild,v 1.1 2004/07/13 18:23:13 seemant Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="tool for automating interactive applications"
+HOMEPAGE="http://expect.nist.gov/"
+SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ppc64"
+IUSE="X doc"
+
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
+
+NON_MICRO_V=${P%.[0-9]}
+S=${WORKDIR}/${NON_MICRO_V}
+
+src_unpack() {
+ unpack ${A}
+ sed -i 's#/usr/local/bin#/usr/bin#' ${S}/expect.man
+ sed -i 's#/usr/local/bin#/usr/bin#' ${S}/expectk.man
+ #stops any example scripts being installed by default
+ sed -i '/^install:/s/install-libraries //' ${S}/Makefile.in
+ sed -i 's/^SCRIPTS_MANPAGES = /_&/' ${S}/Makefile.in
+}
+
+src_compile() {
+ use amd64 && gnuconfig_update
+ use ppc64 && gnuconfig_update
+
+ local myconf
+ local tclv
+ local tkv
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ #tkv isn't really needed, included for symmetry and the future
+ #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+
+ #configure needs to find the files tclConfig.sh and tclInt.h
+ myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl${tclv}/include/generic"
+
+ if use X; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=/usr/lib"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make install INSTALL_ROOT=${D} || die "make install failed"
+
+ dodoc ChangeLog FAQ HISTORY NEWS README
+
+ local static_lib="lib${NON_MICRO_V/-/}.a"
+ rm ${D}/usr/lib/${NON_MICRO_V/-/}/${static_lib}
+
+ #install examples if 'doc' is set
+ if use doc; then
+ docinto examples
+ local scripts=$(make -qp | \
+ sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
+ exeinto /usr/share/doc/${PF}/examples
+ doexe ${scripts}
+ local scripts_manpages=$(make -qp | \
+ sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
+ for m in ${scripts_manpages}; do
+ dodoc example/${m}.man
+ done
+ dodoc example/README
+ fi
+
+}
diff --git a/dev-tcltk/expect/files/digest-expect-5.37.1-r2 b/dev-tcltk/expect/files/digest-expect-5.37.1-r2
new file mode 100644
index 000000000000..6543a4578374
--- /dev/null
+++ b/dev-tcltk/expect/files/digest-expect-5.37.1-r2
@@ -0,0 +1 @@
+MD5 d570837b6dc6311036d7bdeab19f0e03 expect-5.37.1.tar.gz 517284
diff --git a/dev-tcltk/expect/files/digest-expect-5.40.0-r1 b/dev-tcltk/expect/files/digest-expect-5.40.0-r1
new file mode 100644
index 000000000000..8d44a97c4e78
--- /dev/null
+++ b/dev-tcltk/expect/files/digest-expect-5.40.0-r1
@@ -0,0 +1 @@
+MD5 6ae1b87c9af993a69b901b6e52962c18 expect-5.40.0.tar.gz 521414