summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-21 17:18:15 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-21 17:18:15 +0000
commita5e8760b8b4d6836123d3698a989793d674229b8 (patch)
tree93d4905f025b97e7eeed20aacde9722713a6de43 /dev-tcltk
parentMarked stable for amd64 wrt bug #453106 (diff)
downloadgentoo-2-a5e8760b8b4d6836123d3698a989793d674229b8.tar.gz
gentoo-2-a5e8760b8b4d6836123d3698a989793d674229b8.tar.bz2
gentoo-2-a5e8760b8b4d6836123d3698a989793d674229b8.zip
dev-tcltk/tix: Add fix tcl-8.6, #453370
(Portage version: 2.2.0_alpha158/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tix/ChangeLog8
-rw-r--r--dev-tcltk/tix/files/tix-8.4.3-tcl8.6.patch18
-rw-r--r--dev-tcltk/tix/tix-8.4.3.ebuild5
3 files changed, 27 insertions, 4 deletions
diff --git a/dev-tcltk/tix/ChangeLog b/dev-tcltk/tix/ChangeLog
index 18b2a591b0ca..e438120666da 100644
--- a/dev-tcltk/tix/ChangeLog
+++ b/dev-tcltk/tix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/tix
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/ChangeLog,v 1.40 2012/12/13 07:31:34 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/ChangeLog,v 1.41 2013/01/21 17:18:15 jlec Exp $
+
+ 21 Jan 2013; Justin Lecher <jlec@gentoo.org> tix-8.4.3.ebuild,
+ +files/tix-8.4.3-tcl8.6.patch:
+ Add fix tcl-8.6, #453370
13 Dec 2012; Justin Lecher <jlec@gentoo.org> -files/tix-8.2.0-gentoo.diff,
-files/tix-8.4.2-tcl85.patch, tix-8.4.3.ebuild, +files/tix-8.4.3-link.patch,
diff --git a/dev-tcltk/tix/files/tix-8.4.3-tcl8.6.patch b/dev-tcltk/tix/files/tix-8.4.3-tcl8.6.patch
new file mode 100644
index 000000000000..98165a899591
--- /dev/null
+++ b/dev-tcltk/tix/files/tix-8.4.3-tcl8.6.patch
@@ -0,0 +1,18 @@
+ generic/tixGrSort.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/generic/tixGrSort.c b/generic/tixGrSort.c
+index 7dee30f..26ec054 100644
+--- a/generic/tixGrSort.c
++++ b/generic/tixGrSort.c
+@@ -447,8 +447,8 @@ SortCompareProc(first, second)
+ * Parse the result of the command.
+ */
+
+- order = strtol(sortInterp->result, &end, 0);
+- if ((end == sortInterp->result) || (*end != 0)) {
++ order = strtol(Tcl_GetResult(sortInterp), &end, 0);
++ if ((end == Tcl_GetResult(sortInterp)) || (*end != 0)) {
+ Tcl_ResetResult(sortInterp);
+ Tcl_AppendResult(sortInterp,
+ "comparison command returned non-numeric result",
diff --git a/dev-tcltk/tix/tix-8.4.3.ebuild b/dev-tcltk/tix/tix-8.4.3.ebuild
index 76e50688c03a..9da0f794fc69 100644
--- a/dev-tcltk/tix/tix-8.4.3.ebuild
+++ b/dev-tcltk/tix/tix-8.4.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/tix-8.4.3.ebuild,v 1.14 2012/12/13 07:31:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/tix-8.4.3.ebuild,v 1.15 2013/01/21 17:18:15 jlec Exp $
EAPI=5
@@ -33,6 +33,7 @@ src_prepare() {
sed \
-e 's:-Os::g' \
-i configure tclconfig/tcl.m4 || die
+ epatch "${FILESDIR}"/${P}-tcl8.6.patch
}
src_configure() {