summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-14 15:46:06 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-14 15:46:06 +0000
commit979df723c17d0bb958326675a0602d210643872d (patch)
treed67b16e99d52e15d1a49a26f1a105ebb7c8fd495 /dev-scheme/gambit
parentUpdated hardened powerpc profiles, bug #344861 (diff)
downloadgentoo-2-979df723c17d0bb958326675a0602d210643872d.tar.gz
gentoo-2-979df723c17d0bb958326675a0602d210643872d.tar.bz2
gentoo-2-979df723c17d0bb958326675a0602d210643872d.zip
Imported prefix changes
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog10
-rw-r--r--dev-scheme/gambit/files/gambit-4.4.0-install_name.patch11
-rw-r--r--dev-scheme/gambit/gambit-4.5.3-r1.ebuild62
3 files changed, 81 insertions, 2 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index ce573e01fe04..36ea0917d5bc 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-scheme/gambit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.29 2009/11/02 15:09:06 hkbst Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.30 2010/11/14 15:46:06 jlec Exp $
+
+*gambit-4.5.3-r1 (14 Nov 2010)
+
+ 14 Nov 2010; Justin Lecher <jlec@gentoo.org>
+ +files/gambit-4.4.0-install_name.patch, +gambit-4.5.3-r1.ebuild:
+ Imported prefix changes
*gambit-4.5.3 (02 Nov 2009)
diff --git a/dev-scheme/gambit/files/gambit-4.4.0-install_name.patch b/dev-scheme/gambit/files/gambit-4.4.0-install_name.patch
new file mode 100644
index 000000000000..a40c83746b06
--- /dev/null
+++ b/dev-scheme/gambit/files/gambit-4.4.0-install_name.patch
@@ -0,0 +1,11 @@
+--- configure.ac
++++ configure.ac
+@@ -890,7 +890,7 @@
+
+ darwin*) # check for special options added by Apple
+ FLAGS_DYN="$FLAGS_DYN$DASH_bundle$DASH_flat_namespace_undefined_suppress"
+- FLAGS_LIB="$FLAGS_LIB$DASH_dynamiclib$DASH_flat_namespace_undefined_suppress"
++ FLAGS_LIB="$FLAGS_LIB$DASH_dynamiclib$DASH_flat_namespace_undefined_suppress -install_name \$(libdir)/\$(LIBRARY)"
+ ;;
+
+ *) # for other systems
diff --git a/dev-scheme/gambit/gambit-4.5.3-r1.ebuild b/dev-scheme/gambit/gambit-4.5.3-r1.ebuild
new file mode 100644
index 000000000000..2fa6ecee0d36
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.5.3-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.5.3-r1.ebuild,v 1.1 2010/11/14 15:46:06 jlec Exp $
+
+EAPI="3"
+
+inherit eutils elisp-common autotools
+
+MY_PN=gambc
+MY_PV=${PV//./_}
+MY_P=${MY_PN}-v${MY_PV}
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+#gsc is now Gambit Scheme Compiler and not ghostscript.
+#only app-text/ghostscript-gpl-8.64 has freed gsc yet.
+DEPEND="emacs? ( virtual/emacs )
+ !app-text/ghostscript-gnu
+ !<app-text/ghostscript-gpl-8.64"
+RDEPEND=""
+
+SITEFILE="50gambit-gentoo.el"
+
+S=${WORKDIR}/${MY_P} #-devel
+
+IUSE="emacs static"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.4.0-install_name.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable !static shared) --docdir="${EPREFIX}"/usr/share/doc/${PF} --enable-single-host --disable-absolute-shared-libs
+
+ emake bootstrap || die
+
+ if use emacs; then
+ elisp-compile misc/*.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}