summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-12-29 23:57:31 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-12-29 23:57:31 +0000
commit1f3b8016c487eb64caefa02fda714f0e2d4b0788 (patch)
tree2382c7cbb3c74d30b924d9badaed2aeafadeb144 /dev-scheme/gambit
parentVersion bump, has Intel i7 stuff. (diff)
downloadgentoo-2-1f3b8016c487eb64caefa02fda714f0e2d4b0788.tar.gz
gentoo-2-1f3b8016c487eb64caefa02fda714f0e2d4b0788.tar.bz2
gentoo-2-1f3b8016c487eb64caefa02fda714f0e2d4b0788.zip
bump
(Portage version: 2.1.6.2/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog7
-rw-r--r--dev-scheme/gambit/gambit-4.4.0.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index 064e84bebddb..feb2ef21e1ad 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.18 2008/08/28 17:41:15 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.19 2008/12/29 23:57:31 hkbst Exp $
+
+*gambit-4.4.0 (29 Dec 2008)
+
+ 29 Dec 2008; Marijn Schouten <hkBst@gentoo.org> +gambit-4.4.0.ebuild:
+ bump
28 Aug 2008; Ulrich Mueller <ulm@gentoo.org> files/50gambit-gentoo.el,
gambit-4.0_beta22.ebuild, gambit-4.0.0.ebuild, gambit-4.0.1.ebuild,
diff --git a/dev-scheme/gambit/gambit-4.4.0.ebuild b/dev-scheme/gambit/gambit-4.4.0.ebuild
new file mode 100644
index 000000000000..e6e6da01a4e2
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.4.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.0.ebuild,v 1.1 2008/12/29 23:57:31 hkbst Exp $
+
+inherit eutils elisp-common check-reqs autotools multilib
+
+MY_PN=gambc
+MY_PV=${PV//./_}
+MY_P=${MY_PN}-v${MY_PV}
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="emacs? ( virtual/emacs )"
+
+SITEFILE="50gambit-gentoo.el"
+
+S=${WORKDIR}/${MY_P} #-devel
+
+IUSE="big-iron emacs static"
+
+pkg_setup() {
+ if use big-iron; then
+ ewarn "compiling each Scheme module as a single C function"
+ ewarn "using gcc specific optimizations"
+ ewarn "approximately 2GB ram will be needed instead of 0.5GB"
+ ewarn "this will cause heavy thrashing of your system"
+ ewarn "and may cause your compiler to crash when it runs out of memory"
+ ewarn "unless your system is BIG IRON"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="2560" check_reqs
+ else
+ ewarn "NOT compiling each Scheme module as a single C function"
+ ewarn "NOT using gcc specific optimizations"
+ ewarn "approximately 0.5GB ram will be needed"
+ ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="768" check_reqs
+ fi
+}
+
+src_compile() {
+ econf $(use_enable !static shared) $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts) --disable-absolute-shared-libs
+
+ emake bootstrap || die
+
+ if use emacs; then
+ elisp-compile misc/*.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
+ mv "${D}"/usr/bin/gsc "${D}"/usr/bin/gsc-gambit
+}
+
+_src_install(){
+ rm "${D}"/usr/current
+
+ mv "${D}"/usr/syntax-case.scm "${D}"/usr/$(get_libdir)
+
+
+ # remove emacs/site-lisp/gambit.el
+ rm -r "${D}"/usr/share/emacs
+ if use emacs; then
+ elisp-install ${PN} misc/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ dodoc INSTALL.txt README
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # create some more explicit names
+ dosym gsc-gambit usr/bin/gambit-compiler
+ dosym gsi usr/bin/gambit-interpreter
+
+ echo "GAMBCOPT=\"=/usr/\"" > "${T}"/50gambit && doenvd "${T}"/50gambit
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}