summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-13 07:28:52 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-13 07:28:52 +0000
commitfc26db3dbd0b0e4aeb191f1e02fbcc854c22d26e (patch)
tree1582d0d4b14208a9d4401f2d651a5d2f0cdfc9d3 /dev-ruby
parentPopulate depends and setting the proper permissions on the scripts being inst... (diff)
downloadgentoo-2-fc26db3dbd0b0e4aeb191f1e02fbcc854c22d26e.tar.gz
gentoo-2-fc26db3dbd0b0e4aeb191f1e02fbcc854c22d26e.tar.bz2
gentoo-2-fc26db3dbd0b0e4aeb191f1e02fbcc854c22d26e.zip
Convert to ruby-ng.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/cgikit/ChangeLog7
-rw-r--r--dev-ruby/cgikit/cgikit-1.2.1-r1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/cgikit/ChangeLog b/dev-ruby/cgikit/ChangeLog
index 79c565137944..987142e9f139 100644
--- a/dev-ruby/cgikit/ChangeLog
+++ b/dev-ruby/cgikit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/cgikit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/cgikit/ChangeLog,v 1.16 2010/05/22 15:05:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/cgikit/ChangeLog,v 1.17 2010/06/13 07:28:52 graaff Exp $
+
+*cgikit-1.2.1-r1 (13 Jun 2010)
+
+ 13 Jun 2010; Hans de Graaff <graaff@gentoo.org> +cgikit-1.2.1-r1.ebuild:
+ Convert to ruby-ng.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> cgikit-1.2.1.ebuild:
Various cleanups.
diff --git a/dev-ruby/cgikit/cgikit-1.2.1-r1.ebuild b/dev-ruby/cgikit/cgikit-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..54cf5d836b32
--- /dev/null
+++ b/dev-ruby/cgikit/cgikit-1.2.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/cgikit/cgikit-1.2.1-r1.ebuild,v 1.1 2010/06/13 07:28:52 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+DESCRIPTION="CGIKit is a web application framework written in Ruby. The architecture is similar to WebObjects"
+HOMEPAGE="http://www.spice-of-life.net/cgikit/index_en.html"
+SRC_URI="http://www.spice-of-life.net/cgikit/archive/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+all_ruby_prepare() {
+ grep -rl --null '#!/usr/local/bin/ruby' "${S}" | xargs -0 \
+ sed -i -e 's:#!/usr/local/bin/ruby:#!/usr/bin/ruby:'
+}
+
+each_ruby_compile() {
+ ${RUBY} install.rb config || die
+}
+
+each_ruby_install() {
+ ${RUBY} install.rb install --prefix="${D}" || die
+}
+
+all_ruby_install() {
+ dodoc CHANGES CHANGES.ja README README.ja
+
+ insinto /usr/share/doc/${PF}
+ doins -r docs
+ doins -r examples
+}