summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-12-24 15:45:11 +0000
committerHans de Graaff <graaff@gentoo.org>2013-12-24 15:45:11 +0000
commite1089795af3f5b53b2bb96231c3f6bf2c7af2ca5 (patch)
tree5b034774b693c3dc9b14eee4f871e24aeb6b1e2c /dev-ruby
parentVersion bump for Gnome 3.10, drop old (diff)
downloadgentoo-2-e1089795af3f5b53b2bb96231c3f6bf2c7af2ca5.tar.gz
gentoo-2-e1089795af3f5b53b2bb96231c3f6bf2c7af2ca5.tar.bz2
gentoo-2-e1089795af3f5b53b2bb96231c3f6bf2c7af2ca5.zip
Add version compatible with and removed from Rails 4.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activeresource/ChangeLog7
-rw-r--r--dev-ruby/activeresource/activeresource-4.0.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index b78a8aa62dc7..1d584ff514d7 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.165 2013/12/16 20:10:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.166 2013/12/24 15:45:11 graaff Exp $
+
+*activeresource-4.0.0 (24 Dec 2013)
+
+ 24 Dec 2013; Hans de Graaff <graaff@gentoo.org> +activeresource-4.0.0.ebuild:
+ Add version compatible with and removed from Rails 4.
16 Dec 2013; Hans de Graaff <graaff@gentoo.org>
-activeresource-3.2.15.ebuild:
diff --git a/dev-ruby/activeresource/activeresource-4.0.0.ebuild b/dev-ruby/activeresource/activeresource-4.0.0.ebuild
new file mode 100644
index 000000000000..030446980939
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-4.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-4.0.0.ebuild,v 1.1 2013/12/24 15:45:11 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+#RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "=dev-ruby/activesupport-4*
+ =dev-ruby/activemodel-4*
+ >=dev-ruby/rails-observers-0.1.1:0.1"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm Gemfile || die "Unable to remove Gemfile"
+
+ # Pull in the correct version of minitest since we don't use bundler.
+ sed -i -e '1igem "minitest", "~>4.0"' test/abstract_unit.rb || die
+
+}