summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-21 05:51:55 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-21 05:51:55 +0000
commit056435032ad6b130f4a56e2132bc8a39817df234 (patch)
tree20d2bb54f8af8b8d9bc105b8a3699fd07d7b5b98 /dev-ruby
parentCleanup. (diff)
downloadgentoo-2-056435032ad6b130f4a56e2132bc8a39817df234.tar.gz
gentoo-2-056435032ad6b130f4a56e2132bc8a39817df234.tar.bz2
gentoo-2-056435032ad6b130f4a56e2132bc8a39817df234.zip
Version bump.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tzinfo/ChangeLog7
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.37.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index bd582018a3e5..9febd1ccf816 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.115 2013/04/21 05:48:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.116 2013/04/21 05:51:55 graaff Exp $
+
+*tzinfo-0.3.37 (21 Apr 2013)
+
+ 21 Apr 2013; Hans de Graaff <graaff@gentoo.org> +tzinfo-0.3.37.ebuild:
+ Version bump.
21 Apr 2013; Hans de Graaff <graaff@gentoo.org> -tzinfo-0.3.33.ebuild:
Cleanup.
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.37.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.37.ebuild
new file mode 100644
index 000000000000..6c391707d4ac
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.37.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.37.ebuild,v 1.1 2013/04/21 05:51:55 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}