summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 00:26:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 00:26:55 +0000
commitff8c96ea8dbf0d78270553de33d0175f6dbf687a (patch)
tree8d8c69917723d041c9db510ddf7692461598968e /dev-ruby/right_aws
parentdrop USE=gold and enable bfd/gold all the time (with bfd being the default) .... (diff)
downloadgentoo-2-ff8c96ea8dbf0d78270553de33d0175f6dbf687a.tar.gz
gentoo-2-ff8c96ea8dbf0d78270553de33d0175f6dbf687a.tar.bz2
gentoo-2-ff8c96ea8dbf0d78270553de33d0175f6dbf687a.zip
Initial import of RightScale AWS library.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/right_aws')
-rw-r--r--dev-ruby/right_aws/ChangeLog10
-rw-r--r--dev-ruby/right_aws/metadata.xml5
-rw-r--r--dev-ruby/right_aws/right_aws-1.10.0.ebuild38
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/right_aws/ChangeLog b/dev-ruby/right_aws/ChangeLog
new file mode 100644
index 000000000000..46ac795b2644
--- /dev/null
+++ b/dev-ruby/right_aws/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/right_aws
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_aws/ChangeLog,v 1.1 2010/01/28 00:26:55 flameeyes Exp $
+
+*right_aws-1.10.0 (28 Jan 2010)
+
+ 28 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +right_aws-1.10.0.ebuild, +metadata.xml:
+ Initial import of RightScale AWS library.
+
diff --git a/dev-ruby/right_aws/metadata.xml b/dev-ruby/right_aws/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/right_aws/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/right_aws/right_aws-1.10.0.ebuild b/dev-ruby/right_aws/right_aws-1.10.0.ebuild
new file mode 100644
index 000000000000..f8366575073d
--- /dev/null
+++ b/dev-ruby/right_aws/right_aws-1.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_aws/right_aws-1.10.0.ebuild,v 1.1 2010/01/28 00:26:55 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A robust, fast, and secure interface to Amazon EC2, EBS, S3, SQS, SDB, and CloudFront."
+HOMEPAGE="http://www.rightscale.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Tests require you to set up Amazon AWS access so we have no way to
+# handle this from within the ebuild :(
+RESTRICT="test"
+
+# uuidtools is just needed for sdb, but still better to add it to the
+# dependencies.
+# libxml is also optionally supported.
+ruby_add_rdepend '>=dev-ruby/right_http_connection-1.2.4 dev-ruby/uuidtools'
+
+all_ruby_prepare() {
+ # by default the Rakefile will require rcovtask from rcov to allow
+ # coverage testing; since we don't care about that we'll just be
+ # ignoring it for now.
+ sed -i \
+ -e '/rcovtask/s:^:#:' \
+ Rakefile || die
+}