summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-22 08:03:33 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-22 08:03:33 +0000
commit9ec9e3f2f54f0fb2fed520fa89e5e217f8b5d80a (patch)
tree17bc24c5d2ff416f4dae359eabfb4edba0b5e973 /dev-ruby/rake-compiler
parentRemove old versions. (diff)
downloadgentoo-2-9ec9e3f2f54f0fb2fed520fa89e5e217f8b5d80a.tar.gz
gentoo-2-9ec9e3f2f54f0fb2fed520fa89e5e217f8b5d80a.tar.bz2
gentoo-2-9ec9e3f2f54f0fb2fed520fa89e5e217f8b5d80a.zip
Remove old versions.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rake-compiler')
-rw-r--r--dev-ruby/rake-compiler/ChangeLog6
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.7.9.ebuild61
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.8.0.ebuild61
3 files changed, 5 insertions, 123 deletions
diff --git a/dev-ruby/rake-compiler/ChangeLog b/dev-ruby/rake-compiler/ChangeLog
index 01d1ccc6f801..3b26c70aba8b 100644
--- a/dev-ruby/rake-compiler/ChangeLog
+++ b/dev-ruby/rake-compiler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rake-compiler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.46 2012/05/20 06:32:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.47 2012/06/22 08:03:33 graaff Exp $
+
+ 22 Jun 2012; Hans de Graaff <graaff@gentoo.org> -rake-compiler-0.7.9.ebuild,
+ -rake-compiler-0.8.0.ebuild:
+ Remove old versions.
*rake-compiler-0.8.1 (20 May 2012)
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.7.9.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.7.9.ebuild
deleted file mode 100644
index d061e3fe2d7c..000000000000
--- a/dev-ruby/rake-compiler/rake-compiler-0.7.9.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.7.9.ebuild,v 1.2 2011/12/31 18:50:20 grobian Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-# Tests for now seem only to work when rubygems is fully installed for
-# the implementation and that for now only means Ruby 1.8
-RUBY_FAKEGEM_TASK_TEST="-f tasks/rspec.rake -f tasks/cucumber.rake spec cucumber"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
-HOMEPAGE="http://github.com/luislavena/rake-compiler"
-LICENSE="as-is" # truly
-
-SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
-RUBY_S="luislavena-${PN}-*"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-USE_RUBY=ruby18 \
- ruby_add_bdepend "test? ( dev-util/cucumber )"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/rubygems )"
-ruby_add_rdepend "dev-ruby/rake"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19|*jruby)
- # Remove this task so that it won't load on Ruby 1.9 and JRuby
- # that lack the package_task file. It is, though, needed for the
- # tests
- rm tasks/gem.rake || die
- # Remove specs aimed at a C-compiling ruby implementation.
- rm spec/lib/rake/extensiontask_spec.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby19)
- ${RUBY} -S rspec spec || die "Tests failed."
- ;;
- *jruby)
- ${RUBY} -S rspec spec || die "Tests failed."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.8.0.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.8.0.ebuild
deleted file mode 100644
index b6610673526d..000000000000
--- a/dev-ruby/rake-compiler/rake-compiler-0.8.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.8.0.ebuild,v 1.2 2012/04/23 18:02:52 aballier Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-# Tests for now seem only to work when rubygems is fully installed for
-# the implementation and that for now only means Ruby 1.8
-RUBY_FAKEGEM_TASK_TEST="-f tasks/rspec.rake -f tasks/cucumber.rake spec cucumber"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
-HOMEPAGE="http://github.com/luislavena/rake-compiler"
-LICENSE="as-is" # truly
-
-SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
-RUBY_S="luislavena-${PN}-*"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-USE_RUBY="ruby18 ree18" \
- ruby_add_bdepend "test? ( dev-util/cucumber )"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/rubygems )"
-ruby_add_rdepend "dev-ruby/rake"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19|*jruby)
- # Remove this task so that it won't load on Ruby 1.9 and JRuby
- # that lack the package_task file. It is, though, needed for the
- # tests
- rm tasks/gem.rake || die
- # Remove specs aimed at a C-compiling ruby implementation.
- rm spec/lib/rake/extensiontask_spec.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby19)
- ${RUBY} -S rspec spec || die "Tests failed."
- ;;
- *jruby)
- ${RUBY} -S rspec spec || die "Tests failed."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}