summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-05 11:33:25 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-05 11:33:25 +0000
commit77901d0a0febcac28ae24e9b4064de89a5ca6aa9 (patch)
tree70fe38b6cc7721e19da1b2266615ac351a35115b /dev-ruby/ascii85
parentAdd ruby20 target. (diff)
downloadgentoo-2-77901d0a0febcac28ae24e9b4064de89a5ca6aa9.tar.gz
gentoo-2-77901d0a0febcac28ae24e9b4064de89a5ca6aa9.tar.bz2
gentoo-2-77901d0a0febcac28ae24e9b4064de89a5ca6aa9.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ascii85')
-rw-r--r--dev-ruby/ascii85/ChangeLog7
-rw-r--r--dev-ruby/ascii85/ascii85-1.0.2-r1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/ascii85/ChangeLog b/dev-ruby/ascii85/ChangeLog
index da097b74764b..4450734ad339 100644
--- a/dev-ruby/ascii85/ChangeLog
+++ b/dev-ruby/ascii85/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ascii85
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ascii85/ChangeLog,v 1.18 2013/09/04 12:40:13 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ascii85/ChangeLog,v 1.19 2013/10/05 11:33:25 mrueg Exp $
+
+*ascii85-1.0.2-r1 (05 Oct 2013)
+
+ 05 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +ascii85-1.0.2-r1.ebuild:
+ Add ruby20 target.
04 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -ascii85-1.0.1.ebuild:
Cleanup old.
diff --git a/dev-ruby/ascii85/ascii85-1.0.2-r1.ebuild b/dev-ruby/ascii85/ascii85-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..277d2804c9a6
--- /dev/null
+++ b/dev-ruby/ascii85/ascii85-1.0.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ascii85/ascii85-1.0.2-r1.ebuild,v 1.1 2013/10/05 11:33:25 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.txt"
+
+RUBY_FAKEGEM_NAME="Ascii85"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Methods for encoding/decoding Adobe's binary-to-text encoding of the same name."
+HOMEPAGE="http://ascii85.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}